You are here: Home » Topic » Yet another FireFly Client (SilverPlay)page 4

Yet another FireFly Client (SilverPlay)

This topic contains 50 replies, has 13 voices, and was last updated by  Anonymous 8 years, 8 months ago.

Viewing 6 posts - 46 through 51 (of 51 total)
  • Author
    Posts
  • #18376

    lyrikles
    Participant

    Hi, I’ve been messing with SilverPlay for a couple hours trying to get it to work, repeatedly getting a pop-up window just like wwaren:
    @wwarren wrote:

    I get the main page structure, but then an error pops up. Any idea what this error means? “[Async_ExceptionOccurred] Debugging resource strings are unavailable. Often the key and arguments provide sufficient”.
    [attachment=0:1g2g35bu]2009-01-08_232707.png[/attachment:1g2g35bu]
    The suggestion from the readme to check connectivity using http://yourserver:3689/server-info?output=xml yields positive results.

    I enabled debug mode and I noticed this:

    Connect to:http://localhost:3689//server-info?output=xmlx

    there’s double “/” before “server-info”. What can I change to make it look for: http://localhost:3689/server-info?output=xmlx instead?
    Thanks, Erik

    #18377

    Anonymous

    Hi
    Assuming you are running it on an IIS server 🙂
    I uploaded a XAP file onto my webserver.
    http://www.nystedberry.info/silverplay/SilverPlay.xap
    Can you download that and replace the one in your current installation with the one on the webserver?
    It is located in the ClientBin directory where you installed SilverPlay.

    #18378

    lyrikles
    Participant

    I’m actually running Silverplay on Freenas(Freebsd) running lighttpd. I downloaded the XAP file and replaced my XAP file (which was actually larger @ 1,098KB vs. 936KB). It fixed the “//” issue, but I’m still getting the same errors. I get a box that pops up with the following message:

       at System.ComponentModel.AsyncCompletedEventArgs.RaiseExceptionIfNecessary()
    at System.Net.DownloadStringCompletedEventArgs.get_Result()
    at FireFlyConnector.FireflyConnector.ConnectedResponseCompleted(Object sender, DownloadStringCompletedEventArgs e)
    InnerException:

    and in the debug window, I get the error:

    ConnectedResponseCompleted Exception: [Async_ExceptionOccurred]

    I’m able to get output when visiting http://firefly_server_ip:3689/server-info?output=xmlx and I’m pretty sure the parameters are correct:

    Any other Ideas?

    #18379

    Anonymous

    Is your firefly library available from the internet?
    If that is the case I could try to debug it from here. Seems a little wired.
    Unfortunately did the Admin disable private messaging on the board. But you can contact me on [email protected] if that would be a solution for you?

    But one more test before that we do that. Did you place the clientaccesspolicy.xml file in the root of your webapp.
    In linux you might have to rename that to lowercase as it’s case sensitive.

    #18381

    Anonymous

    Hi

    Hi all

    I have a netgear Readynas duo, running their packaged firefly -mt-daapd, svn-1676. Itunes clients work quite nicely off it. I’d like SilverPlay working too.

    But, when I run
    http://readynasip:3689/SilverPlay.html
    I get a 404 not found.

    when I run
    http://readynasip/server-info?output=xmlx I get the below:


    200
    2.0.0
    3.0.0
    1800
    TEXCOM_Itunes_Server
    2
    0
    0
    0
    0
    0
    1

    The thing is, I cant get SilverPlay or FlashPlay to work. The readynas directory structure is somewhat different to that I’ve seen previously on a NSLU2, but I think I have the firely and silverlight files in the right place.

    But back to Silverlight: ALL the silverlight files I have dropped into the webroot folder (/c/webroot). All I then get is 404 not found. Is it possible I havent set the permissions right, or even that the readynas’s firefly package just wont ever work with such plug-ins? how can I tell if it handles the right Roku protocols etc? I cant see that in the output above. I had no real issues on the NSLU2 but this has stumped me!

    thanks in advance

    iain

    #18382

    Anonymous

    Can someone please post a mirror to the file. The link:

    http://www.nystedberry.info/silverplay/SilverPlay.zip

    Is not working anymore.

    Thank you.

Viewing 6 posts - 46 through 51 (of 51 total)

The forum ‘Add-on Software’ is closed to new topics and replies.