You are here: Home » Topic » Workaround Bonjour: Unknown error: 0

Workaround Bonjour: Unknown error: 0

This topic contains 2 replies, has 2 voices, and was last updated by  Miles 10 years, 6 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #1215

    Miles
    Participant

    Firefly: clean install of 0.2.4
    Platform: Mac OS X server (Dual G4).

    Install seems to go fine (exactly as it did any other time I have intalled Firefly/mt-daapd) but when I try to start the server, I get the following error: “Workaround Bonjour: Unknown error: 0”

    Of course the server then doesn’t show up for any client computer. Anybody seen this before? Is this something that is fixed in the nightlies?

    Thanks,

    Miles

    #9711

    rpedde
    Participant

    @miles wrote:

    Firefly: clean install of 0.2.4
    Platform: Mac OS X server (Dual G4).

    Install seems to go fine (exactly as it did any other time I have intalled Firefly/mt-daapd) but when I try to start the server, I get the following error: “Workaround Bonjour: Unknown error: 0”

    Of course the server then doesn’t show up for any client computer. Anybody seen this before? Is this something that is fixed in the nightlies?

    Thanks,

    Miles

    I’ve never seen this before… google seems to think it’s an apple bug introduced in 10.4.7 (and 10.4.8), but I can’t get a description of what it *is*.

    Are you running it from launchd?

    If so, try running it with -m, and setting up the launchd plist to advertise bonjour itself. Maybe that’s what’s ticking it off.

    — Ron

    #9712

    Miles
    Participant

    I was using launchd to start the server but after messing around with all the options I could think of, I switched to a StartupItems script. When I started the server from there, I got much clearer error messages and was able to debug my problem (which turned out to be relatively simple). I’m not sure if I want to bother moving the startup item back into launchd, or if I’ll just leave it where it is since it works.

    Thanks,

    Miles

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.