You are here: Home » Topic » Windows iTunes 7 can’t see the firefly library (kubuntu can)

Windows iTunes 7 can’t see the firefly library (kubuntu can)

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues Windows iTunes 7 can’t see the firefly library (kubuntu can)

This topic contains 12 replies, has 3 voices, and was last updated by  rpedde 11 years, 5 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #964

    yogomozilla
    Participant

    Hi

    Have mt-daapd running from debs on a kubuntu edgy box. It works fine and I can access the music share via Amarok on my Kubuntu Edgy laptop.

    On an XP laptop I can access the mt-daapd page via http://192.168…..:3689 (being the ip address of the Kubuntu box holding the music) but Itunes 7.02 won’t pick up the “shared library”.
    I have “look for shared libraries” configured as on in the preferences but their don’t seem to be any further preferences.

    I have turned all Windows firewalls off to see if that was the prob but no luck there…

    Is there anything else I need to do for Windows Itunes latest version so that it can play the music?

    Cheers
    James

    #8256

    rpedde
    Participant

    @yogomozilla wrote:

    Is there anything else I need to do for Windows Itunes latest version so that it can play the music?

    If you are using the deb package for “sarge” on the sourceforge download page, it doesn’t work on edgy. You’ll have to use a nightlies build, which has edgy packages.

    http://nightlies.mt-daapd.org

    You’ll want to uninstall your existing package first, then remove the config file.

    — Ron

    #8257

    yogomozilla
    Participant

    Hi Ron

    Thanks for your reply.. I notice there are debs just for Dapper but none for Edgy. Which one is the right one for an Edgy install?

    #8258

    rpedde
    Participant

    @yogomozilla wrote:

    Hi Ron

    Thanks for your reply.. I notice there are debs just for Dapper but none for Edgy. Which one is the right one for an Edgy install?

    Eek. I don’t have an edgy, because The Right Way to do the package for edgy compiles it for avahi. I need to update my build scripts so that they compile for avahi.

    Tell you what. I’ll try to get that done tonight and drop a new nightly for edgy with avahi.

    — Ron

    #8259

    yogomozilla
    Participant

    @rpedde wrote:

    Tell you what. I’ll try to get that done tonight and drop a new nightly for edgy with avahi.

    — Ron

    Hi Ron

    Thanks for package! I tried the edgy deb and it works ok for my edgy laptop (client) but the XP box running itunes 7 still doesn’t pick up the share.

    I started mt-daapd in verbose mode and can see the following:


    2007-02-03 20:06:16 (b7d228c0): Unicast Response: 0 Questions, 1 Answer, 3 Additionals to 192.168.0.107 :5353 on 08097B98/4
    2007-02-03 20:06:16 (b7d228c0): AddRecordToResponseList: _daap._tcp.local. (PTR) already in list
    2007-02-03 20:06:16 (b7d228c0): AddRecordToResponseList: Firefly svn-1498 on wakame._daap._tcp.local. (SRV) already in list
    2007-02-03 20:06:16 (b7d228c0): AddRecordToResponseList: Firefly svn-1498 on wakame._daap._tcp.local. (TXT) already in list
    2007-02-03 20:06:16 (b7d228c0): AddRecordToResponseList: wakame-2.local. (Addr) already in list

    192.168.0.107 is the IP of the XP box so the daap server can see this but itunes isn’t picking up the share. The web interface says that Bonjour is “stopped”.

    I’ve turned off all firewalls on the XP box.

    I noticed I have a wakame.local and wakame-2.local – could this be the problem? something conflicting. wakame is the name of the daap server box.

    I can stream a file from my Amarok client and get the following in the log:


    2007-02-03 20:12:51 (b74d8ba0): Thread 5: could not read: No such file or directory
    2007-02-03 20:12:59 (b74d8ba0): Session 0: Streaming file '12 - Vagabond.mp3' to 192.168.0.172 (offset 0)

    any suggestions?

    edit–
    + the XP laptop can get to the mt-daapd web interface on port 3689

    #8260

    rpedde
    Participant

    @yogomozilla wrote:

    [
    any suggestions?

    edit–
    + the XP laptop can get to the mt-daapd web interface on port 3689

    Here’s a dumb one, but worth checking… do you have the “Search for shared libraries” thing checked in your iTunes preferences?

    #8261

    yogomozilla
    Participant

    yeah, i turned it on and off a couple of times to see if I could trigger something. Apple don’t seem big on diagnostics..

    #8262

    sbkp
    Participant

    I’m having similar trouble — it actually happens whether I’m using iTunes (version 6 or 7) or mt-daapd or firefly.

    The iTunes server is a G4 Mac mini. OS-X 10.4.9.

    In my case, if I launch iTunes on my Windows PC when iTunes or Firefly is already running on the Mac, the client won’t see the share. If I restart iTunes/Firefly on the Mac, then the share will appear on the client. It will eventually disappear, though I haven’t figured out what makes that happen.

    I also have a Roku M2000. That can see the share, but can’t connect to it. Sometimes it will connect after I restart iTunes/Firefly, but never more than once.

    Thanks in advance.

    #8263

    rpedde
    Participant

    @sbkp wrote:

    I’m having similar trouble — it actually happens whether I’m using iTunes (version 6 or 7) or mt-daapd or firefly.

    The iTunes server is a G4 Mac mini. OS-X 10.4.9.

    In my case, if I launch iTunes on my Windows PC when iTunes or Firefly is already running on the Mac, the client won’t see the share. If I restart iTunes/Firefly on the Mac, then the share will appear on the client. It will eventually disappear, though I haven’t figured out what makes that happen.

    I also have a Roku M2000. That can see the share, but can’t connect to it. Sometimes it will connect after I restart iTunes/Firefly, but never more than once.

    Thanks in advance.

    Did you try turning off the firewall on the mini? It sounds like a firewall issue.

    #8264

    sbkp
    Participant

    The firewall is off — what makes it not (seem like) a firewall issue is that it works, and then it doesn’t.

    Now, I seem to have sorted it by upgrading the firmware on my router. I found a reference somewhere that IGMP should be disabled. I couldn’t find any way to do that on my router, so I found new firmware, and there on the main admin page: IGMP Enabled/Disabled.

    The reason I’m not celebrating just yet is that the problem has been intermittent at times. But so far so good (fingers crossed, knock wood, etc).

    Thanks.

    #8265

    rpedde
    Participant

    @sbkp wrote:

    The firewall is off — what makes it not (seem like) a firewall issue is that it works, and then it doesn’t.

    Now, I seem to have sorted it by upgrading the firmware on my router. I found a reference somewhere that IGMP should be disabled. I couldn’t find any way to do that on my router, so I found new firmware, and there on the main admin page: IGMP Enabled/Disabled.

    The reason I’m not celebrating just yet is that the problem has been intermittent at times. But so far so good (fingers crossed, knock wood, etc).

    Thanks.

    Actually, should have iGMP enabled.

    — Ron

    #8266

    yogomozilla
    Participant

    Ron, just updated to svn 1586 and the bug (whatever it was) is fixed (was running svn 1498) – am using the edgy .deb on a feisty box.

    Not sure what changed to make it work so I’m no help there. It even works with the XP (za) firewall on..

    Thanks!

    #8267

    rpedde
    Participant

    @yogomozilla wrote:

    Ron, just updated to svn 1586 and the bug (whatever it was) is fixed (was running svn 1498) – am using the edgy .deb on a feisty box.

    Not sure what changed to make it work so I’m no help there. It even works with the XP (za) firewall on..

    Thanks!

    One change was the upgrade to a newer version of apple’s mDNS code. Might have been it.

    — Ron

Viewing 13 posts - 1 through 13 (of 13 total)

The forum ‘Setup Issues’ is closed to new topics and replies.