You are here: Home » Topic » Where is ssc-script.so ?

Where is ssc-script.so ?

This topic contains 9 replies, has 3 voices, and was last updated by  rpedde 10 years, 8 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #823

    Breepee
    Participant

    I tried installing mt-daapd with transcoding all morning, first the latest official release as deb, then compiled it myself with the proper flags, then SVN1441, but still no succes.

    I think I need the file ssc-script.so with the latest SVN release (1441), but where is it? I need to point to it in the config.

    Thanks!

    #7546

    rpedde
    Participant

    @breepee wrote:

    I tried installing mt-daapd with transcoding all morning, first the latest official release as deb, then compiled it myself with the proper flags, then SVN1441, but still no succes.

    I think I need the file ssc-script.so with the latest SVN release (1441), but where is it? I need to point to it in the config.

    Thanks!

    dpkg -L mt-daapd

    … but I’d guess /usr/share/mt-daapd/plugins. Might just use the contrib config. If you’ve upgraded from an old version, your config is likely well out of date.

    — Ron

    #7547

    Breepee
    Participant

    I downloaded the tar and there is the .c included but after compiling I can’t find the .so anywhere, I searched the whole system and in the probable places.

    #7548

    fizze
    Participant

    well are you sure you compiled with the correct options?

    its –enable-ssc or so, iirc 😉

    #7549

    rpedde
    Participant

    @breepee wrote:

    I downloaded the tar and there is the .c included but after compiling I can’t find the .so anywhere, I searched the whole system and in the probable places.

    after you compile it gets stuck in src/plugins/.libs, and gets installed to $pkgdatadir/plugins, which is arguably wrong, but is either /usr/share/mt-daapd/plugins or /usr/local/share/mt-daapd/plugins depending on the prefix you used.

    Did you do a make install, or just make and copy?

    #7550

    Breepee
    Participant

    configure, with flac, ogg and sqlite
    make
    make install

    but I didn’t do –enable-ssc, will this fix it?

    #7551

    Breepee
    Participant

    OK, I compiled it with –enable-ssc. Seems OK, the ssc-script.so is there now, but still the config file checks out bad. It is basically the original file, with the path to webadmin and the music corrected, server name and extensions (.mp3,.flac,.ogg) changed and these lines added at the end:

    plugin_dir = /usr/local/share/mt-daapd/plugins
    plugins = ssc-script.so
    ssc_prog /usr/local/sbin/mt-daapd-ssc.sh
    ssc_codectypes flac,ogg

    What’s wrong?

    #7552

    rpedde
    Participant

    @breepee wrote:

    OK, I compiled it with –enable-ssc. Seems OK, the ssc-script.so is there now, but still the config file checks out bad. It is basically the original file, with the path to webadmin and the music corrected, server name and extensions (.mp3,.flac,.ogg) changed and these lines added at the end:

    plugin_dir = /usr/local/share/mt-daapd/plugins
    plugins = ssc-script.so
    ssc_prog /usr/local/sbin/mt-daapd-ssc.sh
    ssc_codectypes flac,ogg

    What’s wrong?

    What does it say is wrong?

    the keys and values should generally be in

    x=y

    form in the new config format. The ssc* stuff goes in the [general] section, and the plugin stuff goes in the [plugin] section.

    Try using the template config, your config looks to be a 0.2.4 one, or use your old 0.2.4 one and add the plugin stuff via the web interface — that will upgrade your config to the new format.

    — Ron

    #7553

    Breepee
    Participant

    Using the ‘new’ template as a base fixed it all. Thanks for the help!

    Still a few problems: Ogg transcoding doesn’t work and some files aren’t detected while they should (mt-daapd found ~8500 tracks, while there are 10500 in the folder I pointed to). Any thoughts?

    #7554

    rpedde
    Participant

    @breepee wrote:

    Using the ‘new’ template as a base fixed it all. Thanks for the help!

    Still a few problems: Ogg transcoding doesn’t work and some files aren’t detected while they should (mt-daapd found ~8500 tracks, while there are 10500 in the folder I pointed to). Any thoughts?

    See if you can determine a file that isn’t in there. Once you find it take a close look at the file — it’s not in the library for one of two reasons. Either the extension isn’t in your extensions list, or because the permissions don’t allow the “runas” user to open it with read access.

    For ogg transcoding:

    1. Make sure you have oggdec installed
    2. Put a full path to oggdec in your ssc script (look at your config to find where the script it)
    3. Make sure you have “ogg” in you transcode codecs

    — Ron

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.