You are here: Home » Topic » Web interface & Firefox

Web interface & Firefox

  • This topic has 27 replies, 5 voices, and was last updated 14 years ago by Jxn.
Viewing 15 posts - 1 through 15 (of 28 total)
  • Author
    Posts
  • #625
    CCRDude
    Participant

    I finally have a NAS again and installed the latest Firefly nightly. The orange really gives the web interface a nice touch – if you see it at all! Because on Firefox, the interface is just displayed as, well… crap 😉

    #6557
    fizze
    Participant

    then your version of firefox is most likely horribly outdated 😉

    it sure renders nicely with my FF.

    #6558
    rpedde
    Participant

    @CCRDude wrote:

    I finally have a NAS again and installed the latest Firefly nightly. The orange really gives the web interface a nice touch – if you see it at all! Because on Firefox, the interface is just displayed as, well… crap 😉

    version/platform?

    #6559
    CCRDude
    Participant

    @fizze: if my Firefox is horribly outdated (1.5.0.7 and 2.0 beta 2, Win), I probably forgot to step into the time machine this morning 😛


    @rpedde
    : svn-1376 on Debian stable.

    edit: here’s a screenshot

    #6560
    fizze
    Participant

    *cough* javascript? *cough* 😉

    #6561
    CCRDude
    Participant

    Yes I know what Javascript is, and I remember that Ron was going in that ugly direction 😛 (though I see absoutely Zero sense in putting that much layout into JS) But Javascript is enabled of course, and even though I have NoScript, the server is explicitely allowed in Noscript. And the Firefox JavaScript Console does not show a single error.

    So what exactly did you wanted to tell me by coughing that word? 😉

    #6562
    [email protected]
    Participant

    Your web interface isn’t picking up the Javascripts or the CSS Styles for some reason.
    A Ctrl+F5 sorted mine out.

    The stylesheet and Javascripts are linked to from the included file hdr.html
    See: optsharemt-daapdadmin-root

    #6563
    CCRDude
    Participant

    I can refresh as often as I want without a change, I also cleared the complete cache.

    Well, maybe it’s time for a newer svn version…

    #6564
    [email protected]
    Participant

    AFAIK, svn-1376 is the latest.

    Have you tried re-starting the server?

    #6565
    rpedde
    Participant

    @CCRDude wrote:

    I can refresh as often as I want without a change, I also cleared the complete cache.

    Well, maybe it’s time for a newer svn version…

    that looks very strange. Like a cvs version pointing at a 0.2.4 web root, or a 0.2.4 server pointing at a cvs web root, or something crazy like that.

    Or maybe there are a whole bunch of files missing…

    did you do a regular compile/install, or did you use the debian/rules to build a package?

    #6566
    CCRDude
    Participant

    Update: server restarted, no change.

    The stylesheet is in it’s place, I can open it if I enter it’s address directly into the browser.

    Idea: 9 HTML warnings… if you use XHTML Strict, you should follow the standard, otherwise use HTML Transitional 😉 The complete HTML header is invalid due to the (null)s, so maybe that’s why Firefox, strictly following the rules, doesn’t load the stylesheet?

    I used the tarball with ./configure –enable-oggvorbis –enable-flac –enable-musepack –enable-sqlite. I had a 0.2.4 on the machine before that.

    BUT: If it was a version mismatch, why would it work when I access it through Internet Explorer? I tried Firefox on another machine as well – same problems (all Firefox installations so far had Adblock and NoScript, but those are really two of the most-used Firefox installations).

    I went and deleted the contents of /usr/local/share/mt-daapd/admin-root (where my mt-daapd.conf points to for the webroot), and copied the contents of mt-daapd-svn-1376/admin-root into that folder. I cleared the browser cache and accessed it again – same error.

    I then used chmod to root:root and chown to 555 on the whole admin-root folder (the permissions and owners from the tarball where quite mixed) – no change.

    I used locate smartpopup.html to see if any other directories exist (in case the webroot parameter wouldn’t be working) – that’s not the case.

    The only executable I found is /usr/local/sbin/mt-daapd. It’s really to bad it doesn’t show any version :-/ But the file date is September 7, so it’s the result of my SVN installation (config.status in the svn folder etc. have the same date).

    My final conclusion would be the (null)s in the header again:


    Firefly Media Server


    (null)
    (null)




    (null)
    (null)

    (null)
    (null)

    (null)
    (null)


    Looks very much like under some conditions, ispage is returning (null) instead of an empty line. And comparing that to the hdr.html, I found a possible explanation for that:
    * On the current page, the line is written, but cut too early, after character 62!
    * On other pages ispage, src-fields with a file in the same folder return an empty line, and
    * src-fields with a file in a subfolder return (null).

    #6567
    rpedde
    Participant

    @CCRDude wrote:

    Idea: 9 HTML warnings… if you use XHTML Strict, you should follow the standard, otherwise use HTML Transitional 😉

    I didn’t see that patch in my email? 😉

    The complete HTML header is invalid due to the (null)s, so maybe that’s why Firefox, strictly following the rules, doesn’t load the stylesheet?

    Very likely, but I didn’t know where the (null) was coming from, as I’ve never seen that behavior before.

    Looks very much like under some conditions, ispage is returning (null) instead of an empty line. And comparing that to the hdr.html, I found a possible explanation for that:
    * On the current page, the line is written, but cut too early, after character 62!
    * On other pages ispage, src-fields with a file in the same folder return an empty line, and
    * src-fields with a file in a subfolder return (null).

    That gives me something to go on. Thanks.

    — Ron

    #6568
    CCRDude
    Participant

    @rpedde wrote:

    I didn’t see that patch in my email? 😉

    Maybe because most errors are related to those (nulls) for now 😉

    Patch for hdr.html adding new style file, making script lines shorting by removing closing tag and adding terminating to end of opening tag instead, and removing invalid li:

    --- hdr.html	2006-07-06 06:42:30.000000000 +0200
    +++ hdr.html 2006-09-27 16:15:39.000000000 +0200
    @@ -4,22 +4,23 @@
    Firefly Media Server


    - @ispage index.html::@
    - @ispage index.html::@
    - @ispage index.html::@
    - @ispage index.html::@
    - @ispage config.html::@
    - @ispage config.html::@
    - @ispage config.html::@
    - @ispage config.html::@
    - @ispage smart.html::@
    - @ispage smart.html::@
    - @ispage smart.html::@
    - @ispage playlist.html::@
    - @ispage playlist.html::@
    - @ispage playlist.html::@
    - @ispage playlist.html::@
    - @ispage playlist.html::@
    + @ispage index.html::@
    + @ispage index.html::@
    + @ispage index.html::@
    + @ispage index.html::@
    + @ispage index.html::@
    + @ispage config.html::@
    + @ispage config.html::@
    + @ispage config.html::@
    + @ispage config.html::@
    + @ispage smart.html::@
    + @ispage smart.html::@
    + @ispage smart.html::@
    + @ispage playlist.html::@
    + @ispage playlist.html::@
    + @ispage playlist.html::@
    + @ispage playlist.html::@
    + @ispage playlist.html::@



    @@ -49,7 +50,6 @@

  • about firefly

  • thanks

  • -



  • Patch creating new css file for index.html since style inside the body is not allowed:

    --- index.css	1970-01-01 01:00:00.000000000 +0100
    +++ index.css 2006-09-27 16:07:23.000000000 +0200
    @@ -0,0 +1,31 @@
    +#service, #stat {
    + width: 70ex;
    +}
    +#thread {
    + width: 80ex;
    +}
    +#server_stopped_message {
    + position: absolute;
    + background-color: yellow;
    + padding: 1em;
    +/* border: 1px solid #8CACBB;*/
    + font-size: 120%;
    + margin-bottom: 1em;
    + z-index: 100;
    +
    +}
    +#grey_screen {
    + position: absolute;
    + top: 0;
    + left: 0;
    + width: 100%;
    + height: 1000px;
    + background-color: #000;
    + filter:alpha(opacity=60);
    + opacity: 0.6;
    + z-index: 10;
    +}
    +#button_stop_server, #button_start_scan, #button_start_full_scan {
    + width: 10em;
    + margin-bottom: .2em;
    +}

    Patch removing invalid style definition from index.html:

    --- index.html	2006-07-06 06:42:31.000000000 +0200
    +++ index.html 2006-09-27 16:07:37.000000000 +0200
    @@ -1,37 +1,4 @@
    @include [email protected]
    -

    Server Status

    update: By the way, by shortening the length of the script lines (closing the tags inside the opening tag instead of the additional closing tag), the number of (null)s was reduced. So the problem about the (null) seems to have to do with the length cutting as well (maybe when I made that list above, the files in subdirectories where just unlucky to have a longer total line length).

    #6569
    rpedde
    Participant

    @CCRDude wrote:

    Patch for hdr.html adding new style file, making script lines shorting by removing closing tag and adding terminating to end of opening tag instead, and removing invalid li:

    The self-closing style of script tags make IE ill, but the rest I’ll happily take. Still haven’t looked closer at the null stuff… I’m still struggling with getting an automated build system. Might be this weekend before I get it all put together in a new nightly.

    — Ron

    #6570
    CCRDude
    Participant

    @rpedde wrote:

    The self-closing style of script tags make IE ill,

    Are you sure about that, or is it because the forum added linebreaks (will send it as files by email then next time 😉 )? I have no problems at all with either IE 64 bit nor IE 32 bit (both 6.0). But then, that may have to do with the cutting – because of that, I guess the terminating isn’t considered by any browser in my environment, so you could be right 😉

Viewing 15 posts - 1 through 15 (of 28 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.