You are here: Home » Topic » web interface access?

web interface access?

This topic contains 4 replies, has 2 voices, and was last updated by  rpedde 10 years ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1660

    don quixada
    Participant

    I built the second-latest nightly-build (1586) from the source and installed on my Gentoo box. It works fine and I can even stream oggs and flacs. However, I cannot access the web interface. I’m not sure if it’s the login info that’s wrong or if I need to build it into the program.

    I get an 404 error message when I try to access. Do I need to enable a build flag? If so, what is it?

    Or is my login information wrong?

    I set a password in the mt-daapd.conf file but I couldn’t see a direct reference to a username. I’ve tried ‘admin’, ‘root’, ‘admin-root’ nothing seemed to work. Any suggestions?

    Thanks,

    dq

    EDIT:

    The error message looks like this:

    Not found
    Error 404
    mt-daapd: svn-1586
    Error: No such file or directory
    #12208

    rpedde
    Participant

    @don quixada wrote:

    I built the second-latest nightly-build (1586) from the source and installed on my Gentoo box. It works fine and I can even stream oggs and flacs. However, I cannot access the web interface. I’m not sure if it’s the login info that’s wrong or if I need to build it into the program.

    I get an 404 error message when I try to access. Do I need to enable a build flag? If so, what is it?

    Or is my login information wrong?

    I set a password in the mt-daapd.conf file but I couldn’t see a direct reference to a username. I’ve tried ‘admin’, ‘root’, ‘admin-root’ nothing seemed to work. Any suggestions?

    Thanks,

    dq

    EDIT:

    The error message looks like this:

    Not found
    Error 404
    mt-daapd: svn-1586
    Error: No such file or directory

    The username doesn’t matter (right now), just the password.

    As far as the error goes, check the web_root directive in the config file, and make sure that:

    1. It points to a directory that exists and has the firefly web pages in it.
    2. The files there are world-readable

    Also, you might verify that you did your “make; make install” from the mt-daapd directory, not the “src” directory under it — that would fail to install the admin web pages.

    — Ron

    #12209

    don quixada
    Participant

    Ok, I pointed it to the right directory. And the files are world-readable (chmod a+r *). But I still cannot access the web interface i.e., I get the same 404 error message.

    Does this have something to do with the fact that it takes me several attempts to connect to the server with my Soundbridge before I finally connect?

    Thanks.

    dq

    #12210

    don quixada
    Participant

    Ok, I fixed the problem. I was editing the wrong .conf file! Is there a way to change it from reading /usr/share/etc/local/mt-daapd.conf to read just /etc/mt-daapd.conf? I suspect enable=/usr might do it, is this correct?

    dq

    #12211

    rpedde
    Participant

    @don quixada wrote:

    Ok, I fixed the problem. I was editing the wrong .conf file! Is there a way to change it from reading /usr/share/etc/local/mt-daapd.conf to read just /etc/mt-daapd.conf? I suspect enable=/usr might do it, is this correct?

    dq

    –prefix=/usr

    from the ./configure invocation is what you are looking for, I think.

    — Ron

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.