You are here: Home » Topic » use of another DB ? postgresql / mysql ? and IF choice.

use of another DB ? postgresql / mysql ? and IF choice.

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Feature Requests use of another DB ? postgresql / mysql ? and IF choice.

This topic contains 8 replies, has 3 voices, and was last updated by  Anonymous 11 years, 1 month ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #2543

    Anonymous

    Hello all,

    I installed mt-daap for the first time yesterday. I actually encounter 2 problems:

    1. I have a big collection and the mt-daap service crashes every time it goes over 38k files.

    Uptime 14 hours, 14 minutes, 32 seconds
    Songs 38880
    Songs Served 0
    DB Version 2

    I think this is related to sqlite3 that probably don’t handle so much data. So i’m looking for a solution. is it possible to install postgresql or mysql and to tell firefly to use it instead of sqlite3? do someone have any other solution for me ? I tried to delete the db and made a complete rescan but I can’t include more tracks…I contantly stay on the same 38880 number :S

    I tried to build my collection with rhytmbox that includes a daap protocol. there is absolutely no problem -> i see my whole collection. (more than 38k files;)

    2. i’m using firefly into my lan but have openvpn installed. the problem is that the sound is now streamed alternatively trough the lan or vpn. this implicates that sometimes, when i stream sound to my macbook from inside my lan, i passes trough the internet for nothing ! is it possible to assign a “priority” on the choice of the interface ? for example, if not possible to load from eth0, use tap0 ?

    by the way -> this problem appears with mt-daap AND the daap protocol included in rythmbox.

    Thanks in advance for your answers !

    #17400

    fizze
    Participant

    I’ve seen databases with 80K songs and more, using mt-daapd and sqlite2.
    All worked nicely. Sqlite3 should be superior, so that’s not the issue.

    As with routes and networking…. There should be a default route, and since DAAP works via multicast, you shouldn’t actually be sending multicasts over the VPN, unless it’s a bridged VPN.
    Then again this boils down to the default route option.

    The better solution perhaps would be to run the VPN on an extra network device, and binding the music server to the standard interface, not the VPN one.

    Also, there are no plans for a “bigger” database backend. As far as I know Ron talked about bringing the gdbm backend back, which is a lot faster on embedded devices than sqlite. But I think it would be rather easy to fork and build it with MySQL support. There are only so much database operations, and they are encapsulated rather well.

    #17401

    Anonymous

    at the moment i’m listening the sound via the eth0 interface…but i don’t know why. maybe at next launch of itunes will i pass trough the vpn. tap0. dunno.

    for the 80k files..i’m disapointed i don’t understand what could break the full scan process that way and causes the service to crash… :S

    #17402

    fizze
    Participant

    Well, it’s more likely that firefly can’t digest one of the files, and the scan thus fails.

    I know its a tedious process, but have you tried to set the loglevel to 5 and then do a scan / full rescan so that it goes above your mystical & magical 38800 songs? 😉

    The only limit I know of is with the Soundbridges, they hiccup about 50K songs.

    #17403

    EVILRipper
    Participant

    Yeh. Most scans that I’ve seen fail was due to permission problems. Since that is no issue with you, since you can get to 38k.
    Next to that, most scans died on a certain file. Corrupt files, or unreadable files. Firefly trips over corrupt files because it reads ID3 tags from them.
    So I also suggest what fizze suggested, raise the debuglevel to 5 (or higher up till 9 if no clue given from log) and try again.

    #17404

    Anonymous

    you’r right.

    i used to launch the full scan from the webif for now so could one of you paste me the correct command to re-execute a full scan of the DB with debug level 9 from the term ?

    thanks !

    #17405

    fizze
    Participant

    No such thing as a terminal command.
    You gotta use the web interface. Also, you can use the web interface to dynamically set the debuglevel to 9.

    #17406

    Anonymous

    thanks for the info i did not notice this debug level option.
    I launched a full scan and specified /tmp/log_daap/log.txt as output file.
    The problem is that it don’t writes anything in the file…
    fyi -> I created the file log.txt using vim, then i chmod 777 /tmp/log_daap/log.txt to be sure it was writable by every user.

    would one of you tell me how he did to get this to work ?

    thanks 😉

    #17407

    Anonymous

    i’m dumb…forgot to chmod 😉

Viewing 9 posts - 1 through 9 (of 9 total)

The forum ‘Feature Requests’ is closed to new topics and replies.