You are here: Home » Topic » Unable to find music in media directories

Unable to find music in media directories

This topic contains 2 replies, has 2 voices, and was last updated by  Anonymous 9 years, 10 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2032

    Anonymous

    When using the version of mt-daapd from Gutsy’s universe repo, I’m unable to successfully scan and locate music inside my media directories. I’ve tried pointing the server to a couple of different media directories to no avail. Let me know if any other information is required. Thanks in advance.

    #15212

    fizze
    Participant

    Let’s talk about permissions here.
    The user that mt-daapd aka firefly is running as has different (lower) permissions than your user account.

    For instance it cannot peek into your ~

    Normally this user account is nobody/nobody, so you need to do either:
    a.) put your music in a directory that nobody/nobody can access (that is read+execute permissions on the directory, read on the files)
    b.) change permissions of said directory so that nobody/nobody can use it (+rx on directories, +r on the files)

    #15213

    Anonymous

    Thanks for the help, it worked beautifully!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.