You are here: Home » Topic » Ubuntu Issue???

Ubuntu Issue???

This topic contains 10 replies, has 3 voices, and was last updated by  fizze 10 years, 3 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1646

    lconvis
    Participant

    Sorry for my ignorance, but I am new to Linux. I have installed Firefly on my Ubuntu 7.04 box. Everything seems to be working, it loads, I can access the web interface, it scans my directory and shows a song count. I go to my Soundbridge and it does not see Firefly. I launch my Avahi browser and it detects my Soundbridge. If I launch Rythmbox and enable sharing my Soundbridge sees it (although there are browsing restrictions from Rythmbox)
    I can share from a WinXP or my Mac and the Soundbridge works perfect.

    My ultimate goal is to stay on Ubuntu.

    I know this does not explain much, but I sure could use some help.

    Thanks in advance,

    Lenny

    #12133

    fizze
    Participant

    What version of firefly did you install?
    Probably your Soundbridge is a Pinnacle brand, you need to activate the RSP-plugin of firefly to be able to use it with the soundbridge.

    Only the newer nightly versions (since about v1200) support the RSP protocol, and you’re better off with them anyways. Check http://nightlies.mt-daapd.org for debian/ubuntu packages.

    The Pinnacle-branded SoundBridges do not see iTunes (DAAP) shares. But

    #12134

    lconvis
    Participant

    Thank you so much for your quick reply.

    I went and downloaded the nightly (1586). I checked and the RSP plugin was enabled.

    I know my Soundbridge is a Roku no mention of Pinnacle anywhere.

    Since I installed the nightly (1586) I can no longer access my Web interface for firefly.

    Any more ideas on my Soundbridge?

    Thanks again

    Lenny

    #12135

    fizze
    Participant

    Well, if your soundbridge is indeed a RoKu then it should see the iTunes, rhythmbox, banshee and firefly shares anywho.

    So let’s take this one step further.
    How is your RoKu connected to your music servers? Wirelessly? Via a Router?
    Chances are, the router blocks multicasts, so see if you can tap into your router config and activate any options that enable multicasts.

    As a workaround, wire up your soundbridge to the network and see if its working then, then you’ve found the culprit πŸ˜‰

    #12136

    lconvis
    Participant

    My Soundbridge is connected via wireless. I can fire up my MacBook and iTunes works perfectly to serve the music. I can also run iTunes on my XP box and it works great with the Soundbridge. (Vista however does not serve it well AT ALL)

    Anyway, I am thinking it is related to my Ubuntu installation. Currently I am installing 6.06 LTS and a fresh install of MT-DAAP. I wonder if it is related to 7.04.

    What distro of Linux are you running? I basically want to accomplish the following.

    A linux box to manage my music. Importing CD’s, Sync my iPod and Serve my Soundbridges. I have 3 (Garage, Living and Patio)

    Kinda crazy, but I love my tunes!!!!

    Thanks for all your help!!!

    Lenny

    #12137

    fizze
    Participant

    Not crazy at all πŸ˜‰

    Im running edgy on my desktop, Win XP on my notebook, and uNSLUng 6.8 on my Slug (linksys nslu2) – all run firefly, various versions, but serving up nice.

    Right, so your Linux may be the culprit. Getting closer. Are you using iptables to block any multicast traffic? IE any linux firewall?
    Blocking multicasts seems to be quite common these days. Also, is your avahi-daemon started? firefly likes to use avahi in ubuntu πŸ˜‰
    And without that daemon it doesnt advertise itself in the network.

    #12138

    lconvis
    Participant

    Well, I took another box and installed Ubuntu 6.06 LTS, and MT-DAAP 2.4

    WORKS GREAT!!! I will take it home and try it on my Soundbridge, but it works in iTunes perfectly.

    I have a new problem now. I have an External HDD and anytime I copy music to it, I have to run sudo chmod 777 -R on that directory on my external HDD.

    I know this is not Firefly related, but do you have a quick and dirty way of installing an external HDD (ext3 formatted) onto Ubuntu, with full permissions. I would rather have all my music on an external. Again, I know it is not Firefly related.

    Thanks for ALL your help. The true test will be going home to my wireless network and see what happens.

    Thanks again,

    Lenny

    #12139

    fizze
    Participant

    You’re welcome.

    Yep, there is an easy way around that.
    While its not safe to do, yaddayadda.. ;):D

    Just add “umask=000” to the fstab entry or the mount command as option.
    This will make all files and dirs “777”.

    #12140

    lconvis
    Participant

    Hey there, I have taken a different approach. I have loaded XUbuntu and I am building a dedicated MP3 Server/Library Manager. I chose XUbuntu cause it is lightweight and QUICK!!! I have installed the OS, and MT-DAAP. I am still having issues getting my permissions ironed out. I will add the UNMASK command and see if that helps. My next question is when I copy music from my Thumbdrive to even my /home directory do I need to run the CHMOD 777 -R command before the DAAP server will read it??

    Thanks again. you have got me VERY excited about this DAAP server. I AM ALMOST THERE! Sorry to be such a pest!

    Lenny

    #12141

    rpedde
    Participant

    @lconvis wrote:

    Hey there, I have taken a different approach. I have loaded XUbuntu and I am building a dedicated MP3 Server/Library Manager. I chose XUbuntu cause it is lightweight and QUICK!!! I have installed the OS, and MT-DAAP. I am still having issues getting my permissions ironed out. I will add the UNMASK command and see if that helps. My next question is when I copy music from my Thumbdrive to even my /home directory do I need to run the CHMOD 777 -R command before the DAAP server will read it??

    Thanks again. you have got me VERY excited about this DAAP server. I AM ALMOST THERE! Sorry to be such a pest!

    Lenny

    Sort of… the problems with copying to you home directory is that your home directory isn’t world readable by default (I’d guess). If you want to make it world readable, just make the home directory itself 755 and the mp3 directory underneath is 755, and you’ll probably be good. Default umasks are 002 anyway (probably), so you’ll still be able to read them.

    — Ron

    #12142

    fizze
    Participant

    Inheriting access permissions is a sweet and nice topic for Linux vs. Unix discussions. In Unix (at least those few I know), the permissions get inherited from the parent folder, for instance.

    Anyway, this shortcoming can be worked around by cleverly defining group memberships and creating a mt-daapd run-as user that sits within the same group as most users.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.