You are here: Home » Topic » Ubuntu Dapper: Browser Not Finding Firefly

Ubuntu Dapper: Browser Not Finding Firefly

This topic contains 11 replies, has 4 voices, and was last updated by  Anonymous 9 years, 10 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #2165

    Anonymous

    Hello,
    Have installed mt-daapd 0.2.4 on Dapper Drake. Have confirmed that it is running by mt-daapd start, mt-daapd stop and mt-daapd restart, however when attempting to load the web site [http://localhost:3689], the browser [Firefox, current Dapper version] hangs … no messages, no nothing, just keeps the loading dial spinning. The server also does not appear on my Soundbridge.

    I’ve inspected the mt-dappd.conf and init.d/mt-daapd files and they compare well with examples I’ve found on this site. I’ve used the .deb binary that was referenced in Matt’s Blog [http://dotnet.org.za/matt/articles/48417.aspx].

    Any clues to help resolve this problem would be greatfully received.

    Thanks very much,

    Bill Cole

    #16046

    Anonymous

    Couple of suggestions

    1. Make sure your firewall is open for Firefly. If you are running on a LAN just turn off the firewall and try it, if it works turn off the firewall and try again. If it fails time to look closer at the firewall.

    failing that…

    2. Go to the firefly.conf file and change the Log level to 5 or higher if necessary and restart – Look at the log try and work out where the problem is, if you get nowhere post the log back here

    Good luck

    #16047

    fizze
    Participant

    Actually 0.2.4 is horribly outdated.

    Use any off http://nightlies.fireflymediaserver.com the unstable builds aren’t that unstable.
    svn-1696 is the most recent unstable build as of now, and its actually stable to use on a PC without a hitch.

    So, update to svn-1696, and overwrite your config file with the default one, since the format has also considerably changed since 0.2.4.

    #16048

    Anonymous

    Thanks very much for the good information.

    I enabled the log file a level 5 and found out that:
    “Could not open port: Address already in use”
    “Error starting web server: Address already in use”
    “Aborting”
    “Rendezvous socket closed (daap server crashed?) Aborting.”

    Oh, I turned off the firewall.

    So the problem now is, I guess, finding out what’s using the 3689 socket? This is new territory for me and would very much appreciate help in sorting that out.

    Thanks again, very much.

    Bill Cole

    #16049

    Anonymous

    Bill

    You are working at the edge of my expertise here

    I would go to the firefly.conf file and change port to another port and try that.

    Also, another option maybe to re-install firefly

    Let me know how it goes

    #16050

    Anonymous

    Yup, changed the port to 3688 and, with the firewall [Firestarter] on, the mt-daapd web server served. Still have to get to the Soundbridge to see if I can see the server, though.

    Thanks very much,

    Bill Cole

    #16051

    rpedde
    Participant

    @wacole wrote:

    I’ve inspected the mt-dappd.conf and init.d/mt-daapd files and they compare well with examples I’ve found on this site. I’ve used the .deb binary that was referenced in Matt’s Blog [http://dotnet.org.za/matt/articles/48417.aspx].

    dapper has mt-daapd already in the repository. Remove the version you have installed with “apt-get –purge remove mt-daapd”.

    Remove the init.d files if they haven’t already been removed, then apt-get install mt-daapd. That should get you the version from ubuntu. You’ll need ot update your config, but give that a try and see where it gets you.

    #16052

    Anonymous

    Thanks very much for the info on repository source. I got mt-daapd to purge properly, but apt-get install mt-daapd did not find a package. I checked [as in literally checked the boxes of] all of the repositories that are shown in Synaptics, so there must be a repository that I need to add.

    Thanks very much for the help.

    Bill Cole

    #16053

    rpedde
    Participant

    @wacole wrote:

    Thanks very much for the info on repository source. I got mt-daapd to purge properly, but apt-get install mt-daapd did not find a package. I checked [as in literally checked the boxes of] all of the repositories that are shown in Synaptics, so there must be a repository that I need to add.

    Thanks very much for the help.

    Bill Cole

    I believe it’s in the Universe repository — these were instructions for enabling it on 6.10. Not sure if it still holds, but it might give you a start int he right direction:

    https://help.ubuntu.com/6.10/ubuntu/desktopguide/C/extra-repositories.html

    — Ron

    #16054

    Anonymous

    Thank very much. Did all that, but no mt-daapd, either thru apt-get or Synaptics [ran that just to make sure]. I think the problem is that I’m running 6.06LTS and not 6.10. I’ve taken a stab at updating to 6.10, but ran aground and haven’t the time to tackle it again.

    Bill Cole

    #16055

    rpedde
    Participant

    @wacole wrote:

    Thank very much. Did all that, but no mt-daapd, either thru apt-get or Synaptics [ran that just to make sure]. I think the problem is that I’m running 6.06LTS and not 6.10. I’ve taken a stab at updating to 6.10, but ran aground and haven’t the time to tackle it again.

    Bill Cole

    Wow, I completely misread everything here. Sorry. If you have the dapper package that should work.

    It’s possible firestarter is at issue, too.. there are instructions for configuring it here:

    http://forums.fireflymediaserver.org/viewtopic.php?t=5999

    that might help. The “port in use” is most likely another copy of mt-daapd running. You can always try a “killall -9 mt-daapd” and try restarting it.

    So perhaps reinstalling the version you had (sorry about that ), configuring firestarter, and I think that might ahve a fair shot at working.

    — Ron

    #16056

    Anonymous

    Thanks much. Haven’t gotten back to this, but should be able to try this out later this week. I did find 2 copies of mt-daapd running but haven’t run down the why yet.

    Bill Cole

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.