You are here: Home » Topic » The shared music library "mt-daapd" is not accessi

The shared music library "mt-daapd" is not accessi

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues The shared music library "mt-daapd" is not accessi

This topic contains 5 replies, has 1 voice, and was last updated by  rk 13 years, 1 month ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #288

    rk

    Hi,

    My daapd server appears nicely in iTunes after configuring the daapd-server on my Linux box. Though upon connection I end with the message:

    “The shared music library “mt-daapd” is not accessible for an unknow reason (-3259)”

    Check that any firewall software running on either the shared computer of this computer has been set to allow communication on port 3689.

    What to check ?

    Regards,

    Rene

    #4564

    rpedde
    Participant

    @rk wrote:

    What to check ?

    Check version. You should be running 0.2.4 or better. You can see that by checking the web admin interface (http://server:port, logon as admin, password is the admin_pw).

    That’s almost *always* what it is.

    Aside from that, check to make sure your server isn’t firewalled. What kind of system is it running on?

    #4565

    rk

    Ron,

    Thanks. I am running RedHat AS 4 upd 3 and have been using the latest stable version “mt-daapd-0.2.4-1.fc4.i386.rpm”

    My linux server is not using any firewall or ipchains and I disabled the firewall on my XP box.

    Rene

    #4566

    rpedde
    Participant

    @rk wrote:

    Ron,

    Thanks. I am running RedHat AS 4 upd 3 and have been using the latest stable version “mt-daapd-0.2.4-1.fc4.i386.rpm”

    My linux server is not using any firewall or ipchains and I disabled the firewall on my XP box.

    Rene

    Can you see the web interface? You should be able to go to http://server:port and enter “admin” as the username, and the admin_pw from the config file (default is “mt-daapd”) and get into the web interface.

    If you can’t, that’s why.

    Is it possible you have a multi-homed machine? If so, is it possible that it’s advertising on an interface other than the one your iTunes machine is on? In that case, maybe enabling routing?

    #4567

    rk

    Yep I can see and use the web interface, no prob.

    Well, the system is running a couple of vmware workstations, so there are vmnet interfaces on the box.

    Shall I re-try by disabling them first ?

    Rene

    #4568

    rk

    Great, the problem was related to the multi-homed setup.

    Appreciated !

    Thanks.

    Rene

Viewing 6 posts - 1 through 6 (of 6 total)

The forum ‘Setup Issues’ is closed to new topics and replies.