You are here: Home » Topic » SVN-1545 requires user-id and password for web admin interfa

SVN-1545 requires user-id and password for web admin interfa

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Nightlies Feedback SVN-1545 requires user-id and password for web admin interfa

This topic contains 5 replies, has 2 voices, and was last updated by  rpedde 10 years, 7 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1311

    hans.t
    Participant

    Hi, after switching to SVN-1545 (Windows XP SP2) when I want to open the web admin interface IE 7 comes with a message, stating that Server localhost requires a user-id and password. I have no clue to what these might be and in previous versions I did not get that question.

    Moreover (as I just discovered) my Soundbridge also wants a password (while the security checkbox in the media server is empty)… and obviously I do not know that password either. When I do put a password in the security area of the media server (and mark the checkbox) I can enter the music library with that password. After unchecking the security checkbox again the Soundbridge still requires a password (which is my previously entered one) but does not give acces to the web admin interface (no password).

    SVN 1546 perhaps?

    #10222

    rpedde
    Participant

    @hans.t wrote:

    Hi, after switching to SVN-1545 (Windows XP SP2) when I want to open the web admin interface IE 7 comes with a message, stating that Server localhost requires a user-id and password. I have no clue to what these might be and in previous versions I did not get that question.

    It’s probably “firefly”.

    Moreover (as I just discovered) my Soundbridge also wants a password (while the security checkbox in the media server is empty)… and obviously I do not know that password either. When I do put a password in the security area of the media server (and mark the checkbox) I can enter the music library with that password. After unchecking the security checkbox again the Soundbridge still requires a password (which is my previously entered one) but does not give acces to the web admin interface (no password).

    That’s a bug!

    — Ron

    #10223

    hans.t
    Participant

    Ron, bad news. This bug was not completely fixed in 1549! My soundbridge is now available without password, but I still can not get into the web admin interface (asks for user-id and password).

    #10224

    rpedde
    Participant

    @hans.t wrote:

    Ron, bad news. This bug was not completely fixed in 1549! My soundbridge is now available without password, but I still can not get into the web admin interface (asks for user-id and password).

    That’s “normal new”. I had it set up so that you didn’t have to have a password to connect from the local machine to the web interface ever. But that means that anyone sitting down at the machine can access the web interface. Which is bad on a multi-user system, like a unix machine or a windows terminal server, or when fast user switching is enabled, etc.

    So instead it’s now set so that you don’t need a password from localhost only if the admin password isn’t already set.

    I think for some of the first builds I set the default password to “firefly”. I’m not sure how to fix that, except maybe turn off the password on an install if it’s already set to “firefly”. Then you won’t need a password from localhost (just like before), and people can still change the password if they want.

    Does that make sense?

    #10225

    hans.t
    Participant

    To be honest: not a lot. But I can grasp the solution.

    I can acces the web admin interface using as user-id and password both “firefly” (without the “-s of course). And then I can delete the requires passwords.

    So the solution has been presented. Big thanks!

    #10226

    rpedde
    Participant

    @hans.t wrote:

    To be honest: not a lot. But I can grasp the solution.

    I can acces the web admin interface using as user-id and password both “firefly” (without the “-s of course). And then I can delete the requires passwords.

    So the solution has been presented. Big thanks!

    Correct… if the new behavior isn’t good, then deleting the admin password will make it passwordless from the server machine, and not accessible remotely, which is a safe way to run it.

    — Ron

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.