You are here: Home » Topic » svn-1082 on NSLU2page 2

svn-1082 on NSLU2

This topic contains 35 replies, has 3 voices, and was last updated by  fizze 13 years, 2 months ago.

Viewing 15 posts - 16 through 30 (of 36 total)
  • Author
    Posts
  • #4685

    rpedde
    Participant

    @fizze wrote:

    just a Q though: it seems to scan the DB 2x on init, why so ?
    is there a way to deactivate the background-scan thats issued on startup ?

    its kinda annoying for such testings on the slug…. 😉

    Are you starting it with -s? The sense of that switch has changed several nightlies back. It now means “force a foreground scan at startup”.

    The “second” scan is what used to be the old foreground scan, only as a background scan. You can ignore it when it’s doing that… it’s already advertising itself via rendezvous.
    [/quote]

    the one thats in ‘D’ has to be -9’ed, it wont quit otherwise.
    Im using the standard transcode script, guess theres something wrong in there. Does it work on anyone else’s slug ? if so, what flavour of linux are you running on ? and what config ?
    🙄

    Works for me. I’m using the as-shipped config with no changes, and I’m successfully feeding my sb ogg over rsp.

    Have you tried running the transcode script by hand to see what it does?

    You should be able to run it something like:


    /opt/sbin/mt-daapd.ssc "/path/to/ogg file" 0 180000 > out.wav

    and see what it does. That’s not a completely good test, as you don’t have the same environment as when running it from the daemon, but it’s a good test.

    #4686

    fizze
    Participant

    nah I havent. but then again, mt-daapd is supposed to be UP and running when I enable transcoding, right ?

    the startup code and whatnot should be more or less the same when running with/without transcoding, right ?
    and I do not see a stalled instance of the script, or whatnot.

    mt-daapd doesnt even get as far as advertising itself via rendezvous. the init database just takes forever on the poor slug.

    -d9 output isnt helping there, either.

    I’ll reiterate the log proper log output, with timestamps once more. *sigh*

    and no, I dont run it with -s from the script. its the standard S60mt-daapd script that comes with the ipkg. IF the script does that, then umm yeah, but I dont think so.

    #4687

    rpedde
    Participant

    @fizze wrote:

    the startup code and whatnot should be more or less the same when running with/without transcoding, right ?
    and I do not see a stalled instance of the script, or whatnot.

    I guess I don’t understand the problem you are having.

    Are you saying it hangs when scanning playlists? Is the cpu high? Is there disk activity? What playlist is it scanning when it does that?

    I thought this was some kind of transcoding related issue? No?

    #4688

    fizze
    Participant

    I cant tell, since the CPU on the slug is hogged, and there is disk activity.

    also, just enabling transcoding without process_m3u also results in same behaviour.

    does a “nice” binary exist for unslung ? If so, I could “nice” it and get decent log outputs (hopefully).

    also: I built the DB with extensions mp3, m4a, wma. so when I enable transcoding for .ogg for example, it wont do anything unless I add .ogg to my extensions, right ?

    will the .ogg files be included in the next background scan, then ?

    #4689

    rpedde
    Participant

    @fizze wrote:

    I cant tell, since the CPU on the slug is hogged, and there is disk activity.

    A -d9 should still show you what it’s doing up to the point that it craters.

    also, just enabling transcoding without process_m3u also results in same behaviour.

    That should have no effect whatsoever on startup. The only time transcoding should have any effect at all is when serving the files. This confuses me.

    does a “nice” binary exist for unslung ? If so, I could “nice” it and get decent log outputs (hopefully).

    Dunno, but even without,i t should at least log the last thing it was doing before it fell over.

    also: I built the DB with extensions mp3, m4a, wma. so when I enable transcoding for .ogg for example, it wont do anything unless I add .ogg to my extensions, right ?

    True.

    will the .ogg files be included in the next background scan, then ?

    If you add them to your extensions, yes. But only if you do it from the web interface… it doesn’t (yet) recognize that the config file has been changed underneath it.

    #4690

    fizze
    Participant

    yes, right.
    I’ll play with the latest nightly later today.

    Good work with the playlists though. They work nice.
    One thing though: It seems that the songs in Playlists are sorted alphabetically ascending by Artist ?
    Why so ?

    I dont want my playlists to be sorted at all. 😉

    edit:
    alright, right now I ran the stuff like an hour ago with ogg in extensions and as transcodingextensions.

    the background scan still hasnt finished yet. and I think its either just taking ages (but then I dont have that many ogg files, maybe 200) but some are quite large. maybe that poses a problem ?

    edit2:
    the background scan is now going for more than 90 minutes.
    how can I find out what its processing ?
    I got a decent log file and already searched through it, but no indication of the file scanning activity, whatsoever…. 🙁

    edit3:
    wow, this is getting really funny now.
    heres a short excerpt from the log:

    2006-06-01 20:25:22: Current lock level: 0
    2006-06-01 20:25:22: Current lock level: 0
    2006-06-01 20:25:22: Current lock level: 0
    2006-06-01 20:25:22: Current lock level: 0
    2006-06-01 20:25:22: Current lock level: 0
    2006-06-01 20:25:22: Current lock level: 0
    2006-06-01 20:25:22: Current lock level: 0
    2006-06-01 20:25:22: Current lock level: 0
    2006-06-01 20:25:22: Current lock level: 0
    2006-06-01 20:25:22: Current lock level: 0
    2006-06-01 20:25:22: Current lock level: 0
    2006-06-01 20:25:22: Current lock level: 0
    2006-06-01 20:25:22: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0
    2006-06-01 20:25:23: Current lock level: 0

    I simply pointed my iTunes client to the DAAP share….
    ❓ 😯

    edit4:
    right, after like 10 minutes iTunes had the files.
    This time, it also showed ogg vorbis files with correct metadata. 🙂
    wohoo!

    But of course, even through DAAP those oggs refused to play.
    Maybe it has to do with the load on the slug being too high, I donno.
    I also tried to connect the soundbridge via DAAP /RSP a couple of times, but it timed out always.

    I’ll just leave it overnight to see if the slug calmes down, or some threads terminate and try again tomorrow, if there are no other clues.
    *shrug*

    #4691

    rpedde
    Participant

    @fizze wrote:

    wow, this is getting really funny now.
    heres a short excerpt from the log:

    Try turning off you logfile, and setting debuglevel to 1. See what that does. I wonder if it’s just logging and event handling slowing it down.

    #4692

    fizze
    Participant

    After a while, the slug crashed. I rebooted it, and it restarted mt-daapd with same settings, but without debugging.

    Now, some 9 hours later its still inaccesible by the soundbridge. Still very slow.
    its not the logging thats tearing speed away THAT much. It does, but just to arather minor extent.

    I’ll run it with -d1 or -d2 now.

    #4693

    rpedde
    Participant

    @fizze wrote:

    After a while, the slug crashed. I rebooted it, and it restarted mt-daapd with same settings, but without debugging.

    Now, some 9 hours later its still inaccesible by the soundbridge. Still very slow.
    its not the logging thats tearing speed away THAT much. It does, but just to arather minor extent.

    I’ll run it with -d1 or -d2 now.

    Make sure you don’t have loglevel 9 in the config file, too. And disable logfile if you have one set.

    It’s doing double logging, plus checking for event plugins when logging is high. that’s changed in the last few versions. Enought that high debug levels might really slow down a slow device like the slug.

    #4694

    fizze
    Participant

    Alrighty, I’ll grab the latest nightly and give it another shot w/o any logging.

    right, I let it run for 2h without any other activity. So that would give the scan enough time.
    Just tried to connect my Soundbridge, it announced properly through rendezvous.
    here’s a snip from “ps”

    563 ttyp0 guest 3740 S /opt/sbin/mt-daapd -c /opt/etc/mt-daapd/mt-
    564 ttyp0 guest 14404 R /opt/sbin/mt-daapd -c /opt/etc/mt-daapd/mt-
    565 ttyp0 guest 14404 S /opt/sbin/mt-daapd -c /opt/etc/mt-daapd/mt-
    566 ttyp0 guest 14404 S /opt/sbin/mt-daapd -c /opt/etc/mt-daapd/mt-
    578 ttyp0 guest 14404 S /opt/sbin/mt-daapd -c /opt/etc/mt-daapd/mt-
    588 ttyp0 guest 14404 D /opt/sbin/mt-daapd -c /opt/etc/mt-daapd/mt-

    I almost always seem to have one instance in “D”, but I dont think its really waiting for any IO, donno if busybox is to blame on this.
    One is actually running, I guess this is the thread thats trying to serve the SB, but it timed out already.

    edit:

    here’s the logfile of yesterday’s session, amongst others.

    One more thing:
    I created a smart playlist that shows all .ogg files, and I noticed it only shows a part of them.
    I have 12 files which are all like ~70MB in size. Maybe they’re just too big for the poor slug.

    Whats the largest ogg vorbis file in your lib, Ron ?

    #4695

    fizze
    Participant

    ok, its not related to transcoding.
    even with the latest nightly, simply if I add .ogg to the extensions, the behaviour is the same.
    So I guess its really realted to my larg ogg vorbis files, although ogginfo f.i. displays the info fine.

    are there any special fields needed for mt-daapd to recognize em ?

    #4696

    rpedde
    Participant

    @fizze wrote:

    ok, its not related to transcoding.
    even with the latest nightly, simply if I add .ogg to the extensions, the behaviour is the same.
    So I guess its really realted to my larg ogg vorbis files, although ogginfo f.i. displays the info fine.

    are there any special fields needed for mt-daapd to recognize em ?

    No. Actually, i don’t even read the tags… I use libvorbisfile to do that. I just ask libvorbisfile to open it and hand me the tags back.

    Wonder if it’s possible that it tries to read the whole file into memory or something crazy like that?

    Might be worth ipkg update; ipkg install libogg libvorbis just to see if there are newer libs?

    #4697

    fizze
    Participant

    good catch.
    there indeed are.

    went from 1.0-1 to 1.1.3-2 for both. I’ll try again right now.

    edit:
    same game. didnt help. 🙁

    #4698

    rpedde
    Participant

    @fizze wrote:

    edit:
    same game. didnt help. 🙁

    and if you move hte big oggs out of the way, does it work?

    #4699

    fizze
    Participant

    thats the next thing I’ll try when I have some time to fiddle 😉

Viewing 15 posts - 16 through 30 (of 36 total)

The forum ‘Nightlies Feedback’ is closed to new topics and replies.