You are here: Home » Topic » Startup Issues

Startup Issues

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #1653
    woZa
    Participant

    Hi. I am trying to get mt-daapd-0.3.0_pre1586 running on gentoo. Builds and installs ok. I have been through the conf file and changed things to suit the new version. Upon startup I get the following errors…

    Aug 25 15:01:07 server mt-daapd[28296]: Firefly Version svn-1586: Starting with debuglevel 2
    Aug 25 15:01:07 server mt-daapd[28296]: Error opening plugin dir /usr/lib/firefly. Ignoring
    Aug 25 15:01:07 server mt-daapd[28296]: Error opening plugin dir /usr/lib/mt-daapd. Ignoring
    Aug 25 15:01:07 server mt-daapd[28296]: Error opening plugin dir /usr/share/firefly/plugins. Ignoring
    Aug 25 15:01:07 server mt-daapd[28296]: Plugin loaded: ssc-script/svn-1586
    Aug 25 15:01:07 server mt-daapd[28296]: Plugin loaded: ssc-ffmpeg/svn-1586
    Aug 25 15:01:07 server mt-daapd[28296]: Plugin loaded: rsp/svn-1586
    Aug 25 15:01:07 server mt-daapd[28296]: Plugin loaded: daap/svn-1586
    Aug 25 15:01:07 server mt-daapd[28296]: Starting rendezvous daemon
    Aug 25 15:01:07 server mt-daapd[28296]: Starting signal handler
    Aug 25 15:01:07 server mt-daapd[28298]: Error in drop_privs: Success

    Version 0.24 worked fine.

    Any ideas?

    Thanks

    #12185
    rpedde
    Participant

    @woZa wrote:

    Hi. I am trying to get mt-daapd-0.3.0_pre1586 running on gentoo. Builds and installs ok. I have been through the conf file and changed things to suit the new version. Upon startup I get the following errors…

    Aug 25 15:01:07 server mt-daapd[28296]: Firefly Version svn-1586: Starting with debuglevel 2
    Aug 25 15:01:07 server mt-daapd[28296]: Error opening plugin dir /usr/lib/firefly. Ignoring
    Aug 25 15:01:07 server mt-daapd[28296]: Error opening plugin dir /usr/lib/mt-daapd. Ignoring
    Aug 25 15:01:07 server mt-daapd[28296]: Error opening plugin dir /usr/share/firefly/plugins. Ignoring
    Aug 25 15:01:07 server mt-daapd[28296]: Plugin loaded: ssc-script/svn-1586
    Aug 25 15:01:07 server mt-daapd[28296]: Plugin loaded: ssc-ffmpeg/svn-1586
    Aug 25 15:01:07 server mt-daapd[28296]: Plugin loaded: rsp/svn-1586
    Aug 25 15:01:07 server mt-daapd[28296]: Plugin loaded: daap/svn-1586
    Aug 25 15:01:07 server mt-daapd[28296]: Starting rendezvous daemon
    Aug 25 15:01:07 server mt-daapd[28296]: Starting signal handler
    Aug 25 15:01:07 server mt-daapd[28298]: Error in drop_privs: Success

    Version 0.24 worked fine.

    Any ideas?

    Thanks

    Looks like your run_as user doesn’t exist. Also, as a side note, it also appears that I didn’t realize getpwent doesn’t set errno on failure. D’oh.

    Gotta love an error message like “Error: Success!” Mind bogglingly dumb.

Viewing 2 posts - 1 through 2 (of 2 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.