You are here: Home » Topic » starting Windows Service automatically

starting Windows Service automatically

This topic contains 3 replies, has 3 voices, and was last updated by  cstern 10 years, 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1348

    cstern
    Participant

    I have installed Firefly and set it to run as a user with accompaying password. My media files are on a network share \DISKSRVMusic which requires a password to log in.

    Everything works smoothly, in principle. The only annoyance is that I need to log into my Windows account, and double click on the Firefly icon in the tray, then manually start the firefly server. Of course I have set the service to start automatically, but for some reason that does not happen. What could be wrong?

    Firefly is version 1483

    Thanks in advance.

    Claus Sternberg

    #10465

    fizze
    Participant

    Well, either the service lacks permissions to access said network share, and with you having to enter that password, it highly seems the case 😉

    Mount the network share at boot, and have firefly start up delayed. Of course you’d have to change the music_dir to pont to the drive instead of the UNC path.

    #10466

    rpedde
    Participant

    @fizze wrote:

    Well, either the service lacks permissions to access said network share, and with you having to enter that password, it highly seems the case 😉

    Mount the network share at boot, and have firefly start up delayed. Of course you’d have to change the music_dir to pont to the drive instead of the UNC path.

    Even with drive mapped, the server doesn’t share that drive. It resolves it by unc.

    If it doesn’t start, what’s the error? Do you see anything in your event log or in the firefly log?

    #10467

    cstern
    Participant

    Thanks – problem solved. I checked the EL as suggested and found that the Bonjour service was hanging during boot. It may or may not be related to my disabling the CCAPP service (Symantec antivirus component). It may, however, also be that my installation of Bonjour was somehow broken. I have downloaded a new copy from Apple and installed it on top of the old one.
    Regardless what was the cause, things are working as expected now.
    If I have time, I will try to turn off ccapp.exe again and see if that was the real reason. Ccapp in Symantec Internet Security 2005 (which is the version I have) has a flaw that causes the CPU to run at 99% for (it seems) forever. I have not been able to find a solution for this – but thats a completely different story…

    Anyway – thanks for the prompt response and direction to a diagnostic.

    PS: Without CCAPP it is not possible to browse to secured websites (https://….)

    Best regards,

    Claus Sternberg

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.