You are here: Home » Topic » SSH Tunneling firefly not working.

SSH Tunneling firefly not working.

This topic contains 5 replies, has 4 voices, and was last updated by  rpedde 10 years, 8 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #872

    EVILRipper
    Participant

    Hello,

    First off, what im trying to achieve: Firefly media server is hosted at home, and by SSH tunneling im trying to get Bonjour to see the DAAP share on my laptop at school.

    My setup:
    Home: Debian Linux with Firefly Media Server Version svn-1450
    School: Windows XP Pro with SSH Tunnel Client and Bonjour

    First off, i tunneled with the GUI program through SSH so that my laptop sees localhost:3689 as home_address:3689.

    This is correct: if i check localhost:3689 i get redirected to the admin page.
    Which I can’t get to work is getting bonjour to find this share. It just plain doesnt show up. I’ve been googling for the last 2 hours trying to find out what could cause it. No success so far…

    Any idea what could cause bonjour to not see the share?
    Many thanks in advance.

    ~EVILRipper

    #7773

    schiers
    Participant

    Moin,

    you need to install and run RendevousProxy. You download it here: http://ileech.sf.net/RendezvousProxy/

    Download, install, and add 127.0.0.1 (localhost) Port 3689, Hostlabel Firefly, Servicetype _daap._tcp.(iTunes Host)

    It works, I tunnel with putty and I am able to use iTunes to listen to
    my music.

    BR,
    Carsten.

    #7774

    EVILRipper
    Participant

    Thanks for the fast reply;

    This indeed does help the share to be found in iTunes.
    Though it does not solve the problem for what im trying to achieve; See the share in Bonjour.

    I’m trying to get the share in Bonjour so that I can stream in winamp.
    But Bonjour just refuses to see the share.
    Any idea’s how to get this done?

    Thanks in advance.

    ~EVILRipper

    #7775

    CCRDude
    Participant

    Bounjour aka ZeroConf aka Rendezvous is the name of the protocol, not the name of an application.
    If iTunes, which uses Bonjour to detect servers, can find the server, Bonjour is working. If it doesn’t work in another program, that’s probably because that other program has problems, but not “Bonjour” itself?

    Also, since Bonjour is a protocol to find services, not to use them, and WinAmp imho doesn’t support Bonjour anyway, you can just use the stream address directly in WinAmp (since you know it, no sense in using Bonjour there)?

    #7776

    EVILRipper
    Participant

    Indeed. Bonjour is only a protocol.
    But it can also be downloaded for windows on the apple site:
    http://www.apple.com/support/downloads/bonjourforwindows.html

    This program adds a “tab” to internet explorer with all the found items on the network.
    Currently I’m at home, and it shows the firefly share.

    And indeed, Winamp doesnt support bonjour -officially-. But I found a plugin that uses Bonjour to fill a Playlist full of HTTP streams.

    And what I’m trying to do is that Bonjour sees the Firefly stream just like it does right now (@ home) but then at school.

    I was hoping it was as easy as to SSH tunnel the stream to localhost, and Bonjour would see the share, but it seems it isn’t. So hereby my question, any idea how I enable it to see it?

    #7777

    rpedde
    Participant

    @evilripper wrote:

    Indeed. Bonjour is only a protocol.
    But it can also be downloaded for windows on the apple site:
    http://www.apple.com/support/downloads/bonjourforwindows.html

    This program adds a “tab” to internet explorer with all the found items on the network.
    Currently I’m at home, and it shows the firefly share.

    bonjour bookmarks are type _http._tcp, with a txt record including a “path” key/value pair, like “path=/absolute/uri.html”. So set up an entry just like the one for _daap._tcp, except use _http._tcp, and add a txt value of “path=/”

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.