You are here: Home » Topic » Soundbridge needs reboot to see Firefly after standby

Soundbridge needs reboot to see Firefly after standby

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues Soundbridge needs reboot to see Firefly after standby

This topic contains 14 replies, has 4 voices, and was last updated by  mmain 10 years, 6 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #1269

    mmain
    Participant

    I have a Pinnacle M1001 Soundbridge running against Firefly version svn-1515 on Fedora Core 5.

    When I power up the Soundbridge first time, it configures the network, gets an IP address issued and finds Firefly no problem. However, once I switch into standby, say overnight and power up, it can’t see Firefly. I have found that the easiest solution is to reboot from the system configuration menu and then it finds FireFly no problem.

    Whenever I run iTunes on Windows machines on my net, it always finds the FireFly database.

    Not sure where to start looking to fix this. mDNS is all setup and was a problem initially but, not an issue any longer.

    Many Thanks for any advice,

    Martin Main

    #10006

    fizze
    Participant

    I guess that you’ve set a DHCP lease time which is finite.
    One other thing might be that multicasts arent forwarded properly by your wireless router.

    How is your soundbridge connected to your music-server? And by what means?

    #10007

    mmain
    Participant

    Thanks for feedback.

    I have an entry in dhcpd.conf tied to the MAC address, so although the lease will get renewed it will always end up with the same IP.

    At the Soundbridge end I have a DLink DWL2100AP setup to connect to my main hub which is a DLink DI-624. The DI-624 has multicast streams enabled, there is no equivalent setting on the DWL2100AP. I am using this because it has more HP to connect upstairs where I have the DI-624 i.e. I am using the wired ethernet port on the Sounbridge as it could not find the DI-624 through its own wireless LAN.

    Thanks,

    Martin

    #10008

    fizze
    Participant

    Ok, so DHCP is not an issue. If you have a static DHCP entry, you might as well set up a client lease time of 0 (zero) 😉

    So you have 1 wireless AP (upstairs) and one wireless-to-ethernet bridge, which the soundbridge plugs into?

    #10009

    mmain
    Participant

    Not too sure how to set lease times on a per machine basism but have adjusted this up to 2 weeks renewal time.

    Confirm this is the network configuration I have.

    #10010

    mmain
    Participant

    I have not resolved this problem and after the period of time, the soundbridge needs a reboot. However, I have attempted to try svn-1528 and svn-1539 and when compiled under exactly the same environment as svn-1515, the soundbridge never sees the server at all.

    #10011

    rpedde
    Participant

    @mmain wrote:

    I have not resolved this problem and after the period of time, the soundbridge needs a reboot. However, I have attempted to try svn-1528 and svn-1539 and when compiled under exactly the same environment as svn-1515, the soundbridge never sees the server at all.

    Are you compiling with –enable-avahi, or with –enable-howl?

    Check to make sure you aren’t running another mdns responder, as you can’t run two. In fact, that would explain the other problem if you were already running an mdns responder and tried to run the built-in one.

    #10012

    mmain
    Participant

    I have compiled with –prefix=/usr –enable-mdns –enable-sqlite3 only on all three occasions. I don’t have any avahi or howl responders running.

    Interestingly I had svn-1515 running and the soundbridge playing music and did a make install on svn-1539 and restarted. The soundbridge recovered and continued playing. However, I did a reboot from the soundbridge menu and it can’t see the server.

    Was there some significant change beyond 1515?

    #10013

    rpedde
    Participant

    @mmain wrote:

    I have compiled with –prefix=/usr –enable-mdns –enable-sqlite3 only on all three occasions. I don’t have any avahi or howl responders running.

    Interestingly I had svn-1515 running and the soundbridge playing music and did a make install on svn-1539 and restarted. The soundbridge recovered and continued playing. However, I did a reboot from the soundbridge menu and it can’t see the server.

    Was there some significant change beyond 1515?

    1528 changed to the new apple bonjour libraries. Does it show it registering rendezvous?

    Try configuring it with –prefix=/usr –enable-sqlite3.

    Don’t use –enable-mdns.

    #10014

    mmain
    Participant

    Tried this but no better off, still can’t see the server from the soundbridge. Log file output as noted.

    2007-04-19 23:16:18 (b7ef56b0): Plugin loaded: rsp/svn-1539
    2007-04-19 23:16:18 (b7ef56b0): Plugin loaded: daap/svn-1539
    2007-04-19 23:16:18 (b7ef56b0): Starting rendezvous daemon
    2007-04-19 23:16:18 (b7ef56b0): Starting signal handler
    2007-04-19 23:16:18 (b7ef56b0): Initializing database
    2007-04-19 23:16:22 (b7ef56b0): Starting web server from /usr/share/mt-daapd/admin-root on port 3689
    2007-04-19 23:16:22 (b7ef56b0): Listening on port 3689
    2007-04-19 23:16:22 (b7ef56b0): Starting server thread
    2007-04-19 23:16:22 (b7ef56b0): Registering rendezvous names
    2007-04-19 23:16:22 (b7ef56b0): Serving 22206 songs. Startup complete in 4 seconds

    #10015

    rpedde
    Participant

    @mmain wrote:

    Tried this but no better off, still can’t see the server from the soundbridge. Log file output as noted.

    2007-04-19 23:16:18 (b7ef56b0): Plugin loaded: rsp/svn-1539
    2007-04-19 23:16:18 (b7ef56b0): Plugin loaded: daap/svn-1539
    2007-04-19 23:16:18 (b7ef56b0): Starting rendezvous daemon
    2007-04-19 23:16:18 (b7ef56b0): Starting signal handler
    2007-04-19 23:16:18 (b7ef56b0): Initializing database
    2007-04-19 23:16:22 (b7ef56b0): Starting web server from /usr/share/mt-daapd/admin-root on port 3689
    2007-04-19 23:16:22 (b7ef56b0): Listening on port 3689
    2007-04-19 23:16:22 (b7ef56b0): Starting server thread
    2007-04-19 23:16:22 (b7ef56b0): Registering rendezvous names
    2007-04-19 23:16:22 (b7ef56b0): Serving 22206 songs. Startup complete in 4 seconds

    Do you have a “mDNSResponder” or an “avahi-daemon” running? This is fc5 for intel, right?

    anything funky? Multinetted, multihomed, or aliases on an interface? Anything stranger than a straight eth0 connected to local lan?

    #10016

    mmain
    Participant

    mDNSresponder and avahi-daemon are not running, both are disabled in fc5 startup.

    The machine has two ethernet cards serving as a firewall between the local lan (eth0) and the adsl modem (eth1). The firewall runs under firestarter, which I had to manually amend originally to get multicast operating correctly, which under default configuration does not route.

    I should probably point out that whilst the soundbridge does not seem to work with the later versions (1528, 1539), running iTunes from windows is fine.

    #10017

    rpedde
    Participant

    @mmain wrote:

    mDNSresponder and avahi-daemon are not running, both are disabled in fc5 startup.

    The machine has two ethernet cards serving as a firewall between the local lan (eth0) and the adsl modem (eth1). The firewall runs under firestarter, which I had to manually amend originally to get multicast operating correctly, which under default configuration does not route.

    I should probably point out that whilst the soundbridge does not seem to work with the later versions (1528, 1539), running iTunes from windows is fine.

    Did it ever work in this machine with firestarter running?

    And are you saying that you can see the server from a windows client, but not from the soundbridge client? Is that right? I’m not sure what that would point to. Multicast problems on the wireless access point? Could you move the sb to the wired network for testing?

    Do you have a wireless laptop you could run on the wireless side to see if iTunes could see the it from a laptop on the wireless net?

    Strange…

    If that’s the case, then it

    #10018

    taboman
    Participant

    I am not having the same setup, but I had a similar problem. My FireFly was sitting on the ethernet side, but both soundbridges and also iTunes where on WLAN. Problem was, that after a few minutes/hours the FireFly did disappear from the WLAN side of the router.

    I did traces and stuff and finally found the issue to be the router itself. I have tried Zyxel, D-Link and Netgear, all had the same problem. I now switched to Linksys and the problem disappeared.

    You can also check if your router has something called “WLAN isolation”, which will prevent two WLAN devices to see each other. Try turning this off. Otherwise, your only help is to replace the WLAN router.

    Ron

    #10019

    mmain
    Participant

    I ended up getting this hooked up through a pair of dLan adaptors, which allowed me to network the soundbridge via the mains supply. This works a treat with all svn versions and minimal configuration effort. The DLink DWL2100AP seems to have been the cause of my problems and is certainly blocking some traffic, although nothing documented or configurable to overcome this.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.