You are here: Home » Topic » Soundbridge connection issues

Soundbridge connection issues

This topic contains 3 replies, has 2 voices, and was last updated by  rpedde 9 years, 9 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2073

    Anonymous

    Hi there,

    I have just bought myself a Pinnacle Soundbridge and am having a few problems connecting it to my server. I have a knoppmyth (media centre set up based upon knoppix) computer which is holding all of my music and have downloaded and installed mt-daapd. Now the server seems to be running fine as i can view its web interface happily using a web browser. The problem seems to be that whenever i have to restart my mythbox i then have to do one of two things (or in some cases both) to get my soundbridge to connect again.

    I either have to

    1) Change the name of the server using the web interface
    2) Using a command prompt run ‘mt-daapd stop’ followed by ‘mt-daapd’ restart.

    Its a right pain in the bottom. If anyone has any ideas on what might be going on or how to rectify it i would be very grateful.

    Many thanks

    Rob

    #15420

    rpedde
    Participant

    @rflook wrote:

    Hi there,

    I have just bought myself a Pinnacle Soundbridge and am having a few problems connecting it to my server. I have a knoppmyth (media centre set up based upon knoppix) computer which is holding all of my music and have downloaded and installed mt-daapd. Now the server seems to be running fine as i can view its web interface happily using a web browser. The problem seems to be that whenever i have to restart my mythbox i then have to do one of two things (or in some cases both) to get my soundbridge to connect again.

    I either have to

    1) Change the name of the server using the web interface
    2) Using a command prompt run ‘mt-daapd stop’ followed by ‘mt-daapd’ restart.

    Its a right pain in the bottom. If anyone has any ideas on what might be going on or how to rectify it i would be very grateful.

    Many thanks

    Rob

    My guess is that your server is blocking inbound multicast.

    Specifically, it has to allow inbound UDP port 5353 from 224.0.0.251, and allow sending to udp port 5353 to 224.0.0.251.

    In addition, there has to be a route for the multicast network (224.0.0.0/4) to the inside interface on your network.

    Not sure what your myth box sets up for iptables, but that’s where to check.

    — Ron

    #15421

    Anonymous

    Cool, cheers for that. I have no idea how to do anything wit iptables but i will look into it.

    #15422

    rpedde
    Participant

    @rflook wrote:

    Cool, cheers for that. I have no idea how to do anything wit iptables but i will look into it.

    It’s possible it could also be your wireless router, if your sb and server are separated by wireless. Check the admin page of your router and see if it has any options for IGMP or Multicast (or multicast filtering) and try fiddling with the settings.

    A firmware update might be a win, too.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.