You are here: Home » Topic » soundbridge cannot connect to mt-daapd under linux

soundbridge cannot connect to mt-daapd under linux

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues soundbridge cannot connect to mt-daapd under linux

This topic contains 5 replies, has 2 voices, and was last updated by  rpedde 10 years, 4 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1225

    mathias
    Participant

    I have recently bought a Pinnacle Soundbridge M1001 which I like a lot.

    In the cellar I have an old PC Linux server running OpenSuSE 10.2, and the idea is to serve the music archive from this machine.

    When I install Firefly (nightly builds 1498, 1515) with or without avahi-compat-howl, everything seems to work, I get to the web interface and things look normal (with avahi-compat, the server indicates that bonjour is running). However, the soundbridge does _not_ recognize the server.

    The windows Firefly version (1.0svn-1459) works without further ado, like a charm. I don’t want to let my windows box on day and night, however.

    Firefly under windows uses port 9999. On the linux box I have tried both ports 3689 and 9999, to no avail.

    Please, anybody, help me! What am I missing? I really would like to get this setup to work.

    #9774

    rpedde
    Participant

    @mathias wrote:

    I have recently bought a Pinnacle Soundbridge M1001 which I like a lot.

    In the cellar I have an old PC Linux server running OpenSuSE 10.2, and the idea is to serve the music archive from this machine.

    When I install Firefly (nightly builds 1498, 1515) with or without avahi-compat-howl, everything seems to work, I get to the web interface and things look normal (with avahi-compat, the server indicates that bonjour is running). However, the soundbridge does _not_ recognize the server.

    The windows Firefly version (1.0svn-1459) works without further ado, like a charm. I don’t want to let my windows box on day and night, however.

    Firefly under windows uses port 9999. On the linux box I have tried both ports 3689 and 9999, to no avail.

    Please, anybody, help me! What am I missing? I really would like to get this setup to work.

    With avahi-compat, make sure you are running the avahi daemon, for starters. Check your process list. Also, I’m not really familiar with opensuse, but check your firewall settings. Try turning them off, first, and if it works, then see if you can turn it back on, but enable multicast.

    If you server and the soundbridge are between a wired/wireless boundary — i.e. one of them is wired and the other is wireless, check your router and see if it has an option to enable multicast or IGMP.

    That’s what I can think of offhand, anyway.

    #9775

    mathias
    Participant

    Thanks for the fast reply.

    I should have mentioned that the firewall is disabled. I can connect to mt-daapd on ports 9999 (3689) from another machine and access the web interface. Also, my pinnacle soundbridge m1001 uses software version 2.7.78 (the newest).

    The problem with the wireless/wired boundary should apply to the windows server too. The router has no such options, but obviously it works with the windows server.

    When I start avahi befor mt-daapd, mt-daapd indicates that Bonjour is stopped, when I start it afterwards or not at all, on the web interface everything seems o.k. It doesn’t make a difference though.

    Should itunes recognize mt-daapd? It doesn’t either.

    Well, obviously I’m missing something. What is it?

    Thanks again!

    #9776

    rpedde
    Participant

    @mathias wrote:

    Thanks for the fast reply.

    I should have mentioned that the firewall is disabled. I can connect to mt-daapd on ports 9999 (3689) from another machine and access the web interface. Also, my pinnacle soundbridge m1001 uses software version 2.7.78 (the newest).

    The problem with the wireless/wired boundary should apply to the windows server too. The router has no such options, but obviously it works with the windows server.

    When I start avahi befor mt-daapd, mt-daapd indicates that Bonjour is stopped, when I start it afterwards or not at all, on the web interface everything seems o.k. It doesn’t make a difference though.

    Should itunes recognize mt-daapd? It doesn’t either.

    Well, obviously I’m missing something. What is it?

    Thanks again!

    If you’ve upgraded from stable, try deleting your config file and using the one from the contrib folder (after editing, of course). Sounds like it’s missing the plugins_dir.

    #9777

    mathias
    Participant

    Wow, finally it works! I would kiss you if I could — now there are more advantages to cyberspace than might at first be obvious…

    I must have compiled various versions of mt-daapd a hundred times. Now this worked for me:

    ./configure –enable-sqlite –enable-mdns

    and in mt-daapd.conf

    [general]
    web_root = /usr/share/mt-daapd/admin-root
    port = 3689
    admin_pw = mt-daapd
    db_dir = /var/cache/mt-daapd
    mp3_dir = /home/mathias/musicke
    servername = thermix
    runas = mathias
    playlist = /etc/mt-daapd.playlist
    extensions = .mp3,.m4a,.m4p
    [plugins]
    plugin_dir = /usr/local/share/mt-daapd/plugins

    Seems simple, but took me forever…

    Thanks again for your help and support.

    Greets, Mathias

    #9778

    rpedde
    Participant

    @mathias wrote:

    Wow, finally it works! I would kiss you if I could — now there are more advantages to cyberspace than might at first be obvious…

    Saved by the intarweb again. 🙂

    Thanks again for your help and support.

    Greets, Mathias

    np. I need to add some attempts to auto-locate the directory… it would help people significantly, as it seems to be a growing problem.

    Note to self…

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.