You are here: Home » Topic » Songs starting in the middle

Songs starting in the middle

This topic contains 6 replies, has 2 voices, and was last updated by  johnso_i 12 years, 6 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #32

    johnso_i

    I am seeing a problem with some mp3 starting from the middle or close to the end. Also when this happens the time changes from the correct value to say 10 seconds. If you play the mp3 directly you have no problems.

    I have tried removing the database and rescanning, but the same songs still have the problem. I have has this problem on 0.2.1.1 and also tried cvs-20050320.

    Anyone else seen the problem?

    #3165

    velociped
    Participant

    What happens when you play these tracks directly?
    (e.g. from the file itself and not through a share)

    Is the file size much smaller than expected?

    It sounds as though the file has become corrupted. You might check the log file to see if anything has been logged with respect to these particular files. Probably unlikely given that they are being added to the database and served, but it would not hurt to check.

    Herman

    #3166

    rpedde
    Participant

    I’m not sure exactly what you are saying is happening here.

    Are you saying that when you first connect, a particular song shows a correct song length, but as soon as you play it through iTunes, the song length changes to something less? Like 10 seconds?

    If so, that’s a “bad tag” problem. iTunes is reading the tag (since it can’t read the tag until it starts streaming the song) and the header must be wrong, causing it to decided that the song is only 10 seconds long.

    You might try removing the id3 tag from that song and retagging it, then seeing what it does.

    #3167

    johnso_i

    I am having the problems with different mp3’s, so I do not think the problem is with the tags or the files being corrupt as if I access the Linux server over a samba share Winamp is able to play the track from the beginning.

    To try to explain it better when look at the song in iTunes 4.7.1.30 it show you the correct Time of the song for example 5:08 but when you play the song the time has changed to 2:25 and the song starts playing skipping the first 2:43 minutes of the song.

    From the log file :

    2005-03-30 14:31:01: Session 0: Streaming file ’03 Sometimes You Can’t Make It On Yo.mp3′ to 192.168.151.91 (offset 0)

    Thanks
    Ian

    #3168

    velociped
    Participant

    Ian,

    I an still guessing that you are dealing with an id3 tag or header corruption issue. Not being familiar with Winamp and the degree to which it accommodates errors, I can only suggest that being able to play the tracks in question via a Samba share using that client may not be diagnostic enough.

    What happens when you mount the share and attempt to play the tracks through iTunes instead?

    If you would be willing to send me a tarball containing one or more of the files in question, I would be happy to try to help diagnose the issue.

    Herman
    [Herman.May@earthling.net]

    #3169

    rpedde
    Participant

    Yup, that sounds like exactly what happens with a bad id3 tag.

    Try removing the id3 tag and retagging it. I’m sure it will fix it.

    mt-daapd is sending the whole file, starting at the beginning (offset 0). iTunes is interpreting the tag badly and starting in the middle of the file.

    If it will play in winamp, retagging it will fix it.

    — Ron

    #3170

    johnso_i

    You were right, I removed all the tags and then added them again and now everything is working fine.

    Thanks for your help 🙂

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.