You are here: Home » Topic » smart playlists not updating!

smart playlists not updating!

This topic contains 9 replies, has 3 voices, and was last updated by  dfsuther 10 years, 11 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1463

    dfsuther
    Participant

    I have a bunch of smart playlists written to exclude recently played tunes. I seem to recall that they once worked (some months back); now, they never update. I always have the same tunes at the head of each of them.

    I can play a dozen tunes on my Soundbridge. Disconnect, reconnect — same dozen tunes at the head of the list. Connect from one of my Macs. Same dozen tunes at the head of the list. I read a post either here or over at Roku’s fora that you have to reconnect to see playlist changes, so I tried connecting the soundbridge to a different server, then reconnecting to FireFly
    . Same dozen tunes at the head of the list.

    There must be some terribly obvious thing I’m doing wrong. What on earth is it?

    #11093

    fizze
    Participant

    First of all, what version of firefly are you running?
    Second: How exactly did you set up your “smart” playlist?
    Does it come from iTunes.XML ?
    Did you specify it manually through firefly’s web-admin?

    #11094

    dfsuther
    Participant

    @fizze wrote:

    First of all, what version of firefly are you running?
    Second: How exactly did you set up your “smart” playlist?
    Does it come from iTunes.XML ?
    Did you specify it manually through firefly’s web-admin?

    I’ll check the version when I get home.
    I set up the smart playlist through firefly’s web-admin. It should be using firefly’s internal last-played date (whatever the proper name was).

    When I get home I’ll copy the exact syntax of the playlist expression into a reply to this message.

    #11095

    fizze
    Participant

    That sure sould help. 🙂

    In other news, feel free to check against:
    http://trac.fireflymediaserver.org/wiki/SmartPlaylists

    for all available date fields.

    #11096

    dfsuther
    Participant

    I originally used that very reference when writing the smart playlist expressions. Thanks for the pointer, though, as I had lost the URL and had only my tattered paper copy.

    #11097

    dfsuther
    Participant

    And here’s the actual information. I’m using Firefly version svn-1376. A sample smart playlist that doesn’t update is specified as:


    genre includes "Jazz" AND time_played before 3 weeks before today

    another is


    genre includes "Classical" AND time_played before 5 weeks before today AND comment !includes "Holiday"

    Neither of these playlists updates successfully.

    I’d be perfectly happy to update to a different version of Firefly, or make whatever other changes y’all suggest, but I had some trouble figuring out which nightly would be be a better choice. 😕

    #11098

    rpedde
    Participant

    @dfsuther wrote:

    And here’s the actual information. I’m using Firefly version svn-1376. A sample smart playlist that doesn’t update is specified as:


    genre includes "Jazz" AND time_played before 3 weeks before today

    another is


    genre includes "Classical" AND time_played before 5 weeks before today AND comment !includes "Holiday"

    Neither of these playlists updates successfully.

    I’d be perfectly happy to update to a different version of Firefly, or make whatever other changes y’all suggest, but I had some trouble figuring out which nightly would be be a better choice. 😕

    If those are transcoded files, that might be the problem. At some point, there was a fix for updating last played on transcoded files. Other than that, I’m not sure. If you have a particular song that you can identify, you can try playing the whole song at -d9, and watch for the “update play_count, last_played” query in the logs.

    If you dont’ see it, that’s the culprit.

    But I’m kind of thinking now that it might be the transcoding thing, if they are transcoded.

    — Ron

    #11099

    dfsuther
    Participant

    Files are 160Kbps AAC files. I have plenty of files that get transcoded (from Apple Lossless), but these particular files aren’t.

    Any suggestions of a reasonably-stable more-modern version to try?

    #11100

    rpedde
    Participant

    @dfsuther wrote:

    Files are 160Kbps AAC files. I have plenty of files that get transcoded (from Apple Lossless), but these particular files aren’t.

    Any suggestions of a reasonably-stable more-modern version to try?

    1498 is stable, and recent nightlies seem stable. Between those two, not so much. 🙂

    #11101

    dfsuther
    Participant

    @rpedde wrote:

    1498 is stable, and recent nightlies seem stable. Between those two, not so much. 🙂

    I’ve finally downloaded and installed 1498. It fixes my problem completely.

    Thanks for the advice.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.