You are here: Home » Topic » Running mt-daapd on openWRT

Running mt-daapd on openWRT

This topic contains 14 replies, has 4 voices, and was last updated by  rpedde 11 years, 8 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #1007

    steinb_i
    Participant

    Hi from Hamburg (Germany)!
    First, thanks for this great piece of code. On my ubuntu server system it runs perfectly!

    I would like to run another streaming server on my router. The router runs with openWRT RC4 . I guess there are people who were able to run it. Not me! I installed the package i found. The debug info shows that it runs fine. But it never shows up in itunes!

    Any hints?
    Thanks for your interest.

    Till

    #8572

    fizze
    Participant

    Moinmoin nach Hamburg. 🙂

    Either your router doesn’t properly allow multicasts.

    What router are you running? I suspect a WRT54 of some sort;)
    What does the syslog say?
    if mt-daapd is unable to acces the mp3_dir, it terminates.
    For a test you could just specify an empty directory where the mt-daapd user has read permissions, so it would come up and you could access the web-interface.

    #8573

    steinb_i
    Participant

    It is a ASUS 500g Delux and i think it schould support multicast

    mt-daapd is able to access the mp3 dir and it add the songs to the database. So far it works fine. The web-interface does not work. After logging in I only get error pages. I think this is a conflict with the native web interface of openWRT but I’m not sure about that. I can live without the web interface thats not the problem.
    The bigger problem is that the server does not show up in iTunes. When the client comes up I can see the client packages with tcp-dump. But it looks like the server does not answer.

    #8574

    CCRDude
    Participant

    Since Fireflys (mt-daapds) admin pages are on port 3689, I doubt they would conflict with the native web interface.

    If you could post those errors here, maybe they’ll tell somebody something?

    #8575

    fizze
    Participant

    hm – can you post the source of the webpages, if you get any?

    also CCRDude is right, there really shouldnt be any conflicts, albeit you set the port to 80 😛

    Can you run mt-daapd with -d 9 and post the log?
    be aware though, that log level is really verbosive.

    #8576

    steinb_i
    Participant

    First Debug messages:

    [email protected]:~# mt-daapd -d 9 -f
    Read web_root: /usr/share/mt-daapd/admin-root
    Read port: 3689
    Read admin_pw: mt-daapd
    Read db_dir: /var/cache/mt-daapd
    Read mp3_dir: /var/cache
    Read servername: mt-daapd
    Read runas: root
    Read playlist: /etc/mt-daapd.playlist
    Read extensions: .mp3,.m4a,.m4p
    Checking existence of /tmp/cache
    Checking existence of /tmp/cache/mt-daapd
    Starting rendezvous daemon
    Starting signal handler
    Loading playlists
    Signal handler started
    Initializing database
    Finished loading smart playlists
    Adding smart playlist AAC Files as 5
    Adding new playlist AAC Files
    Added playlist
    Adding smart playlist Non-DRMed Music as 4
    Adding new playlist Non-DRMed Music
    Added playlist
    Adding smart playlist Recently Added as 3
    Adding new playlist Recently Added
    Added playlist
    Adding smart playlist 60's Music as 2
    Adding new playlist 60's Music
    Added playlist
    Building playlists
    Loaded database... found 0 songs
    Starting mp3 scan
    Foreground scanning for MP3s in /tmp/cache
    Found /tmp/cache/mt-daapd
    Found dir mt-daapd... recursing
    Found /tmp/cache/mt-daapd/songs.gdb
    Found /tmp/cache/songs.gdb
    Initial update over. Removing stale items
    Done removing stale items
    Reorganizing db
    Reorganize done
    Finding deleted static playlists
    Starting web server from /usr/share/mt-daapd/admin-root on port 3689
    Preparing to listen on port 3689
    Starting server thread
    Registering rendezvous names
    Scanned 0 songs in 0 seconds

    And websource


    error: hdr.html out of web root


    Welcome




    This is the administrative web interface for
    mt-daapd




    About


    mt-daapd is a multi-threaded pthreads implementation of Apple's DAAP
    server. It works for me, it might work for you, too. No promises
    though. See the section below titled "No Warranty". This work,
    although released under the GNU General Public License, is Copyright
    (C) 2003 Ron Pedde. All Rights reserved. See the link labeled "GPL
    License" for more information.

    Legal Crap

    Portions of this program are Copyright (c)
    1999-2001 Apple Computer, Inc. All Rights Reserved. See the link
    labeled "ASPL License" for more information.


    No Warranty


    BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY
    FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN
    OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES
    PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED
    OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
    MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS
    TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE
    PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING,
    REPAIR OR CORRECTION.





    error: ftr.html out of web root

    #8577

    fizze
    Participant

    ok, this looks like the classy “nightly installed over 0.2.4” issue. 😉

    remove your mt-daapd.conf, and reinstall from the nightly. The old config file isnt compatible with the new one.

    #8578

    steinb_i
    Participant

    That was not the nightly package. It was a package from openWrt.org.
    See: http://www.ipkg.be/package/2043919

    I’m not able to install the nightly, cause I can not satisfy the dependencies.

    #8579

    rpedde
    Participant

    @steinb_i wrote:

    That was not the nightly package. It was a package from openWrt.org.
    See: http://www.ipkg.be/package/2043919

    I’m not able to install the nightly, cause I can not satisfy the dependencies.

    It looks like it’s advertising itself. Do have you “search for shared music” enabled in your iTunes preferences?

    #8580

    steinb_i
    Participant

    yes! iTunes finds another mt-daapd that is running on a Ubuntu sysytem. The problem must be on the openWRT system

    #8581

    rpedde
    Participant

    @steinb_i wrote:

    yes! iTunes finds another mt-daapd that is running on a Ubuntu sysytem. The problem must be on the openWRT system

    It might be that it doesn’t see the interfaces right… they have some kind of crazy interfaces on those — vlans, etc.

    Do you have a howl or a avahi package for that platform? Maybe you can use howl or avahi for advertisement and then run mt-daapd without the mdns advertiser (-m)

    #8582

    steinb_i
    Participant

    there is a howl package, but i have no idea how to use that thing! 😉

    #8583

    rpedde
    Participant

    @steinb_i wrote:

    there is a howl package, but i have no idea how to use that thing! 😉

    Should be able to install the howl package and set a mDNSResponder.conf (int /etc/howl?) that looks like:


    My-server _rsp._tcp local. 3689
    My-server _daap._tcp local. 3689

    Then run the mDNSResponder and it should show up in iTunes, even without mt-daapd running (course, you won’t be able to connect…)

    Then start mt-daapd with the -m argument, and it will not try to advertise mdns.

    — Ron

    #8584

    steinb_i
    Participant

    hmmm! interessting:

    [email protected]:~# mDNSBrowse
    [assert] error: 146 (Connection refused)
    [assert] where: “socket.c”, “sw_socket_tcp_connect”, line: 720

    could that be the prolem with mt-daapd?

    #8585

    rpedde
    Participant

    @steinb_i wrote:

    hmmm! interessting:

    [email protected]:~# mDNSBrowse
    [assert] error: 146 (Connection refused)
    [assert] where: “socket.c”, “sw_socket_tcp_connect”, line: 720

    could that be the prolem with mt-daapd?

    certainly seems to be a problem of some kind, although I’m not sure what that is. Firewalled against localhost? Hostname set to the external interface, not the internal interface?

Viewing 15 posts - 1 through 15 (of 15 total)

The forum ‘Setup Issues’ is closed to new topics and replies.