You are here: Home » Topic » Roku M1001 plays radio but sees no Firefly library

Roku M1001 plays radio but sees no Firefly library

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues Roku M1001 plays radio but sees no Firefly library

This topic contains 14 replies, has 2 voices, and was last updated by  fizze 8 years, 11 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #2700

    echtepino
    Participant

    mt-daapd/Firefly Version: svn-1441
    Server Operating System: XP SP3
    Server Hardware: AMD, 2100 MHz
    Client Device: Visual MR
    Also tried using: iBridge
    Connection of clients: wired through router static IP (connection working)

    Web interface: http://localhost:3689/index.html Bonjour running, FF running, 21 songs (shows)

    Roku plays radio but doesn’t see FF library.
    Firefly log:

    2008-11-15 16:06:59 (8d6efdc2): Firefly Version svn-1441: Starting with debuglevel 2
    2008-11-15 16:06:59 (8d6efdc2): Starting rendezvous daemon
    2008-11-15 16:06:59 (8d6efdc2): Building drive mapping table from D:Program FilesFirefly Media Servermapping.ini
    2008-11-15 16:06:59 (8d6efdc2): Initializing database
    2008-11-15 16:06:59 (8d6efdc2): Starting web server from D:Program FilesFirefly Media Serveradmin-root on port 3689
    2008-11-15 16:06:59 (8d6efdc2): Registering rendezvous names
    2008-11-15 16:06:59 (8d6efdc2): Serving 21 songs. Startup complete in 0 seconds

    Anybody an idea?

    #17893

    fizze
    Participant

    Do you have bonjour running?
    Is your firewall setup to allow bonjour and firefly access to the network?

    Can the soundbridge see the server and just not connect, or can’t it see your share at all?

    #17894

    echtepino
    Participant

    Thnx for your reply.
    Yes, bonjour is running.
    Bonyour service is allowed, Firefly service is allowed in McafeeFirewall.
    The last question I don’t understand…
    Soundbridge connects to the router but it can’t see the library (No music library found).

    #17895

    fizze
    Participant

    I am almost sure that McAffee is the culprit. Make sure you allow multicasts/unicasts. That is how firefly announces itself on the network.

    To make sure, just disable McAffee and set it to allow all traffic – for a short time – and then check if the soundbridge can see it.

    #17896

    echtepino
    Participant

    Nope it can’t be McAfee… since yesterday I use McAfee, before I used ZoneAlarm, even when I disabled ZA I couldn’t see the library.
    Multicast I can only use/set on the (Speedtouch) Router in WiFi-mode, this Soundbridge is ethernet not wireless.

    #17897

    fizze
    Participant

    Ew, ZA….. the last time I used ZA it blocked everything when you disabled it.
    Well if you’re certain…

    Then I suggest you grab wireshark or tcpdump and start to look for those multicast packets on the wire.

    #17898

    echtepino
    Participant

    That goes beyond my knowledge, thnx for the help….

    #17899

    fizze
    Participant

    Using Wireshark isn’t that difficult actually.

    You can also try to wire the soundbridge to your PC directly with a crossover cable, eliminating the router.
    Did you try to enable the multicast settings anyway?

    #17900

    echtepino
    Participant

    The same config worked for years (two) and now I can’t get it into action
    There is no multicast setting in the Speedtouch ethernet settings…. strange?

    #17901

    echtepino
    Participant

    Does this help?



    #17902

    fizze
    Participant

    @echtepino wrote:

    The same config worked for years (two) and now I can’t get it into action

    Great that you mention this little detail πŸ˜‰
    Never change a running system! So what did you change, thats the culprit then.
    πŸ™„

    #17903

    echtepino
    Participant

    Yeah I know, if only I knew…. I thought It was just the firmwareupdate of the router….

    #17904

    fizze
    Participant

    Could be the case. Those SpeedTouch things are evil.
    You’re best off to get a real router and just use the speedtouch as DSL modem anyway.

    Could very well be that the speedtouch is blocking multicast packets. *shrug*

    You need to narrow down the options here. To rule out the speedtouch just wire the SB up to your PC directly.

    #17905

    echtepino
    Participant

    That’s a good idea, i’ll come back later!
    (Noob question): normal UTP or cross-cable?
    I also have a Fritzbox 7170 new-in-the-box, better?

    #17906

    fizze
    Participant

    You can try a direct cable but only if your computer is kinda new and detects crossover / direct cable. I’m not sure if the soundbridge does detect it, either.

    So short answer: try it, if the lights go blinky it’s looking good πŸ™‚

    Usually you need a cross-over cable to directly connect two devices with cat5.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.