You are here: Home » Topic » Rebuffering when changing to wireless

Rebuffering when changing to wireless

This topic contains 3 replies, has 2 voices, and was last updated by  uncleremus 9 years, 4 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2397

    uncleremus
    Participant

    Hello,

    I have recently switched to wireless on the computer that runs mt-daapd (svn-1696) in my network. I can now experience an increase of rebuffering at my Soundbridge, especially when I change song, but also during normal uninterrupted playback. Is there anything one can do to prevent this? Any configuration of mt-daapd? Maybe something on the server (Gentoo), can you prioritize traffic on a certain port ? Or at the router (Linksys WRT54GL)?

    #16882

    Anonymous

    The WRT54G does have the ability to give priority to the wired ethernet ports or to devices wired to those ports by name … see the QoS menu under “Applications and Gaming” in the Admin of the router, as shown on this page http://ui.linksys.com/files/WRT54G/v8/8.00.0/qos.htm

    Make sure you don’t have priority set for any of the wired ethernet ports or devices, as that will take priority over your other wireless devices. I don’t know if the Soundbridge supports the WMM priority setting at the bottom of that page under wireless QoS … in the rokulabs.com forums they usually say to turn that off (“Disable”).

    Otherwise, I think you are in the “weak signal” conundrum, where you can spend a lot of money and time on solutions until you find one that works for your particular situation. The easiest and cheapest are things like making sure the router isn’t sitting next to the broadband modem or any other device that might cause interference (I even tried aluminum foil under mine at one point). Removing the wireless landline phone from the room, etc. Sometimes moving the router slightly has a big effect. Changing broadcast channels in the router can sometimes get around interference from wireless phones, neighboring networks, etc.

    Some people are having good success with the powerline “Homeplug” adapters such as the Actiontec 85 mbps units (you actually get a bit less than half that throughput), but they can be affected by things like dimmer switches, etc. They run about $80 for two (one at the router plugged into an ethernet port that you would then give priority, and one at your Soundbridge … it sends the signal over the power wire in your house).

    Some people are using access points to receive the signal with some gain due to their antennas, and then plugging the Soundbridge into the AP’s ethernet ports.

    Others Google “extend WRT54G range” and apply one of the firmware hacks that purports to increase wireless range (I have no idea how well these work … they seem to be complicated from a set up standpoint).

    #16883

    Anonymous

    The WRT54G does have the ability to give priority to the wired ethernet ports or to devices wired to those ports by name … see the QoS menu under “Applications and Gaming” in the Admin of the router, as shown on this page http://ui.linksys.com/files/WRT54G/v8/8.00.0/qos.htm

    Make sure you don’t have priority set for any of the wired ethernet ports or devices, as that will take priority over your other wireless devices. I don’t know if the Soundbridge supports the WMM priority setting at the bottom of that page under wireless QoS … in the rokulabs.com forums they usually say to turn that off (“Disable”).

    Otherwise, I think you are in the “weak signal” conundrum, where you can spend a lot of money and time on solutions until you find one that works for your particular situation. The easiest and cheapest are things like making sure the router isn’t sitting next to the broadband modem or any other device that might cause interference (I even tried aluminum foil under mine at one point). Removing the wireless landline phone from the room, etc. Sometimes moving the router slightly has a big effect. Changing broadcast channels in the router can sometimes get around interference from wireless phones, neighboring networks, etc.

    Some people are having good success with the powerline “Homeplug” adapters such as the Actiontec 85 mbps units (you actually get a bit less than half that), but they can be effected by things like dimmer switches, etc. They run about $80 for two (one at the router plugged into an ethernet port that you would then give priority, and one at your Soundbridge … it sends the signal over the power wire in your house).

    Some people are using access points to receive the signal with some gain due to their antennas, and then plugging the Soundbridge into the AP’s ethernet ports.

    Others Google “extend WRT54G range” and apply one of the firmware hacks that purports to increase wireless range (I have no idea how well these work … they seem to be complicated from a set up standpoint).

    #16884

    uncleremus
    Participant

    Thanks a lot for your reply, I will try this out and report the results afterwards.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.