You are here: Home » Topic » Promblem Playing FLAC files

Promblem Playing FLAC files

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1018
    bkaatz
    Participant

    I’ve added the extension .flac to the list of extensions listed in the online FF configuration and added a the music folder containing all my .flac files (and just a few .mp3 files). SB sees the .flac files, displays the song names with a little “x” in front of each file name, and will not play them.

    Do I need a plug-in or to change additional configuration settings? I’m thinkin the problem is with transcoding. After consulting the wiki, I changed the adv. config. of the SSC Program to: ssc_prog /usr/local/sbin/mt-daapd-ssc.pl and then the SSC Codec Types to: ssc_codectypes flac,shn,ogg,alac. Still didn’t work after the complete re-scan (even delected the songs.db file first).

    Additionally, is there an app that will help me organize my .flac files so they will be browsable in SB by ARTIST and ALBUM without changing the file names of the .flac files?

    #8628
    rpedde
    Participant

    @bkaatz wrote:

    I’ve added the extension .flac to the list of extensions listed in the online FF configuration and added a the music folder containing all my .flac files (and just a few .mp3 files). SB sees the .flac files, displays the song names with a little “x” in front of each file name, and will not play them.

    Do I need a plug-in or to change additional configuration settings? I’m thinkin the problem is with transcoding. After consulting the wiki, I changed the adv. config. of the SSC Program to: ssc_prog /usr/local/sbin/mt-daapd-ssc.pl and then the SSC Codec Types to: ssc_codectypes flac,shn,ogg,alac. Still didn’t work after the complete re-scan (even delected the songs.db file first).

    Additionally, is there an app that will help me organize my .flac files so they will be browsable in SB by ARTIST and ALBUM without changing the file names of the .flac files?

    You need two things… to pick up the metadata (which will give you the artist and album info in the db), you need to configure with “–enable-flac”, and have the flac libs and whatnot installed (via fink or darwinports, probably).

    As far as transcoding, you may have better luck with mt-daapd-ssh.sh. You’ll need to edit it and put in the full paths to the files up at the top… like instead of:


    FLAC=flac

    you’ll need to do something like:


    FLAC=/sw/bin/flac

    For example. You’ll want to change all the other files up at the top the same way — flac, alac, oggdec, and wavstreamer (probably in /usr/local/bin, based on your example above).

    — Ron

    #8629
    bkaatz
    Participant

    Hmmm. There is much in your response that I do not understand. So I’ll try to summarize my current issue/s:

    Changing my Transcoding settings as I mentioned above didn’t allow me to play .flac files AND I lost my ability to play the Apple Lossless files. There are now little “x”s in front of the Apple Lossless file names when viewed thru SB. Changing the settings back to what I thought they were originally (SSC Program: ./mt-daapd-ssc.sh and SSC Codec Types: alac) did not return my ability to play Apple Lossless files.

    I accidently deleted the additional Library Folder I had pointed to the folder on my external drive where I keep my .flac files and now FF won’t let me add it back (“/volume/maxtor/music/lossless” and the error i get is “Error: 500general:mp3_dir”). I’m new to the Mac…but I manage to get that folder viewable via SB this morning – even if the .flac files wouldn’t play.

    Here is what is currently in the three fields to which i have made changes today via the online configuration tool:

    MUSIC FILES/Extensions = .mp3,.m4a,.m4p,.aiff,.flac
    TRANSCODING/SSC Program = ./mt-daapd-scc.sh
    TRANSCODING/SSC Codec Types = FLAC=/sw/bin/flac

    Let me know if there are any other settings you need to see.

    Sorry I couldn’t figure out how to quote your post properly and had to resort to this. 😳

    #8630
    rpedde
    Participant

    @bkaatz wrote:

    Hmmm. There is much in your response that I do not understand.

    Okay, so I’m to assume that you didn’t build it from source, but rather are trying to get the nightlies as installed from the .dmg to do flac on the mac?

    That will be hard. Easiest way would be to rebuild it from scratch and then toss he binaries that you build into the right places to make the prefs pane and stuff continue to work. The problems you are going to have is that you don’t have a program to do the transcoding (as firefly relies on an external program [flac] to do the transcoding).

    Likewise, you won’t have metadata — album, title, artist, etc, since you don’t have the flac libraries necessary to read that info.

    It will take some work to get it all built. Is that something you want to do? You’ll have to install fink, the program used to install unix libraries and stuff, and then building it from source. It isn’t terribly hard, though. If you want to tackle it, I’m willing to help.

    I accidently deleted the additional Library Folder I had pointed to the folder on my external drive where I keep my .flac files and now FF won’t let me add it back (“/volume/maxtor/music/lossless” and the error i get is “Error: 500general:mp3_dir”). I’m new to the Mac…but I manage to get that folder viewable via SB this morning – even if the .flac files wouldn’t play.

    Check from the terminal, and make sure that’s the right folder, and that case is right.

    MUSIC FILES/Extensions = .mp3,.m4a,.m4p,.aiff,.flac
    TRANSCODING/SSC Program = ./mt-daapd-scc.sh
    TRANSCODING/SSC Codec Types = FLAC=/sw/bin/flac

    ssc codec types shold be “alac,flac” (the flac still won’t work, but that’s what it should be).

    I’ve already promised a couple folks that I’d work on flac, so maybe I’ll give that a shot yet this weekend.

    — Ron

    #8631
    bkaatz
    Participant

    Thanks so much for your help. I think I’m gonna hold off on the .flac thing for now. I think I will set up a separate iTunes library for my lossless collection and translate the .flac files to Apple Lossless.

    With that goal in mind, per your instructions I changed the SSC Codec Type to “alac” and I’m still getting the “unable to play…” error on the SB when trying to play the apple lossless files. This is very frustrating since it was working before I started changing stuff in the three fields.

    If you can help me get the Apple Lossless back and help me with pointing FF to the right place on my external hard drive…I would be most appreciative.

    #8632
    rpedde
    Participant

    @bkaatz wrote:

    Thanks so much for your help. I think I’m gonna hold off on the .flac thing for now. I think I will set up a separate iTunes library for my lossless collection and translate the .flac files to Apple Lossless.

    With that goal in mind, per your instructions I changed the SSC Codec Type to “alac” and I’m still getting the “unable to play…” error on the SB when trying to play the apple lossless files. This is very frustrating since it was working before I started changing stuff in the three fields.

    If you can help me get the Apple Lossless back and help me with pointing FF to the right place on my external hard drive…I would be most appreciative.

    Double check your ssc script, it should be:

    ./mt-daapd-ssc.sh (*not* ./mt-daapd-scc.sh)

    and

    Make sure you have “alac”, not “.alac” in the ssc codecs.

    — Ron

    #8633
    bkaatz
    Participant

    Will give it a try. Do I have to force a complete rescan (by tossing the songs.db file)?

    Re the problem i’m having pointing FF to the right place on my external hard drive: can you make that field (ADD MUSIC FOLDER) browseable?

    #8634
    rpedde
    Participant

    @bkaatz wrote:

    Will give it a try. Do I have to force a complete rescan (by tossing the songs.db file)?

    Re the problem i’m having pointing FF to the right place on my external hard drive: can you make that field (ADD MUSIC FOLDER) browseable?

    It’s harder than it seems, but I’ve got the xml functions on the server side for server-side drive browsing. I hope to add it soonish.

    #8635
    bkaatz
    Participant

    just to let you know, i’m all good with streaming apple lossless and have the music files pointing to the right places now. will try to stay abreast of your .flac innovations.

    thanks a lot for you help and all your hard work!

    #8636
    removablebrain
    Participant

    Ron,

    Is it best to install the latest dmg from the nightlies, then build from source (as instructed above) if I want to get flac transcodes & the prefpane to work?

    #8637
    rpedde
    Participant

    @removablebrain wrote:

    Ron,

    Is it best to install the latest dmg from the nightlies, then build from source (as instructed above) if I want to get flac transcodes & the prefpane to work?

    That’s probably the “cheater” way to do it. Use fink or darwinports to install libflac, libvorbisfile, libogg, and flac. Then build your own version using “–enable-flac”. Then you can swap the binary you built with the binary in the dmg, and everything will work.

    I did do some research on this — building static libs looks *really* *ugly*. I did see that xiph has a universal framework for flac 1.1.2, so I might see if I can get it compiled with that.

    Still a while off, though – I have to fix breakage from the release of Visduh.

    — Ron

Viewing 11 posts - 1 through 11 (of 11 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.