You are here: Home » Topic » problems with win32 port

problems with win32 port

This topic contains 17 replies, has 1 voice, and was last updated by  rpedde 11 years, 5 months ago.

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #179

    rpedde
    Participant

    Post issues with the win32 port here. I hope to get this on par with the unix side quickly.

    Known issues:

    1. Paths in config file must be full paths, not relative paths
    2. Paths must be local, not UNC (I think?)
    3. sqlite3 doesn’t work (threading issues)

    Please post results here though.

    #3974

    rpedde
    Participant

    The only one left here is sqlite3. At least a brief look seems to show that it all seems to be working. Anyone?

    #3975

    politby

    I’m not getting mt-daapd on Windows to pick up iTunes playlists correctly. It shows the playlists, but they have no tracks in them.

    – Music files are in subfolders of “My DocumentsMy Music”
    – iTunes library files are in “My DocumentsMy MusiciTunes”
    – All paths in mt-daapd config file are absolute paths

    mt-daapd has loaded all tracks correctly, and again also shows the iTunes playlists – so evidently it has parsed the library file.

    Anything I can do to get the playlists right, or is this not working in the most recent nightly build?

    /POL

    #3976

    rpedde
    Participant

    The absolute paths thing isn’t a requirement anymore, but the paths have to be relative to the mt-daapd install directory, as that is the working directory of mt-daapd.

    I’ll spend some time looking at the itunes stuff on that, and will post here when I have something.

    — Ron

    #3977

    politby

    rpedde wrote:

    The absolute paths thing isn’t a requirement anymore, but the paths have to be relative to the mt-daapd install directory, as that is the working directory of mt-daapd.

    I’ll spend some time looking at the itunes stuff on that, and will post here when I have something.

    — Ron

    Hmm. So if mt-daapd is installed in C:Program Filesmt-daapd, then the location of the music files and iTunes library would have to be relative to that path? I don’t quite follow. If music files and iTunes folder are in the D:MediaMy Music tree as in my case, how does this work out?

    /POL

    #3978

    rpedde
    Participant

    no, sorry. Just that if you *don’t* use absolute paths, then directories are relative to the installed dir.

    For example if you put:


    mp3_dir = ..
    db_dir = db

    then mp3_dir would be “c:program files”, and db_dir would be “c:program filesmt-daapddb”

    You can still specify full paths, though, so d:wherever would be okay.

    #3979

    politby

    Ron, I think I may have found another bug. After a reboot of the Windows machine, the mt-daapd service starts up but does not publicize itself on the network. If I manually go into services.msc and restart mt-daapd, it comes up OK.

    Almost as if it was dependent on some other service that may not be started
    yet when mt-daapd is started after a reboot.

    /POL

    #3980

    rpedde
    Participant

    Yeah, that’s almost certainly a service dependency on bonjour for windows. You can manually fix that on the dependancies tab.

    I’ll have to find a “smarter” way of installing the service than I am now.

    — Ron

    #3981

    rpedde
    Participant

    Installer dependency is fixed in svn (r902). Don’t know if you experienced it, but there was a password problem with the windows version also. That was fixed in r900.

    Still looking at the iTunes playlist issue.

    #3982

    politby

    rpedde wrote:

    Installer dependency is fixed in svn (r902). Don’t know if you experienced it, but there was a password problem with the windows version also. That was fixed in r900.

    Still looking at the iTunes playlist issue.

    Are you going to put out a new nightly with these fixes? I can’t seem to add the dependency – there’s no “add” button in the dependency tab of services.msc.

    /POL

    #3983

    rpedde
    Participant

    Yeah, I wasn’t in a hurry because there aren’t any real “showstoppers” in the current nightly. But I was going to go ahead and package a new one tomorrow, as I have the day off, and will have plenty of time (aside from the ob. honeydos).

    — Ron

    #3984

    rpedde
    Participant

    playlist issue fixed in r903. I’ll for sure be dropping a new nightly tomorrow.

    #3985

    politby

    rpedde wrote:

    playlist issue fixed in r903. I’ll for sure be dropping a new nightly tomorrow.

    Okay, I just installed svn-909 on my Windows system, with the relevant parameters from my config file inserted in the new config, and it won’t start.

    Same problem as I had previously, “did not respond in an appropriate manner”. Probably some problem with the config file. Still seems some parameter specs want a ‘=’ in them and some not. Log file is completely empty, even with the d9 parameter, and the database isn’t initialized.

    I went back to 20060324 which works fine.

    Any suggestions?

    /POL

    #3986

    rpedde
    Participant

    There are two styles of the config file. If it is in the windows .ini format, i.e. if the first non-comment line is a section header, then it expects it in key = value format. If there is no section header, it’s in “compatibility” mode, and it doesn’t expect an =.

    I need to divert logging to the eventlog before it reads the config file, but that’s the issue.

    My suggestion would be to use the same technique as before: run it in the foreground and see what it’s mad about. “c:program filesmt-daapd -d9 -f”

    — Ron

    #3987

    politby

    rpedde wrote:

    There are two styles of the config file. If it is in the windows .ini format, i.e. if the first non-comment line is a section header, then it expects it in key = value format. If there is no section header, it’s in “compatibility” mode, and it doesn’t expect an =.

    I need to divert logging to the eventlog before it reads the config file, but that’s the issue.

    My suggestion would be to use the same technique as before: run it in the foreground and see what it’s mad about. “c:program filesmt-daapd -d9 -f”

    — Ron

    Turns out that the db_parms parameter in my config file had a final “” at the end of the path:

    db_parms=D:MediaMy Musicmt-daapd

    That caused the process to crash. 🙂

    Removing the last so that it reads

    db_parms=D:MediaMy Musicmt-daapd

    cured the problem. Apparently mt-daapd doesn’t want Windows paths to end with “”.

    /POL

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.