You are here: Home » Topic » Problems using FF over a D-Link wireless router

Problems using FF over a D-Link wireless router

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues Problems using FF over a D-Link wireless router

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #2220
    cstern
    Participant

    Hi all,

    I have been running Firefly on my Synology box for quite a while now, and successfully, too. I was using a Belkin wireless router and a Pinnacle Soundbridge M1001. No problems at all.

    Yesterday I upgraded my router as we got fibernetwork to the house and I’d like to enjoy the full speed on both my wired and wireless PCs. The new router is a D-Link DIR-655 802.11n router with the most recent firmware.

    Now the M1001 does not detect the FF anymore. The funny thing is that from iTunes both on the wired PCs and on the wireless notebook FF shows up as before.

    Another observation: I tried to enable the built-in iTunes server in the Synology – it has a new firmware and I wanted to check if the iTunes server software was upgraded in the process – It did not seem to be a newer version, still an old mt-daapd incarnation. However – IT did show up on the M1001! But was dreadfully slow – I would guess 10 times compared to FF.

    I have enabled multicast and uPnP on the router but to no avail.

    So, now I seek your advice! I hope I do not have to keep the old Belkin in addition to the new shiny D-Link, just for the sake of music streaming…

    #16314
    Anonymous
    Inactive

    I have the Pinnacle SoundBridge and the D-Link DIR-615, newest firmware on both, gave up trying to get it working with firefly. Came to the conclusion that the router was not compatible. Internet radio and WMC work fine.

    #16315
    cstern
    Participant

    Damn, I just spent a smaller fortune on the DIR-655 and a corresponding notebook adapter. It must be possible to make it work.

    Ron, what ports need to be open? 3689? and what others?

    The very strange thing is that the firefly server works on PCs and the Soundbridge can play internet radio…

    On the Roku forum someone wrote that changing the security to WPA2 only and AES encryption should do the trick. But it didn’t for me.

    I hope someone has the solution

    #16316
    cstern
    Participant

    An update: I connected the soundbridge with a cable and everything works as it should. On the Roku forum I have been recommended to go back to an older firmware on the router, so I am going to try that.

    #16317
    rpedde
    Participant

    @cstern wrote:

    Damn, I just spent a smaller fortune on the DIR-655 and a corresponding notebook adapter. It must be possible to make it work.

    Ron, what ports need to be open? 3689? and what others?

    The very strange thing is that the firefly server works on PCs and the Soundbridge can play internet radio…

    On the Roku forum someone wrote that changing the security to WPA2 only and AES encryption should do the trick. But it didn’t for me.

    I hope someone has the solution

    I’ve also heard people say things like that, but I’m not entirely sure how that would change anything. Stranger things have happened though.

    I wish roku would just put in a setting to allow you to specify the ip of the server, so you wouln’t have to rely on multicast for discovery, since it’s obviously flawed on a fair number of routers. :/

    To answer your question, bonjour requires 3689 inbound tcp, as well as in and outbound to/from 224.0.0.251 udp port 5353 for discovery.

    But as detailed in your posts, I think this isn’t the issue — I think it’s related to multicast implementation on the router.

    — Ron

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.