Port forwarding advice please

Viewing 15 posts - 1 through 15 (of 23 total)
  • Author
    Posts
  • #1925
    Anonymous
    Inactive

    Hi all

    I have a Soundbridge M1001 connected to my Mac via a BT Hub (wireless router) and a Belkin Range Extender. All works well except that every 70 minutes (to the second) I lose the connection to firefly and have to reboot the Soundbridge to reconnect. I don’t lose internet radio connection.

    Roku say it is an issue with the Belkin, and to be fair if I move the soundbride into range and wirelessly connect the soundbridge direct to the BT Hub all works fine.

    Belkin have responded to say it is to do with Port forwarding settings and these need to be set correctly in all three devices. I am struggling to understand what they mean and would welcome any help, advice or direction.

    hope you can help 😕

    thanks
    Duff

    #14309
    Osik
    Participant

    Just to make sure i understand your scenario:

    You are connecting to your soundbridge using the range extender -> bt hub -> soundbridge? Are all these devices connecting wirelessly each other?

    I guess this is not a problem of portforwarding. I think this comes through temporary timeouts or it is the wpa key refreshing of your wlan devices. Portforwarding makes no sense because you are using it in your LAN not over Internet, right?

    I can’t explain this because i am not a pro on networking and never used such things like a range extender but maybe this is an hint.

    Greetz

    Osik

    #14310
    Anonymous
    Inactive

    @Osik wrote:

    You are connecting to your soundbridge using the range extender -> bt hub -> soundbridge? Are all these devices connecting wirelessly each other?

    Osik

    The BT Hub is the router, connected to the dsl input, and ethernet connected to my Mac, PC and Network Printer. The Hub also suppliers the wireless signal around the house, but due to the location, I require the signal to be boosted to reach the back of the house, where the soundbridge is located, hence the Belkin Rage Extender which provides a wireless bridge between the Hub and the Soundbridge.

    The issue is very precise, loosing connection to firefly after 1hr 10mins, but still having a connection to the network and internet radio. I get exactly the same scenario if I ethernet cable the Soundbridge to the Belkin. However, the Soundbridge has no problem playing for hours when wirelessly connected directly to the Hub (eg take the Belkin out of the equation.

    It is the precision of the problem that makes me belive there is a setting somewhere that is causing this, but where? 😕

    Duff

    #14311
    sonichouse
    Participant

    Hi Duff,

    If the range extender has an aerial that you can reposition, try it so that the aerial is transmitting on the same plane. By that I mean, with my AP downstairs and my M1001 upstairs, moving the aerial so that is was nearer the horizontal greatly improved signal strength and stability.

    I had problems with an M1001 when it had low signal strength. It generally failed to get a dhcp address.

    Out of interest, have you tried setting your M1001 to use a fixed IP address ? I wonder what the dhcp lease time is ?

    Steve

    #14312
    Anonymous
    Inactive

    @sonichouse wrote:

    Hi Duff,

    If the range extender has an aerial that you can reposition, try it so that the aerial is transmitting on the same plane. By that I mean, with my AP downstairs and my M1001 upstairs, moving the aerial so that is was nearer the horizontal greatly improved signal strength and stability.

    I had problems with an M1001 when it had low signal strength. It generally failed to get a dhcp address.

    Out of interest, have you tried setting your M1001 to use a fixed IP address ? I wonder what the dhcp lease time is ?

    Steve

    Hi Steve

    Thanks for your post. Can I just clarify re the aerials, they are currently both vertical, are you suggesting moving them both to be horizontal?

    To be honest, I didn’t think it was a signal strength issue as the wireless quality is showing at 98. However, I am interested in the fixed IP address suggestion. Can you advise how to do this?

    Duff

    #14313
    sonichouse
    Participant

    @Duffledorf wrote:

    However, I am interested in the fixed IP address suggestion. Can you advise how to do this?

    Check out the following http://www.rokulabs.com/support/soundbridge/static_ip.php but essentially telnet to your soundbridge on port 4444 and type command ipset.

    Sounds like your signal is OK, so no need to meddle 😆

    #14314
    Anonymous
    Inactive

    @sonichouse wrote:

    Check out the following http://www.rokulabs.com/support/soundbridge/static_ip.php but essentially telnet to your soundbridge on port 4444 and type command ipset.

    Sounds like your signal is OK, so no need to meddle 😆

    Hi Steve

    I followed the instructions, and reset all the settings on the Soundbridge, but seems that isn’t the problem as following a reboot and a 70 min test, I am still getting the same results. Any other suggestions welcome.

    Duff 😥

    #14315
    Osik
    Participant

    Hi Duff,

    are there any chances to connect with another device (notebook eg.) using your range extender to your music library. is there also a timeout after 70 minutes? this is just to verify that its not your soundbridge.

    What happen when you test your soundbridge without the range extender but next to your router?

    greetz

    Osik

    #14316
    fizze
    Participant

    Well, those belkin devices are inferiour. I guess that getting another device is out of the question, but just for kicks, the Linksys WRT54 family products can work as router, WLAN access point, wireless range extender, etc. all in one. Im using a bunch of those in my home network without a hitch. 🙂

    70 minutes seems weirdish. IF the Belkin would swallow multicasts/anycasts then the soundbridge wouldnt see firefly at all. Can’t be an inactivity timeout either, since you can stream for 70 minutes without a problem, right?

    Sure would be nice to tap into that network and see what packages disappear after 70 minutes….

    Does the belkin have some sort of firewall / filtering enabled?

    #14317
    Anonymous
    Inactive

    @Osik wrote:

    Hi Duff,

    are there any chances to connect with another device (notebook eg.) using your range extender to your music library. is there also a timeout after 70 minutes? this is just to verify that its not your soundbridge.

    What happen when you test your soundbridge without the range extender but next to your router?

    greetz

    Osik

    Hi Osik
    I currently only have my Mac set up with Firefly, I could set up my pc as well (will there be any conflicts if both run at same time?). Or are you saying it would be best to try my laptop running a library connected wirelessly to the Belkin (ie taking the router out of the equation)?

    If I move the soundbridge into the room where the router is (BT Hub) it runs without problem, had running 9 -10 hours without issue.

    @fizze wrote:

    Well, those belkin devices are inferiour. I guess that getting another device is out of the question, but just for kicks, the Linksys WRT54 family products can work as router, WLAN access point, wireless range extender, etc. all in one. Im using a bunch of those in my home network without a hitch. 🙂

    70 minutes seems weirdish. IF the Belkin would swallow multicasts/anycasts then the soundbridge wouldnt see firefly at all. Can’t be an inactivity timeout either, since you can stream for 70 minutes without a problem, right?

    Sure would be nice to tap into that network and see what packages disappear after 70 minutes….

    Does the belkin have some sort of firewall / filtering enabled?

    Hi fizze

    If I knew for certain it was the Belkin, I would replace it, but would be a little POed if I still had the problem after laying out more cash. Do you have any suggestions regarding ‘tapping into the network’ to identify what is happening.

    The belkin just emulates the router, it would be really great if you could have a quick look at the user guide and see if you think I have missed anything.

    Cheers
    Duff

    #14318
    Osik
    Participant

    well no need to setup an pc with firefly if your soundbridge works like charm testing it in the room next to your wifi router.

    now i would say, and i remember somehow, that wpa encryption changes the keys every 60 minutes but save the before used key for further 10 minutes. if your soundbridge doesn’t renew the key it disconnects after 70 minutes.

    but i’m not really sure. fact is your belkin is misconfigured somehow. don’t have to be your error, could be a mistake by belkin.

    but i have no idea how to fix this 🙁

    regards

    Osik

    #14319
    Anonymous
    Inactive

    Hi Osik
    Thanks for the response,
    @Osik wrote:

    now i would say, and i remember somehow, that wpa encryption changes the keys every 60 minutes but save the before used key for further 10 minutes. if your soundbridge doesn’t renew the key it disconnects after 70 minutes.

    I wasn’t aware of that, and it certainly would make sense. I guess the easy way to test it, is to turn off all security for a couple of hours and see if it makes a difference. I will try this and report back.

    @Osik wrote:

    but i’m not really sure. fact is your belkin is misconfigured somehow. don’t have to be your error, could be a mistake by belkin.

    hmmm, probably my error, I dread going near the Belkin, it is a nightmare to set up and while the manual seems to make sense, when trying to apply it I find that it isn’t specific enough and open to interpretation. I guess if the test proves it is a security issue then I need to get in there again and have a play. (or bin it and buy the linksys recommended by fizze 🙂 )

    Cheers for help so far.

    Duff

    #14320
    Anonymous
    Inactive

    @Duffledorf wrote:

    I wasn’t aware of that, and it certainly would make sense. I guess the easy way to test it, is to turn off all security for a couple of hours and see if it makes a difference. I will try this and report back.

    Hi Osik
    Have tried switching off the security on both the router and the belkin, but it made absolutly no difference, so not an encryption key change, as it still does it without one! 😥

    @Osik wrote:

    but i’m not really sure. fact is your belkin is misconfigured somehow. don’t have to be your error, could be a mistake by belkin.

    Have also had another look through all the settings both on the BT Hub and the Belkin and can’t find any settings that could be doing this, and nothing that helps with port forwarding also.

    The message I am getting briefly before I loose the library, is that the library shut down, which still makes me think firefly, but what could firefly do to the belkin but not do for a router connection?

    Duff 😥

    #14321
    [email protected]
    Participant

    I use a Belkin F5D7132uk with WPA-PSK encryption to extend the range of my Speedtouch 780WL and it doesn’t drop the connection.

    The only modification I made was to use a higher gain antenna instead of the one supplied.

    SoundBridge is running software version 3.0.44
    Signal Quality: 99
    Signal Level: -46dBm

    #14322
    Osik
    Participant

    Hi duff,

    sounds strange. it have to be the range extender because you aren’t losing connection without this.

    i have no idea where this error come from. 🙁

    does this also happens if your itunes shares your music to the soundbridge?

    Greetz

    Osik

Viewing 15 posts - 1 through 15 (of 23 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.