You are here: Home » Topic » Playlist help

Playlist help

This topic contains 3 replies, has 2 voices, and was last updated by  rpedde 10 years, 4 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1563

    aardwolf

    Help,

    Have got myself very confused. Can somebody point me in the right direction.

    I have firefly running on a Buffalo Linkstation and working fine. I organise the files on the Buffalo using iTunes on my PC. The music streams to a Roku with no problems

    I want to be able to create a playlist using itunes and move it to the Buffalo.

    Because of the number of files the roku gets confused if you try and browse the library directly.

    Some pointer to get an understanding of the best way to do this would be gratefully recieved.

    Cheers

    #11707

    rpedde
    Participant

    @aardwolf wrote:

    Help,

    Have got myself very confused. Can somebody point me in the right direction.

    I have firefly running on a Buffalo Linkstation and working fine. I organise the files on the Buffalo using iTunes on my PC. The music streams to a Roku with no problems

    I want to be able to create a playlist using itunes and move it to the Buffalo.

    Because of the number of files the roku gets confused if you try and browse the library directly.

    Some pointer to get an understanding of the best way to do this would be gratefully recieved.

    Cheers

    Generally, the easiest way is to copy your “iTunes Music Library.xml” into the root of your music share.

    Then do a scan, it should pick it up. Once you have that working, you can set up a batch file or something to do it, and click on that to copy the file to your server whenever you update your iTunes playlists.

    Yell if this sounds foreign, or if that doesnt’ work the way you expect.

    Also, you might have to go into the web interface and make sure that “enable m3u” is turned on, as well as “enable playlists” and (if it’s there) “enable itunes” in the advanced section.

    — Ron

    #11708

    davesanti
    Participant

    Ron,

    I have no problems with m3u playlists, but scans never pick up xml’s.

    I have created them in itunes and exported to the root directory (right there with my m3u’s). I have itunes enable in the config and it still never finds the the playlists at all.

    Dave

    #11709

    rpedde
    Participant

    @davesanti wrote:

    Ron,

    I have no problems with m3u playlists, but scans never pick up xml’s.

    I have created them in itunes and exported to the root directory (right there with my m3u’s). I have itunes enable in the config and it still never finds the the playlists at all.

    Dave

    Hrm, it sure should. Can you run it with a debuglevel of 9 and a logfile set in the config and then do a full scan? Maybe put the logfile in the same directory as the mp3_dir, so you can pull it off, then zip it and email it to [email protected]? Then I can take a look at the log and tell you what’s up.

    — Ron

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.