You are here: Home » Topic » on the fly conversion doesnt workpage 2

on the fly conversion doesnt work

This topic contains 20 replies, has 3 voices, and was last updated by  mas 12 years, 8 months ago.

Viewing 6 posts - 16 through 21 (of 21 total)
  • Author
    Posts
  • #7841

    fizze
    Participant

    oh, it seems there is quite a lot of packages you didnt install.

    like procps, core-utils, etc 😉

    the ipkg search utility on nslu2-linux.org will become a good friend of yours, I think 🙂

    #7842

    mas
    Participant

    Well yes this is a production / use system running unslung 6.7 and busybox!

    The packages that you list are the feature rich heavy load parts that busybox provides smaller versions for. That beeing said the search function is no help as these would conflict with busybox and are deliberately not installed.

    Unless you want to do development and/or native compiling the busybox utils should work fine with everything.

    bash is installed btw as I didnt wanna have the ash/bash problems with scripts.

    Installed currently:
    alac-decoder – 0.1.0-2 – A decoder for the apple lossless file format
    audiofile – 0.2.6-4 – Misc Audio Libraries.
    bash – 3.2-1 – A bourne style shell
    busybox – 1.1.3-3 – A userland replacement for embedded systems.
    busybox-base – 1.1.3-3 – A userland replacement for embedded systems.
    busybox-links – 1.1.3-3 – A userland replacement for embedded systems.
    cpio – 2.6-3 – file archive utility
    ctcs – 1.2-6 – CTorrent Control Server (CTCS) is an interface for monitoring and managing Enhanced CTorrent clients
    enhanced-ctorrent – dnh2.2-6 – Enhanced CTorrent is a revised version of CTorrent
    expat – 2.0.0-5 – XML Parser library
    ffmpeg – 0.4.9-pre1+r5834-2 – FFmpeg is an audio/video conversion tool.
    file – 4.18-1 – Ubiquitous file identification utility.
    flac – 1.1.2-4 – FLAC is a free lossless audio codec. This package contains the codec libraries and the command-line tools flac and metaflac.
    gdbm – 1.8.3-2 – GNU dbm is a set of database routines that use extensible hashing. It works similar to the standard UNIX dbm routines.
    gnutls – 1.6.0-1 – GNU Transport Layer Security Library.
    groff – 1.19.1-5 – front-end for the groff document formatting system
    id3lib – 3.8.3-1 – Library for reading, writing, and manipulating ID3v1 and ID3v2 tags.
    ipkg – 0.99.154-r2 –
    ipkg-web – 5-5 – A web frontend for ipkg
    ivorbis-tools – 1.0-2 – Tools to allow you to play, encode, and manage Ogg Vorbis files. This version is hacked to use the Tremor integer decoder.
    kernel – 2.4.22.l2.3r63-r10 –
    kernel-image-2.4.22-xfs – 2.4.22.l2.3r63-r10 –
    kernel-module-nls-cp850 – 2.4.22.l2.3r63-r10 –
    ldconfig – 2.2.5-1 – Builds ld.so.cache, which is used to speed up dynamic linking and to configure a system-wide library search path.
    less – 394-3 – Less file browser
    libao – 0.8.6-1 – libao is a cross-platform audio library that allows programs to output audio using a simple API on a wide variety of platforms.
    libc6-unslung – 2.2.5-r5 –
    libcurl – 7.16.0-2 – Curl is a command line tool for transferring files with URL syntax, supporting FTP, FTPS, HTTP, HTTPS, GOPHER, TELNET, DICT, FI
    libdb – 4.2.52-3 – Berkeley DB Libraries
    libgcc – 3.4.4-r3 –
    libgcrypt – 1.2.3-1 – GNU cryptography libray, needed by gnutls
    libgpg-error – 1.1-1 – Error handling library for libgcrypt
    libid3tag – 0.15.1b-1 – The library used for ID3 tag reading
    libipkg – 0.99.154-r2 –
    libmad – 0.15.1b-2 – MPEG Audio Decoder library
    libmemcache – 1.4.0.rc2-2 – The C API for memcached.
    libnsl – 2.2.5-3 – Network Services Library
    libogg – 1.1.3-2 – Ogg is a multimedia container format.
    libstdc++ – 5.0.7-4 – Standard C++ library, needed for dynamically linked C++ programs
    libtasn1 – 0.3.8-1 – Describe libtasn1 here.
    libtool – 1.5.10-2 – Library tools.
    libvorbis – 1.1.2-3 – Ogg Vorbis compressed audio format.
    libvorbisidec – cvs-20050221-2 – libvorbisidec is the integer-only ogg decoder library, AKA Tremor
    libxml2 – 2.6.27-1 – Libxml2 is the XML C parser and toolkit developed for the Gnome project.
    libxslt – 1.1.15-6 – An XML Stylesheet processor based on libxml2
    lsof – 4.77.dfsg.1-1 – LiSt Open Files – a diagnostic tool.
    man – 1.5p-4 – unix manual page reader
    man-pages – 2.33-3 – unix manual pages
    mt-daapd – svn-1433-1 – A multi-threaded DAAP server for Linux and other POSIX type systems. Allows a Linux box to share audio files with iTunes users
    mtr – 0.72-1 – mtr combines the functionality of the ‘traceroute’ and ‘ping’ programs in a single network diagnostic tool.
    nano – 2.0.1-2 – A pico like editor
    ncurses – 5.5-1 – NCurses libraries
    ncursesw – 5.5-1 – NCurses libraries with wide char support.
    nload – 0.6.0-2 – Nload is a console application which monitors network traffic and bandwidth usage in real time
    nslu2-linksys-libs – 2.3r63-r2 –
    ntpclient – 2003_194-3 – Using RFC1305 (NTP), retrieves a remote date and time
    openssh – 4.3p2-6 – a FREE version of the SSH protocol suite of network connectivity tools.
    openssl – 0.9.7l-1 – Openssl provides the ssl implementation in libraries libcrypto and libssl, and is needed by many other applications and librari
    pcre – 6.7-2 – Perl-compatible regular expression library
    perl – 5.8.8-11 – Practical Extraction and Report Language.
    perl-dbd-sqlite – 1.12-1 – The Perl Database Driver for SQLITE.
    perl-dbi – 1.53-1 – DBI – The Perl Database Interface by Tim Bunce.
    perl-digest-hmac – 1.01-4 – The module allows you to use the NIST SHA-1 message digest algorithm.
    perl-digest-sha1 – 2.11-2 – The module allows you to use the NIST SHA-1 message digest algorithm.
    perl-html-parser – 3.55-2 – A collection of modules that parse and extract information from HTML documents.
    perl-html-tagset – 3.04-4 – This module contains data tables useful in dealing with HTML.
    perl-net-dns – 0.48-4 – Perl DNS Resolver Module.
    psutils – p17-1 – Describe psutils here.
    rdate – 1.4-2 – Using RFC868, retrieves a remote date and time and sets the local time
    readline – 5.2-1 – The GNU Readline library provides a set of functions for use by applications that allow users to edit command lines as they are
    slingbox – 1.00-r8 –
    sqlite – 3.3.8-1 – SQLite is a small C library that implements a self-contained, embeddable, zero-configuration SQL database engine.
    sqlite2 – 2.8.16-1 – SQLite is a small C library that implements a self-contained, embeddable, zero-configuration SQL database engine.
    unarj – 2.65-1 – unarj – An uncompressor for .arj format archive files
    unrar – 3.6.5-1 – unrar is an application that can decompress files and archives created using the RAR compression scheme
    unslung-feeds – 3.0-1 – A list of sanctioned Unslung package feeds.
    unslung-rootfs – 2.3r63-r11 –
    update-modules – 1.0-r4 –
    wget-ssl – 1.10.2-3 – A network utility to retrieve files from the Web
    xvid – 20060306-1 – Xvid is MPEG4 codec
    zip – 2.32-1 – a compression and file packaging utility.
    zlib – 1.2.3-1 – zlib is a library implementing the ‘deflate’ compression system.



    Thats already a lot and more than it should be hehe.

    #7843

    mas
    Participant

    I have in the meantime done a ipkg -force-overwrite -force-depends on the core-utils, ps-utils etc. package to force it to partially overwrite the busybox.

    The fatter utils seem to work via the shell (taking precedence over the busybox links) but no difference on the playback front.

    I tend to think its a rather rare issue with the version I run possibly. Guess best is to wait till the ipkg distripoint on fireflymediaserver.org for the armb distribution is updated and then see it the problem prevails with a top new svs version.

    Give me a hump once there is a new version in the ipkg list.

    #7844

    rpedde
    Participant

    @mas wrote:

    Give me a hump once there is a new version in the ipkg list.

    I will, but I don’t imagine it will change much. The script based transcoding on the slug packages hasn’t changed in a year or so, and I haven’t had any problems with it *ever* not working out of the box.

    There is something very strange going on. Everything you’ve described shows it cannot *not* work, so I have absolutely no idea what would be going wrong here.

    Whatever it is, it probably won’t be fixed though, since I have no idea what isn’t working with it. And consequently can’t fix it. Have you watched it with ethereal? Is it actually sending data?

    #7845

    mas
    Participant

    I will have a look with a packet sniffer once I am back from xmas vacation.

    #7846

    mas
    Participant

    Jay Jay! I found the bug and fixed it!!! It was a bug on my NSLU side (not unexpectandly as all looked good from the server side).

    Havent gotten around to try the packetsniffer, but I suddenly had the idea while screwing around with my NSLU to try how that thing would work as root. The mt-daapd runs as nobody normally. So switched it to root via the runas option and suddenly it works.

    Darn! So it had to be access permissing thing. Having installed the heavyweight core-utils just recently I now had a working su (the one from busybox is a joke and su nobody doesnt work there!) and so I did a su nobody and voila. oggdec was barking at couldnt load library. As root it would of course work as I had tried out earlier.

    Ok, so what was causing the glitch? Simply a somehow wrongly set permission on /opt/lib/libvorbis*.so. Darn, I dunno how it could happen but after I fixed it it now works als nobody as well.

    mt-daapd apparently doesnt log error messages that the mt-daapd-ssc script generates it seems so everything looked nice even at debuglevel 9.

    Ok, so if very strange errors that have no imaginable cause happen – check runas=root and if it works then look at the permissions of all involved files. Good to remember.

    Thanks Ron for excluding all the possible issues from the server side! I would have given up earlier otherwise likely.

Viewing 6 posts - 16 through 21 (of 21 total)

The forum ‘Nightlies Feedback’ is closed to new topics and replies.