You are here: Home » Topic » .ogg metadata is not read

.ogg metadata is not read

This topic contains 3 replies, has 2 voices, and was last updated by  rsl360 8 years, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2795

    Anonymous

    It just doesn’t work, using firefly svn-1696, I used the –enable-oggvorbis flag, mt-daapd.conf has “extensions = .mp3,.m4a,.m4p,.ogg,.flac”, but ogg metadata is just not being read.

    I also configured with –enable-flac and flac files have their metadata show up fine, but I’ve had no luck with ogg. Thing is, ogg worked the last time I had an mt-daapd install, but I reinstalled opensuse and had to reinstall mt-daapd.

    #18176

    rsl360
    Participant

    A little more information would be helpful.

    Is firefly completely dead? Does it give you your songs, but not artists or albums?

    Robbie

    #18177

    Anonymous

    All files work fine (mp3, flac) except ogg files, when I try to look for an ogg file from a client like Amarok, they appear under “Unknown” for the artist, and the track titles do not show up, instead the filename is there. Firefly doesn’t crash or anything, ogg (and all other) files can play fine but the metadata on ogg files doesn’t show up.

    #18178

    rsl360
    Participant

    Wow, the board is finally back up. Thanks, somebody.

    Are you using a binary, or did you build firefly from the source?

    I’m not sure, but I think the problem of not reading the .ogg metadata may be a dependency problem. I think I had the same problem. I’m not sure if it was exactly the problem you are having, but it was close. I think the way I fixed it was to look for everything .ogg related (with yumex) and installed them all. I’ve since tried to make a list of the firefly dependencies by looking at the various instructions and the wiki. I’ve come up with this:

    Everything needs:
    libid3tag
    libsqlite0
    libsqlite0-dev

    Fedorda needs:
    libid3tag-devel,
    id3tag and id3tag-devel

    Ogg needs:
    vorbis-tools

    And I think these are also needed, but I’m not sure if it’s documented anywhere. I think I got error messages when compiling and these made the errors go away.
    avahi-daemon
    libgdbm-dev
    gcc

    Anyone else want to correct me, add/subtract stuff, please do.

    Robbie

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.