You are here: Home » Topic » NSLU2 : firefly does not start

NSLU2 : firefly does not start

This topic contains 13 replies, has 4 voices, and was last updated by  rpedde 10 years, 4 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1220

    zemickeyman
    Participant

    Hello everybody,

    I’ve just installed the firefly sever on my NSLU2 box.
    I’ve checked if the server is started by : “ps -ef |grep mt-daapd” command but even after a server reboot : “/opt/etc/init.d/S60mt-daapd”, the answer is always the same
    2564 ttype0 root 2668 S grep mt-daapd

    others processes are not working !!
    does anybody know what could be the problem ?

    thanks in advance

    Mickey

    #9734

    fizze
    Participant

    mt-daapd needs to have read access to the music-directory. otherwise it wont start.
    Edit the file /opt/etc/mt-daapd/mt-daapd.conf and make sure that you point it to the directory which contains your music.

    If you leave anything else untouched, you can monitor mt-daapds progress by tailing the /var/log/messages file.

    tail -f /var/log/messages

    the -f option “follows” the fiel output, you’ll see. Simply press CTRL+C to abort at any time. This is also a means to check for error messages.
    Once mt-daapd has completed the scanning and populating the DB, you’ll be able to utilize the web-interface at port 3689, which is a more user-friendly way to change settings. 🙂

    #9735

    zemickeyman
    Participant

    hello

    I’ve done the following commands

    First in the /opt/etc/mt-daapd/mt-daapd.conf, I’ve checked that my share folder was /share/hdd/data/public/mp3
    then


    # chmod o+r -R /share/hdd/data/public/mp3
    # /opt/etc/init.d/S60mt-daapd
    # tail -f /var/log/messages

    Apr 2 13:56:40 mt-daapd[573]: Starting rendezvous daemon
    Apr 2 13:56:40 mt-daapd[575]: Starting signal handler
    Apr 2 13:56:41 mt-daapd[575]: Loading playlists
    Apr 2 13:56:41 mt-daapd[575]: Initializing database
    Apr 2 13:56:41 mt-daapd[575]: Starting mp3 scan
    Apr 2 13:56:41 mt-daapd[575]: Error scanning MP3 files: Permission denied
    Apr 2 13:56:41 mt-daapd[575]: Aborting
    Apr 2 13:56:41 mt-daapd[574]: Rendezvous socket closed (daap server crashed?) Aborting.
    Apr 2 13:56:41 mt-daapd[574]: Aborting

    I don’t understand why the permission is denied : in the mp3 folder there is only one mp3 file that have the readable properties ( i’ve checked it)

    addtional info : I’ve done everything logged as root (SSH mode)

    thanks for your help

    zemickeyman

    #9736

    rpedde
    Participant

    @zemickeyman wrote:

    hello

    I’ve done the following commands

    First in the /opt/etc/mt-daapd/mt-daapd.conf, I’ve checked that my share folder was /share/hdd/data/public/mp3
    then


    # chmod o+r -R /share/hdd/data/public/mp3
    # /opt/etc/init.d/S60mt-daapd
    # tail -f /var/log/messages

    Apr 2 13:56:40 mt-daapd[573]: Starting rendezvous daemon
    Apr 2 13:56:40 mt-daapd[575]: Starting signal handler
    Apr 2 13:56:41 mt-daapd[575]: Loading playlists
    Apr 2 13:56:41 mt-daapd[575]: Initializing database
    Apr 2 13:56:41 mt-daapd[575]: Starting mp3 scan
    Apr 2 13:56:41 mt-daapd[575]: Error scanning MP3 files: Permission denied
    Apr 2 13:56:41 mt-daapd[575]: Aborting
    Apr 2 13:56:41 mt-daapd[574]: Rendezvous socket closed (daap server crashed?) Aborting.
    Apr 2 13:56:41 mt-daapd[574]: Aborting

    I don’t understand why the permission is denied : in the mp3 folder there is only one mp3 file that have the readable properties ( i’ve checked it)

    addtional info : I’ve done everything logged as root (SSH mode)

    thanks for your help

    zemickeyman

    Check the directory it lives in, too. It has to be at least r-x for world to be able to work.

    I use rwxr-xr-x for directories and rw-r–r– for files. That’s pretty much the minimum you can have to have it work. Remember, it drops privs and runs as “nobody”, not as root.

    — Ron

    #9737

    fizze
    Participant

    “Read” access under Linux isnt equivalent to read access on windows machines. (NTFS)

    In Linux, read access is only sufficient, when you know an exact filename and path. But in order to browse a directory, you need to have execute (+x) rights, too.
    This is why firefly fails to start.

    This takes some getting used to, especially when there is more than one user group involved 😉

    edit:
    Oh, Ron, btw: Firefly does run as guest:everybody on the NSLU2. This user luckily IS in the same group as the “admin” user, that normally does file uploads. 😉

    #9738

    zemickeyman
    Participant

    If I understand, I have to set the following permission to rwxr-xr-x to /share/hdd/data/public/mp3 and its sub directories (Can I create subdirectories like Itunes organizes the music directories?)
    And the following permissions to mp3 files: rw-r–r–.

    As I am a little bit lazy: Do you know what chmod commands I have to type ? 😉

    #9739

    fizze
    Participant

    thats 755 on dirs and 644 on the files.
    Octal representation is much more handy here.

    Check out
    This link

    #9740

    rpedde
    Participant

    @zemickeyman wrote:

    If I understand, I have to set the following permission to rwxr-xr-x to /share/hdd/data/public/mp3 and its sub directories (Can I create subdirectories like Itunes organizes the music directories?)
    And the following permissions to mp3 files: rw-r–r–.

    As I am a little bit lazy: Do you know what chmod commands I have to type ? 😉


    find /share/hdd/data/public/mp3 -type d -exec chmod 2775 {} ;
    find /share/hdd/data/public/mp3 -type f -exec chmod 644 {} ;
    #9741

    zemickeyman
    Participant

    It doesn’t change anything even if directories and files permission are okay !!
    always :

    Apr 3 19:43:26 mt-daapd[575]: Starting rendezvous daemon
    Apr 3 19:43:26 mt-daapd[577]: Starting signal handler
    Apr 3 19:43:27 mt-daapd[577]: Loading playlists
    Apr 3 19:43:27 mt-daapd[577]: Initializing database
    Apr 3 19:43:27 mt-daapd[577]: Starting mp3 scan
    Apr 3 19:43:27 mt-daapd[577]: Error scanning MP3 files: Permission denied
    Apr 3 19:43:27 mt-daapd[577]: Aborting
    Apr 3 19:43:27 mt-daapd[576]: Rendezvous socket closed (daap server crashed?) Aborting.
    Apr 3 19:43:27 mt-daapd[576]: Aborting

    do you think this could be a problem :
    I’m logged to NSLU2 as root using openssh (via putty)

    I don’t understand the permission is denied even if the file and directories are readable !!

    i think i will give up !!

    thank you for your help

    Mickeyman

    #9742

    CCRDude
    Participant

    Not sure about the NSLU os, but if its init.d script is in any way similar to the Debian one, the mt-daapd process will NOT be started as the user you’ve used to log into the sell, but as the user specified in /etc/mt-daapd.conf, where you’ll find the default setting runas = nobody.

    So it’s nobody, not root, who needs access to those folders!

    Rons description should have changed permissions correctly… btw, what about to the path to this location? Imho data and public need to be visible (a+rx) as well – to nobody, not root.

    #9743

    rpedde
    Participant

    @zemickeyman wrote:

    It doesn’t change anything even if directories and files permission are okay !!
    always :

    Apr 3 19:43:26 mt-daapd[575]: Starting rendezvous daemon
    Apr 3 19:43:26 mt-daapd[577]: Starting signal handler
    Apr 3 19:43:27 mt-daapd[577]: Loading playlists
    Apr 3 19:43:27 mt-daapd[577]: Initializing database
    Apr 3 19:43:27 mt-daapd[577]: Starting mp3 scan
    Apr 3 19:43:27 mt-daapd[577]: Error scanning MP3 files: Permission denied
    Apr 3 19:43:27 mt-daapd[577]: Aborting
    Apr 3 19:43:27 mt-daapd[576]: Rendezvous socket closed (daap server crashed?) Aborting.
    Apr 3 19:43:27 mt-daapd[576]: Aborting

    do you think this could be a problem :
    I’m logged to NSLU2 as root using openssh (via putty)

    I don’t understand the permission is denied even if the file and directories are readable !!

    i think i will give up !!

    thank you for your help

    Mickeyman

    Don’t forget the permissions on the mp3 directory itself, not just the files and directories *in* it.

    There is no two ways about it — the permissions on the mp3 directory itself is too restrictive. No other way you get that error message. It has to be world readable and executable.

    #9744

    zemickeyman
    Participant

    in the /opt/etc/mt-daapd/mt-daapd.conf
    I’ve try to change the defaut “run as” record that was “guest” by “root” and the server works !

    so it is a permission problem !!

    do you know what should be the default value for “run as”
    and do you know how can I can checked if the defaut value/user belongs to root group ?

    thanks in advance

    Mickey

    #9745

    zemickeyman
    Participant

    no idea ??
    I think it is not safe to run as root isn’t it ?

    Mickeyman

    #9746

    rpedde
    Participant

    @zemickeyman wrote:

    no idea ??
    I think it is not safe to run as root isn’t it ?

    Mickeyman

    I sure wouldn’t. But the fix is listed above. The directory you have specified as a mp3_dir is either wrong, or has the wrong permissions on it. If you fix the permissions, it should run fine.

    — Ron

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.