You are here: Home » Topic » NSLU-2 / Firefly / Soundbridge problem when changing router

NSLU-2 / Firefly / Soundbridge problem when changing router

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues NSLU-2 / Firefly / Soundbridge problem when changing router

This topic contains 13 replies, has 6 voices, and was last updated by  Jxn 9 years, 9 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #2060

    Rage
    Participant

    Hi,

    I have an unslung NSLU-2 running firefly. Everything was working fine until by BT Homehub router faceplanted. I therefore bought and installed a Belkin N Wireless Router.

    For some reason the router is not recognising the slug, it definately recognised the Soundbridge as I can run firely from the computer no problems, full normal access.

    I have tried searching for the slug and connecting to it but I get the following error message “You do not have permission to use this network resourse….”

    When I try to connect to the slug via the Soundbridge I get an error message “Connection to server failed”

    Any ideas on how I can make the slug seen on my network?

    #15371

    fizze
    Participant

    How is the soundbridge connected? Wired or wireless?

    If its wireless then the problem might be that its only 802.11b capable, not 11g or let alone 11n.

    So you might want to turn off the n-mode and enable b only to see if thats it.

    If its wired it really should work, unless there are a lots of “security features” that block multicasts…. šŸ™„

    #15372

    Rage
    Participant

    The SB is wireless and working fine. The NSLU-2 is wired to the router.

    #15373

    rpedde
    Participant

    @rage wrote:

    The SB is wireless and working fine. The NSLU-2 is wired to the router.

    ANd how is the computer that you could run firefly from set up? Wired or wireless?

    Is your nslu2 set up for dhcp? Or is it set with a static address? What *is* the address? Can you ping it from your workstation?

    I’m thinking you got a new dhcp range with your new router.

    – Ron

    #15374

    fizze
    Participant

    The NSLU2 is hardly ever set up with DHCP, unless you’re running some sweet debian, since the dhcp implementation of linksys is utterly broken.

    So your guess sounds very good, Ron šŸ™‚

    #15375

    S80_UK
    Participant

    Yes – this is the likely problem. NSLU2 by default is fixed – 192.168.1.77 if memory serves. This may well be on a different subnet to the addresses allocated by DHCP on the new router.

    #15376

    Rage
    Participant

    My computer is wireless to the router.

    The NSLU-2 is 192.168.1.77 I cannot ping or telnet to it. The router IP is 192.168.2.1.

    Does this therefore mean that the NSLU-2 is outside the range of the router, if so what do I do about it?

    #15377

    Rage
    Participant

    Well,

    I reassigned an IP of 192.168.1.1 to the router and therefore made the DHCP range 192.168.1.2 – 100. As the NSLU-2 is 1.8.168.1.77 it should now connect?

    EDIT: OK, good, I can now connect to the slug, but the SB won’t connect, I will reboot it and see what happens.

    EDIT 2: Success! Thank you for helping out a nooblah. šŸ˜€

    #15378

    fizze
    Participant

    Great its working now šŸ™‚

    Just a sidenote:

    DHCP range 192.168.1.2 – 100. As the NSLU-2 is 1.8.168.1.77

    As the IP of the slug is static (nothing to do with DHCP), it should be outside the DHCP-range.

    I’d just set the DHCP Range to 192.168.1.100 – 192.168.1.200.
    That way you can leave the slug at .77.

    Otherwise chances are (slim, but still ;)) that one of the clients one day gets assigned .77 as an IP address and the network will be borked.

    #15379

    Rage
    Participant

    Cheers for the advice. Learning…always learning… šŸ˜€

    #15380

    slipincat
    Participant

    You can always assign the IP to the NSLU mac address on the router so it won’t be reassigned by mistake by the DHCP server.
    This is what I did with my NSLU on my router.

    #15381

    fizze
    Participant

    I did so too, but actually to use dnsmasq to resolve its hostname šŸ˜‰

    Anyway, it’s best to seperate “dynamic” hosts and “static” hosts on a network. Just don’t get too crazy and turn on DHCP on the slug, coz thats utterly broken.

    #15382

    rpedde
    Participant

    @fizze wrote:

    I did so too, but actually to use dnsmasq to resolve its hostname šŸ˜‰

    Anyway, it’s best to seperate “dynamic” hosts and “static” hosts on a network. Just don’t get too crazy and turn on DHCP on the slug, coz thats utterly broken.

    All mine are dhcp configed. šŸ™‚

    — Ron

    #15383

    Jxn
    Participant

    @fizze wrote:

    Anyway, it’s best to seperate “dynamic” hosts and “static” hosts on a network. Just don’t get too crazy and turn on DHCP on the slug, coz thats utterly broken.

    Yes, should get you out of most trouble if you don’t mix dynamic and static IP addresses.

    If giving the Slug a static or dynamic address through DHCP is a problem depends on which firmware you have on it. I have Debian Etch running on my Slug, and that works good. But then again, servers should have static addresses.

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.