You are here: Home » Topic » "no supported mediaserver found…"

"no supported mediaserver found…"

This topic contains 8 replies, has 3 voices, and was last updated by  Anonymous 8 years, 8 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #2767

    Anonymous

    well if im lucky no one will get upset for me posting something that already been asked…
    i just built firefly according to the instructions in this post: viewtopic.php?p=19954&sid=2c5314b799499f40b044756afbd83490...

    now i got the same problem as hakan way down in the topic…

    which is i get firefly up and running and all seems dandy…but my soundbridge says: “no supported mediaserver found, only unrecognized DAAP server”…

    any thoughts anyone…

    #18066

    stretch
    Participant

    Sounds like you have a Pinnacle branded SoundBridge.
    Apple did not licence DAAP to Pinnacle so Pinnacle branded units do not work with DAAP servers.

    You will have to compile with RSP enabled

    #18067

    Anonymous

    yepp…

    pinnacle it is…

    since i am what it says on the right (noob)… would that be hard to build into firefly…and how to do it…

    …tried to google it…no succes…

    #18068

    EVILRipper
    Participant
    [email protected]:~$ mkdir firefly
    [email protected]:~$ cd firefly
    [email protected]:~/firefly$ wget http://nightlies.fireflymediaserver.org/nightlies/svn-1586/mt-daapd-svn-1586.tar.gz
    [email protected]:~/firefly$ tar -xvzf mt-daapd-svn-1586.tar.gz
    [email protected]:~/firefly$ cd mt-daapd-svn-1586
    [email protected]:~/firefly/mt-daapd-svn-1586$ ./configure --enable-flac --enable-sqlite3 --with-id3tag=/opt/local

    [email protected]:~/firefly/mt-daapd-svn-1586$ make

    You used the above code to build firefly? You need to enable RSP when building. It would need changes to the following line:
    ./configure –enable-flac –enable-sqlite3 –with-id3tag=/opt/local –enable-rsp

    I’m not completely sure that is the correct flag, as I never compiled firefly myself.
    If you have no success compiling, maybe a .dmg file for mac would help you out:
    http://nightlies.fireflymediaserver.org/version.php?version=svn-1586
    Look at that page, it has a precompiled version for mac. Though I’m not sure whether it’s the correct version of mac…

    Hope this helps

    #18069

    Anonymous

    cheers…
    i actually already tried with –enable-rsp…with no succes…i have been using the precompiled .dmg…but i would like flac support…been googling like crazy but can’t seem to find out how to do it….

    #18070

    EVILRipper
    Participant

    Right. I noticed in the wiki RSP is not a build option: http://wiki.fireflymediaserver.org/Configure_Options
    so I checked my own admin page, and saw RSP is under plugins.
    maybe you should enable the plugin or point to the correct plugin dir?
    Your currently running plugins are shown on the home of the adminpage of firefly.
    Perhaps you can copy the plugin from the precompiled package, and add it to your own compiled version which has flac enabled.

    #18071

    Anonymous

    thanks a bunch…what i did was just not replace the rsp.so…and it works like a charm…although i just noticed that something must have gone wrong…i still can’t play my flacs…

    the make process is concluded with this:
    make all-am
    make[5]: Nothing to be done for `all-am’.
    make[4]: Nothing to be done for `all-am’.
    make[2]: Nothing to be done for `all-am.

    can that have anything to do with it not working…

    #18072

    EVILRipper
    Participant

    I don’t really know why they dont show up.. But I know flac can (needs?) be transcoded on-the-fly by firefly.
    When a song is requested, firefly transcodes the stream to output as something like WAV or PCM.
    This puts the decoding load on the server instead of the client. (which usually has more power)
    However, I doubt this transcoding has anything to do with showing up in firefly..

    Is .flac in the music files extensions? (See adminpage->configuration->music files->extensions)
    Also, note that linux is case sensitive, so a .FLAC file is probably not recognized.

    #18073

    Anonymous

    …although i just noticed that something must have gone wrong…i still can’t play my flacs…

    the make process is concluded with this:
    make all-am
    make[5]: Nothing to be done for `all-am’.
    make[4]: Nothing to be done for `all-am’.
    make[2]: Nothing to be done for `all-am.

    can that have anything to do with it not working…

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.