You are here: Home » Topic » Newbie/Server port number problem (I think)

Newbie/Server port number problem (I think)

This topic contains 14 replies, has 2 voices, and was last updated by  rpedde 10 years, 7 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #1257

    motte_
    Participant

    Hi,
    I can’t connect to FireFly from my SB!
    I can listen too Internet radio but;
    When I use port 3689 FireFly can create a library in Itunes but my SB can’t connect to FireFly.
    When I use port 9999 FireFly can not create a library in Itunes but my SB can connect to my FireFly (but then I don’t se any music, of course)
    What’s wrong?
    I’ve turned of all my Firewalls during my testing.

    FireFly Server 1.0 SVN1359 – Running
    Bonjour – Running
    Itunes 7.1.1.5 – Running
    SB HomeMusic, 2.7.78 – Running
    Windows XP, SP2

    #9942

    rpedde
    Participant

    @motte_ wrote:

    Hi,
    I can’t connect to FireFly from my SB!
    I can listen too Internet radio but;
    When I use port 3689 FireFly can create a library in Itunes but my SB can’t connect to FireFly.
    When I use port 9999 FireFly can not create a library in Itunes but my SB can connect to my FireFly (but then I don’t se any music, of course)
    What’s wrong?
    I’ve turned of all my Firewalls during my testing.

    FireFly Server 1.0 SVN1359 – Running
    Bonjour – Running
    Itunes 7.1.1.5 – Running
    SB HomeMusic, 2.7.78 – Running
    Windows XP, SP2

    First things first. Set your firefly to 9999. make sure again that your firewalls are off. Later, we can set them back up, but let’s keep them off for the purposes of testing.

    Set your music directory to your “My Music” directory. That should be something like “documents and settingsyour namemy documentsmy music”.

    Then go into the web interface on firefly by going into the tray icon, and hitting the web management button on the “Server” tab. It should come up to a web page, with a button that says “FULL SCAN”. Hit that button, and it will turn gray. Then wait for a while until it becomes normal again. Look at the line that shows how many music files are in your library. It shoudl be more than 0.

    Then try and connect from the SB and see if you can see any songs.

    If that doesn’t work step by step, then I’ll need more information, like:

    1. Where is your iTunes mucis stored? Is it local to the machine running the server, or it is in on a network drive?

    2. How is your PC and your Soundbridge connected? Is one wired and one wireless? And if one of them is wireless, then what kind of wireless router do you have.

    I think that should make it go, though.

    — Ron

    #9943

    motte_
    Participant

    Hi,
    I think I managed to solve the problem. I had forgotten that my router had a virtual server and I had to open up a port. When I opened port 9999 FireFly seemed to start to scan. Unfortunately I had no time to finish testing yesterday so I will look into it again Friday.
    Thanks for your help so far.

    #9944

    motte_
    Participant

    Hi again,
    I still got problems.
    It seems that Firefly just keep scanning and scanning. I had the computer on all night and in the morning it was over 10000 threads and still keep searching (I use Debug Level 9). I’ve started a new scan and when I hit Refresh the last column say:
    2007-04-14 11:50:06 (1a463fac): Converting socket to fd
    2007-04-14 11:50:06 (1a463fac): Returning fd 514
    2007-04-14 11:50:06 (16f2043d): Thread 434: Entering ws_dispatcher (Connection from 127.0.0.1)
    2007-04-14 11:50:06 (16f2043d): Thread 434: got request
    2007-04-14 11:50:06 (16f2043d): Request: GET /xml-rpc?method=stats HTTP/1.1
    2007-04-14 11:50:06 (16f2043d): Thread 434: Read: Accept: */*
    2007-04-14 11:50:06 (16f2043d): Thread 434: Adding header *Accept=*/**
    2007-04-14 11:50:06 (16f2043d): Added *Accept=*/**
    2007-04-14 11:50:06 (16f2043d): Thread 434: Read: Accept-Language: sv
    2007-04-14 11:50:06 (16f2043d): Thread 434: Adding header *Accept-Language=sv*
    2007-04-14 11:50:06 (16f2043d): Added *Accept-Language=sv*
    2007-04-14 11:50:06 (16f2043d): Thread 434: Read: x-prototype-version: 1.4.0
    2007-04-14 11:50:06 (16f2043d): Thread 434: Adding header *x-prototype-version=1.4.0*
    2007-04-14 11:50:06 (16f2043d): Added *x-prototype-version=1.4.0*
    2007-04-14 11:50:06 (16f2043d): Thread 434: Read: Referer: http://localhost:9999/index.html
    2007-04-14 11:50:06 (16f2043d): Thread 434: Adding header *Referer=http://localhost:9999/index.html*
    2007-04-14 11:50:06 (16f2043d): Added *Referer=http://localhost:9999/index.html*
    2007-04-14 11:50:06 (16f2043d): Thread 434: Read: x-requested-with: XMLHttpRequest
    2007-04-14 11:50:06 (16f2043d): Thread 434: Adding header *x-requested-with=XMLHttpRequest*
    2007-04-14 11:50:06 (16f2043d): Added *x-requested-with=XMLHttpRequest*
    2007-04-14 11:50:06 (16f2043d): Thread 434: Read: UA-CPU: x86
    2007-04-14 11:50:06 (16f2043d): Thread 434: Adding header *UA-CPU=x86*
    2007-04-14 11:50:06 (16f2043d): Added *UA-CPU=x86*
    2007-04-14 11:50:06 (16f2043d): Thread 434: Read: Accept-Encoding: gzip, deflate
    2007-04-14 11:50:06 (16f2043d): Thread 434: Adding header *Accept-Encoding=gzip, deflate*
    2007-04-14 11:50:06 (16f2043d): Added *Accept-Encoding=gzip, deflate*
    2007-04-14 11:50:06 (16f2043d): Thread 434: Read: User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
    2007-04-14 11:50:06 (16f2043d): Thread 434: Adding header *User-Agent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)*
    2007-04-14 11:50:06 (16f2043d): Added *User-Agent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)*
    2007-04-14 11:50:06 (16f2043d): Thread 434: Read: Host: localhost:9999
    2007-04-14 11:50:06 (16f2043d): Thread 434: Adding header *Host=localhost:9999*
    2007-04-14 11:50:06 (16f2043d): Added *Host=localhost:9999*
    2007-04-14 11:50:06 (16f2043d): Thread 434: Read: Connection: Keep-Alive
    2007-04-14 11:50:06 (16f2043d): Thread 434: Adding header *Connection=Keep-Alive*
    2007-04-14 11:50:06 (16f2043d): Added *Connection=Keep-Alive*
    2007-04-14 11:50:06 (16f2043d): Thread 434: Read:
    2007-04-14 11:50:06 (16f2043d): Thread 434: Headers parsed!
    2007-04-14 11:50:06 (16f2043d): Checking to see if connection matches close
    2007-04-14 11:50:06 (16f2043d): And it does NOT
    2007-04-14 11:50:06 (16f2043d): Thread 434: Connection type HTTP/1.1
    : Connection: persist
    2007-04-14 11:50:06 (16f2043d): Thread 434: parsing GET args
    2007-04-14 11:50:06 (16f2043d): Thread 434: Entering ws_getgetvars (method=stats)
    2007-04-14 11:50:06 (16f2043d): Thread 434: Adding arg method = stats
    2007-04-14 11:50:06 (16f2043d): Added *method=stats*
    2007-04-14 11:50:06 (16f2043d): Thread 434: Done parsing GET/POST args!
    2007-04-14 11:50:06 (16f2043d): Thread 434: Original URI: /xml-rpc
    2007-04-14 11:50:06 (16f2043d): Thread 434: Translated URI: /xml-rpc
    2007-04-14 11:50:06 (16f2043d): Thread 434: Preparing to find handler
    2007-04-14 11:50:06 (16f2043d): Thread 434: URI Match!
    2007-04-14 11:50:06 (16f2043d): Thread 434: Time is 1176544206 seconds after epoch
    2007-04-14 11:50:06 (16f2043d): Thread 434: Setting time header
    2007-04-14 11:50:06 (16f2043d): Added *Date=Sat, 14 Apr 2007 09:50:06 GMT*
    2007-04-14 11:50:06 (16f2043d): Added *Connection=keep-alive*
    2007-04-14 11:50:06 (16f2043d): Added *Server=mt-daapd/svn-1359*
    2007-04-14 11:50:06 (16f2043d): Added *Content-Type=text/html*
    2007-04-14 11:50:06 (16f2043d): Added *Content-Language=en_us*
    2007-04-14 11:50:06 (16f2043d): Thread 434: Using non-default handler
    2007-04-14 11:50:06 (16f2043d): in main_auth
    2007-04-14 11:50:06 (16f2043d): Entering candispatch
    2007-04-14 11:50:06 (16f2043d): Dispatching auth for /xml-rpc to config auth
    2007-04-14 11:50:06 (16f2043d): Checking if 127.0.0.1 is local
    2007-04-14 11:50:06 (16f2043d): in main_handler
    2007-04-14 11:50:06 (16f2043d): Entering candispatch
    2007-04-14 11:50:06 (16f2043d): Dispatching /xml-rpc to config handler
    2007-04-14 11:50:06 (16f2043d): Checking if 127.0.0.1 is local
    2007-04-14 11:50:06 (16f2043d): Entering config_handler
    2007-04-14 11:50:06 (16f2043d): Entering config_set_status
    2007-04-14 11:50:06 (16f2043d): Exiting config_set_status
    2007-04-14 11:50:06 (16f2043d): Updating Connection from keep-alive to close
    2007-04-14 11:50:06 (16f2043d): Entering config_set_status
    2007-04-14 11:50:06 (16f2043d): Exiting config_set_status
    2007-04-14 11:50:06 (16f2043d): Added *Cache-Control=no-cache*
    2007-04-14 11:50:06 (16f2043d): Added *Expires=-1*
    2007-04-14 11:50:06 (16f2043d): Updating Content-Type from text/html to text/xml; charset=utf-8
    2007-04-14 11:50:06 (16f2043d): Emitting reponse header Expires: -1
    2007-04-14 11:50:06 (16f2043d): Emitting reponse header Cache-Control: no-cache
    2007-04-14 11:50:06 (16f2043d): Emitting reponse header Content-Language: en_us
    2007-04-14 11:50:06 (16f2043d): Emitting reponse header Content-Type: text/xml; charset=utf-8
    2007-04-14 11:50:06 (16f2043d): Emitting reponse header Server: mt-daapd/svn-1359
    2007-04-14 11:50:06 (16f2043d): Emitting reponse header Connection: close
    2007-04-14 11:50:06 (16f2043d): Emitting reponse header Date: Sat, 14 Apr 2007 09:50:06 GMT
    2007-04-14 11:50:06 (16f2043d): Executing: select count(*) FROM songs
    2007-04-14 11:50:06 (16f2043d): Thread 434: xml-rpc served
    2007-04-14 11:50:06 (16f2043d): Entering config_set_status
    2007-04-14 11:50:06 (16f2043d): Exiting config_set_status
    2007-04-14 11:50:06 (16f2043d): Thread 434: Terminating
    2007-04-14 11:50:06 (16f2043d): Thread 434: Freeing request headers
    2007-04-14 11:50:06 (16f2043d): Thread 434: Freeing response headers
    2007-04-14 11:50:06 (16f2043d): Thread 434: Freeing request vars
    2007-04-14 11:50:06 (16f2043d): Thread 434: Closing fd
    2007-04-14 11:50:06 (16f2043d): With thread 434 exiting, 1 are still running
    When I changed the Debug Level to 0, then it comes up with 0 songs.

    One thing that maybe can be of help is when I open the Firefly web page it says under Client IP:
    Client IP Action
    127.0.0.1 Serving xml-rpc method
    192.168.1.230 (null)

    The information you asked for:
    1. Where is your iTunes mucis stored? Is it local to the machine running the server, or it is in on a network drive?
    Answer: It is local
    2. How is your PC and your Soundbridge connected? Is one wired and one wireless? And if one of them is wireless, then what kind of wireless router do you have.
    Answer: Wireless
    Router: OfficeConnect Wireless 11g Cable/DSL Router, Version 2.00.02

    #9945

    rpedde
    Participant

    @motte_ wrote:

    It seems that Firefly just keep scanning and scanning. I had the computer on all night and in the morning it was over 10000 threads and still keep searching (I use Debug Level 9). I’ve started a new scan and when I hit

    That’s normal, it checks for new songs and stuff in the background, and it starts a new thread every time.

    What exactly isn’t working, because from the log file, it looks okay.

    — Ron

    #9946

    motte_
    Participant

    There are no songs when I’m trying to connect through my SB (0 playlists, 0 artists…).

    #9947

    rpedde
    Participant

    @motte_ wrote:

    There are no songs when I’m trying to connect through my SB (0 playlists, 0 artists…).

    What is your music directory set to, and is there any music in that directory?

    #9948

    motte_
    Participant

    C:Documents and SettingsÄgarenMina dokumentMin musikiTunes
    The same as in Itunes.
    Itunes containes 1580 files, 804 mapps and 8,39 GB

    #9949

    rpedde
    Participant

    @motte_ wrote:

    C:Documents and SettingsÄgarenMina dokumentMin musikiTunes
    The same as in Itunes.
    Itunes containes 1580 files, 804 mapps and 8,39 GB

    Aaah… that’s a unicode problem. Upgrade to the 1.1b here:

    http://forums.rokulabs.com/viewtopic.php?t=11098

    and that should fix you up.

    — Ron

    #9950

    motte_
    Participant

    I’m sorry but that didn’t fix the problem. I installed FireFly 1.0 svn-1483 and I still have zero songs when I try to connect through my SB 🙁

    #9951

    rpedde
    Participant

    @motte_ wrote:

    I’m sorry but that didn’t fix the problem. I installed FireFly 1.0 svn-1483 and I still have zero songs when I try to connect through my SB 🙁

    That’s from the 1.1beta link? It’s not 1490 or 1491 or something?

    Try this: http://nightlies.mt-daapd.org/Firefly%20Media%20Server%20%28svn-1489%29.exe

    That’s 1489, and it has all the unicode fixes. If that doesn’t work, then it’s something I haven’t seen before, and I’d like to get a log file from you install to see if I can figure out what its doing.

    — Ron

    #9952

    motte_
    Participant

    I’ve installed Firefly Service 1.0 svn-1489 but it didn’t work. Sorry to ask a dumb question but where do I find my log file from my install?
    I’ve copied the start up in the FireFly log. It was quite a bit. Should I post it here in the forum or should I mail it to you (if you want it)?
    For your information I have reinstalled Bonjour and Firefly.

    #9953

    rpedde
    Participant

    @motte_ wrote:

    I’ve installed Firefly Service 1.0 svn-1489 but it didn’t work. Sorry to ask a dumb question but where do I find my log file from my install?
    I’ve copied the start up in the FireFly log. It was quite a bit. Should I post it here in the forum or should I mail it to you (if you want it)?
    For your information I have reinstalled Bonjour and Firefly.

    Can you go into the web admin and set the debuglevel (might be called loglevel) and set it to 9? Then start the server normally, stop it, and zip up the “firefly.log” in c:program filesfirefly media server and email it to me at [email protected].

    That would help a lot. Thanks.

    — Ron

    #9954

    motte_
    Participant

    I’ve just emailed the log file.

    #9955

    rpedde
    Participant

    @motte_ wrote:

    I’ve just emailed the log file.

    Thank you.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.