Newbie question about using firefly on Maxtor mss+

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server General Discussion Newbie question about using firefly on Maxtor mss+

Viewing 12 posts - 46 through 57 (of 57 total)
  • Author
    Posts
  • #7479
    rpedde
    Participant

    @Iris wrote:

    Even though the time setting via the MSS web interface and that viewed via explorer is correct the one recorded in Firefly’s log is 2 hours behind. Is there another location that the time should be set for Firefly? My location is 6 hours behind UTC and DST is off.

    Iris

    Nope, it gets the time from the system, so that must be the time on the machine. You can check by doing a “date” from the console.

    #7480
    Iris
    Participant

    @rpedde wrote:

    @Iris wrote:

    Even though the time setting via the MSS web interface and that viewed via explorer is correct the one recorded in Firefly’s log is 2 hours behind. Is there another location that the time should be set for Firefly? My location is 6 hours behind UTC and DST is off.

    Iris

    Nope, it gets the time from the system, so that must be the time on the machine. You can check by doing a “date” from the console.

    Well, not that this is directly related to Firefly but I would of thought that the time/date shown on the MSS web interface was the date stored on that machine but I’m getting conflicting results. I read somewhere on a Wiki about setting this so I’ll have to try and find that again. Hmmmm…

    Iris

    #7481
    Iris
    Participant

    I’ve tried a modified version of what was posted on the FAQ for the MSS – that being:

    # nvram set time_zone=CST+6CST
    # nvram commit
    # ntpclient -h 192.43.244.18 -s
    # hwclock -w
    # reboot

    and it seems to be working after a few tries getting it right. I initially relied upon the MSS web interface but I guess I can’t rely on it 100%. In fact, in my searches I did find a post that mentioned the time set feature of the web interface had a bug in it but a version wasn’t mentioned.

    #7482
    RickV
    Participant

    Hi Ron,

    I tested with a smaller music-folder. Just one “CD” in it and then it works well. So it looks like there is a limitation on the number of songs in a music-folder.

    In the advanced settings I see that it’s possible to select sqlite3 as database type. Do you think it’s possible that version can handle bigger music folders?

    Greetings,
    Rick
    PS: Did you receive the compressed songs-database?

    #7483
    rpedde
    Participant

    @RickV wrote:

    Hi Ron,

    I tested with a smaller music-folder. Just one “CD” in it and then it works well. So it looks like there is a limitation on the number of songs in a music-folder.

    In the advanced settings I see that it’s possible to select sqlite3 as database type. Do you think it’s possible that version can handle bigger music folders?

    Greetings,
    Rick
    PS: Did you receive the compressed songs-database?

    I don’t believe it’s a limit on number of songs. There are folks that are running over 100K songs. I did get the database, but haven’t loaded it up yet. I hope to look at it later tonight.

    — Ron

    #7484
    anton90125
    Participant

    I took the plunge! Followed all your clear steps.

    The server installed with no problem.

    In server setup/config I had an error 500- something about MP3 dir?
    Anyway this cleared up after my 4th attempted.

    My last outstanding problem is the connection between my soundbridge and my wireless router. I have to use a wireless set up when my roku is sitting with my hifi (though I have tested it with an ethernet cable stretching across my room). Because I am using FLAC, I have bandwidth issues. I am using a d-link wireless bridge to get 802.11g performance but I am experiencing rebuffering at the roku end. I am in the process of getting D-Link DI-624M Super G with speeds upto 108Mbps. I am hoping that this will sort this data bottle neck out. Is there no config setting on the firefly which can help this flow?

    Thanks for you assistance in writing a superb “How do Iā€. And thank you for a superb piece of software.

    #7485
    rpedde
    Participant

    @anton90125 wrote:

    Because I am using FLAC, I have bandwidth issues. I am using a d-link wireless bridge to get 802.11g performance but I am experiencing rebuffering at the roku end. I am in the process of getting D-Link DI-624M Super G with speeds upto 108Mbps. I am hoping that this will sort this data bottle neck out. Is there no config setting on the firefly which can help this flow?

    Not really, not on the firefly end. Encoding it back to mp3 might help, although it would make the flacs lossy, which kind of defeats the purpose of keeping the music in flac. šŸ™

    I’d guess the problem is less one of speed as it is signal quality. It might be that you can find a better position for the wirelss bridge, or reposition antennas on the access point or something to get you a better signal strength where the soundbridge is. I think that’s the main problem — signal strength, not bandwidth. Although who knows… with a “super G”, you might be able to get two mediocre connections which might be enough to keep the soundbridge from rebuffering. Not sure. I’m assuming the bridge is capable of Super G?

    #7486
    S80_UK
    Participant

    @anton90125 wrote:

    Because I am using FLAC, I have bandwidth issues. I am using a d-link wireless bridge to get 802.11g performance but I am experiencing rebuffering at the roku end. I am in the process of getting D-Link DI-624M Super G with speeds upto 108Mbps. I am hoping that this will sort this data bottle neck out. Is there no config setting on the firefly which can help this flow?

    Hi,
    I’m not sure that this is your problem. I run with a large number of FLAC files (trancoded to WAV on a Slug) and I am wireless to a SB1000 with the original 802.11b wi-fi card, so the link for that device is limited to 11Mbits/sec. I have no rebuffering problems. Have you checked to make sure that there are no other local wireless networks using the same channel? Strong interference could easily be responsible for the loss of data that you are seeing.

    #7487
    anton90125
    Participant

    I tried adjusting the arieal position, the position of the wireless bridge relative to the router and every channel 1 to 13-but to no avail. I did discovered that there was another wireless network on channel 12.
    The roku rebuffered every 30 seconds (playtime). Connecting directly with a ethernet cable -no problem -no buffering. I still believe that is a bandswidth problem.I am now awaiting the super G wireless router. The wireless bridge is already super G. I still would welcome any advise.

    Anton šŸ˜•

    #7488
    richdunlop
    Participant

    Anton,

    I’ve had lots of painful experience of setting up Roku Soundbridges wirelessly and I have to say that I’m with S80_UK on this one – in my experience rebuffering is almost always caused by poor wireless performance or interference. Unless your wlan is very, very busy you should have plenty bandwidth to do what you are trying to do.

    To fix my wireless issues (including rebuffering) I tried all sorts of things including bridges, MIMO routers etc. In the end I nailed the problem very cheaply by buying some cheap Buffalo routers, installing dd-wrt and boosting transmit power. No more wireless issues, Roku disconnects or rebuffering. In fact, I’m gradually coming round to thinking that wireless might actually be a viable networking technology!

    Hope that helps,
    rich

    #7489
    schro20
    Participant

    I ran into something similar to what was reported in this thread already. I got to the ipkg step which failed. Doing route -n I see that the kernel got my gateway wrong. It thinks it is 192.168.0.0 while it actually is 0.1. Interestingly the Maxtor configuration status page lists is correctly as 0.1. I also note that it got the DNS servers correct. So it is talking to the router to get this info, but somehow gets the gateway part wrong. I don’t know how to fix this. I did a reboot to no avail. The Maxtor gets a reserved address from the router which does DHCP.

    Added: I did
    route add default gw 192.168.0.1

    which fixed my issue. So far everything is hunky dory.

    I might suggest adding this as a hint to the MSS setup page since others seem to have run into it and I had a hard time finding documentation for “route” as it exists on the MSS. The above finally worked.

    I would also suggest that users who edit files on the box are reminded that it’s good practice to save the original as name.bak (or some such convention).

    Ready to serve!

    #7490
    rpedde
    Participant

    @schro20 wrote:

    I might suggest adding this as a hint to the MSS setup page since others seem to have run into it and I had a hard time finding documentation for “route” as it exists on the MSS. The above finally worked.

    I added something of a terse note on this. I might break troubleshooting out into a separate page or somthing, but at least the info is there now.

    — Ron

Viewing 12 posts - 46 through 57 (of 57 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.