You are here: Home » Topic » Newbie question about using firefly on Maxtor mss+

Newbie question about using firefly on Maxtor mss+

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server General Discussion Newbie question about using firefly on Maxtor mss+

This topic contains 56 replies, has 7 voices, and was last updated by  rpedde 10 years, 11 months ago.

Viewing 15 posts - 1 through 15 (of 57 total)
  • Author
    Posts
  • #810

    anton90125
    Participant

    Hello,

    Looking at the various treads I think this has been solved.

    I want to stream music (flac) from my NAS Maxtor MSS(2.6.2-openmss1-rc2) + to my Roku M1000.

    I have looked at twonkymedia and (from various comments in their forum) it appears that there are problems transcoding flac files on a nas (not enough processing power) using their flac plug-in.

    The Firefly community seems to have solved this problem though as a green newbie it is not clear how.

    Can someone please describe in clear steps the processes required to get firefly installed and working transcoding flac. Assume correctly my very limited knowledge of UNIX.

    Anton 😕

    #7435

    rpedde
    Participant

    @anton90125 wrote:

    Hello,

    Looking at the various treads I think this has been solved.

    I want to stream music (flac) from my NAS Maxtor MSS(2.6.2-openmss1-rc2) + to my Roku M1000.

    I have looked at twonkymedia and (from various comments in their forum) it appears that there are problems transcoding flac files on a nas (not enough processing power) using their flac plug-in.

    The Firefly community seems to have solved this problem though as a green newbie it is not clear how.

    Can someone please describe in clear steps the processes required to get firefly installed and working transcoding flac. Assume correctly my very limited knowledge of UNIX.

    Anton 😕

    I’ve started a wiki to try and build a manual for firefly. The first page is now the “Installing Firefly on the MSS” page. It’s kind of terse, but here’s a walkthrough:

    http://wiki.fireflymediaserver.org/MSS_Installation

    It’s really a “fattened up” version of this post: http://forums.fireflymediaserver.org/viewtopic.php?t=5102

    — Ron

    #7436

    anton90125
    Participant

    Brilliant!

    This is exactly what I am after.

    Thanks

    Anton

    #7437

    deanm

    I (hope to) have exactly the same setup, streaming via a Linksys WRT54GS AP and have followed the details on the wiki (at least one of the three attempts must have been correct ‘:)’).

    Everything goes swimmingly until I try to execute /opt/etc/init.d/S60Mt-daapd at which point I get /opt/lib/ld.so.1: not found.

    Following some of the other thread I tried the following:

    # /opt/lib/ld.so.1 /opt/sbin/mt-daapd -d9 -c /opt/etc/mt-daapd/mt-daapd.conf -f
    with a result
    /opt/lib/ld.so.1: not found

    I had a hunt around and found ld.so.1 to the /lib directory so tried

    # /lib/ld.so.1 /opt/sbin/mt-daapd -d9 -c /opt/etc/mt-daapd/mt-daapd.conf -f
    and this time got
    Found 1 tokens in /share/hdd/data/public/mp3
    Token 1: /share/hdd/data/public/mp3
    Expanding precomments to 2048
    Expanding precomments to 4096
    Found 2 tokens in rsp.so,ssc-script.so
    Token 1: rsp.so
    Token 2: ssc-script.so
    Checking existence of /opt/share/mt-daapd/admin-root
    Checking existence of /opt/share/mt-daapd/admin-root
    Checking existence of /opt/var/mt-daapd
    Checking existence of /opt/var/mt-daapd
    Checking existence of /opt/share/mt-daapd/plugins
    Checking existence of /opt/share/mt-daapd/plugins
    Loading new config file.
    Firefly Version svn-1433: Starting with debuglevel 9
    Attempting to load plugin /shares/mss-hdd/__opt/share/mt-daapd/plugins/out-daap.so
    SIGSEGV

    I’m not sure whether this is something missing, a version mismatch or just me being dumb!

    Any suggestions?

    Thanks
    Dean

    #7438

    rpedde
    Participant

    @deanm wrote:

    Any suggestions?

    Did you do the “ipkg install mss-libhelper”?

    The ld.so.1 library should be a part of that package. I’ll double check it.

    — Ron

    #7439

    deanm

    Yes, installed mss-libhelper without problem.

    BTW/ version svn-1433 was the version installed (maybe I just missed 1441)

    Dean

    #7440

    rpedde
    Participant

    @deanm wrote:

    Yes, installed mss-libhelper without problem.

    BTW/ version svn-1433 was the version installed (maybe I just missed 1441)

    Dean

    Okay. I’ll double-check that package.

    — Ron

    #7441

    Iris
    Participant

    @rpedde wrote:

    I’ve started a wiki to try and build a manual for firefly. The first page is now the “Installing Firefly on the MSS” page. It’s kind of terse, but here’s a walkthrough:

    http://wiki.fireflymediaserver.org/MSS_Installation

    — Ron

    Okay, I telnet into the device and started entering the commands. Well, the first line – cat src nslu2 …. I get a file not found error. 😕

    Use my browser to check the link I went to http://ipkg-us-dyoung.nslu2-linux.org/feeds/optware/mss/cross/unstable/ and I see a list of files. I also checked the post you mentioned where a lot of this came through and couldn’t see a similar command. What am I missing here. I did try it twice checking my syntax!

    Iris

    #7442

    rpedde
    Participant

    @iris wrote:

    Okay, I telnet into the device and started entering the commands. Well, the first line – cat src nslu2 …. I get a file not found error. 😕

    D’oh!

    That should be: echo “src nslu2…

    Not cat. Fixed the web page. Sorry. And after my exhortation to type everything EXACTLY they way it said, and I bungled it. Dumb.

    Sorry about that.

    BTW: I’m sitting in #mt-daapd on freenode, if anyone needs more help with this.

    – Ron

    #7443

    Iris
    Participant

    Well I’m going to hang around! Back to the instructions…

    Thanks

    #7444

    Iris
    Participant

    executing ipkg update generates a Host Lookup failure

    #7445

    rpedde
    Participant

    @iris wrote:

    executing ipkg update generates a Host Lookup failure

    That’s a network settings issue. Check the default gateway and the dns server settings on your mss. They should be the same as the dns and gateway ip addresses of your PC. Typically, that’s the ip address of your router.

    Again, you can contact me on AIM (rpedde68) or on IRC on #mt-daapd on freenode if you want to walk through this via conversation rather than round-tripping through the forums. 🙂

    — Ron

    #7446

    rpedde
    Participant

    @rpedde wrote:

    @deanm wrote:

    Yes, installed mss-libhelper without problem.

    BTW/ version svn-1433 was the version installed (maybe I just missed 1441)

    Dean

    Okay. I’ll double-check that package.

    — Ron

    Okay, I added a new package called “mss-ld-so”, try that. I didn’t want to add that to the libhelper package, as I think some firmware versions already include that file.

    — Ron

    #7447

    Iris
    Participant

    @rpedde wrote:

    @iris wrote:

    executing ipkg update generates a Host Lookup failure

    That’s a network settings issue. Check the default gateway and the dns server settings on your mss. They should be the same as the dns and gateway ip addresses of your PC. Typically, that’s the ip address of your router.

    Again, you can contact me on AIM (rpedde68) or on IRC on #mt-daapd on freenode if you want to walk through this via conversation rather than round-tripping through the forums. 🙂

    — Ron

    Sorry, I’m not set-up for either. I checked the netowkr settings before I even started. IP of MSS through the Status page all checks out, gateway, etc. The ip is dynamic – don’t know if that’s an issue.

    #7448

    rpedde
    Participant

    @iris wrote:

    @iris wrote:

    executing ipkg update generates a Host Lookup failure

    I checked the netowkr settings before I even started. IP of MSS through the Status page all checks out, gateway, etc. The ip is dynamic – don’t know if that’s an issue.

    Try this:


    # ping www.google.com
    PING www.l.google.com (216.239.51.104): 56 data bytes
    64 bytes from 216.239.51.104: icmp_seq=0 ttl=242 time=44.7 ms

    If you get the:

    PING http://www.x.google.com (###.###.###.###), then your dns is set right. If you don’t get an IP address there, then it’s likely that your dns is the problem.

    We can start with the basics… what’s the IP of your PC and your router? You can find your PC settings by doing “ipconfig /all” at a dos prompt on the PC. If it’s something like 192.168.1.1 for the router and 192.168.1.100 for the PC, then the mss should be something like that as well… 192.168.1.something.

    Generally, the gateway address is the address of the router: 192.168.1.1. In most home networking environments, that’s the address one should use for DNS as well.

    On the mss, you can see the IP address it has by doing “ifconfig eth0” from a telnet window.

    You can see the gateway by doing “route -n” and looking for the Gateway for the 0.0.0.0 destination.

    You can see the dns server by doing “cat /etc/resolv.conf” and checking for a “nameserver” line.

    I’d guess one of those things isn’t right, or doesn’t match your internal network settings.

Viewing 15 posts - 1 through 15 (of 57 total)

You must be logged in to reply to this topic.