You are here: Home » Topic » New NSLU2 and mt-daapd issue on unslung v6.8

New NSLU2 and mt-daapd issue on unslung v6.8

This topic contains 1 reply, has 0 voices, and was last updated by  furtive 11 years, 2 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #476

    furtive

    My new NSLU2 arrived yesterday so I wasted no time in hacking it.

    I installed Unslung v6.8 as per the instructions here with no problems, and have installed mt-daapd which gave the following result:

    # ipkg install -force-reinstall mt-daapd
    Reinstalling mt-daapd (0.2.4-1) on root…
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/nslu2/cross/stable/mt-daapd_0.2.4-1_armeb.ipk
    conffile_has_been_modified: conffile /opt/etc/mt-daapd/mt-daapd.conf has no md5sum
    conffile_has_been_modified: conffile /opt/etc/mt-daapd/mt-daapd.playlist has no md5sum
    Configuring mt-daapd

    To complete this installation, make any necessary changes
    to the config file in /opt/etc/mt-daapd/mt-daapd.conf, and
    start the daemon by running /opt/etc/init.d/S60mt-daapd

    However, when I try and start it by running

    # /opt/etc/init.d/S60mt-daapd

    I get the following error:

    /opt/sbin/mt-daapd: error while loading shared libraries: libz.so: cannot open shared object file: No such file or directory.

    I have searched my slugs disk and the file libz.so does not exist – could it be missing from the 6.8 release of unslung? Or can anyone think of anything else I might have done wrong?

    I tried enabling logging by editing /opt/etc/init.d/S60mt-daapd and also added -d2 to the command line in the script, but there is no log being generated in /var/log[/url]

    #5718

    furtive

    I seem to have fixed it by re-running

    # ipkg update
    # ipkg install unslung-feeds
    # ipkg update

    and then running

    ipkg install -force-overwrite mt-daapd

    (which said it had nothing to do)

    I also had to change the path of my mp3 folder from /share/hdd/data/public/mp3 to just /public/mp3

    I now see mt-daapd in iTunes. However, I also see firefly 😮

    I’ll see if I can sort that out…

    EDIT: Stupidity alert. The Firefly server was running on my PC!

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.