You are here: Home » Topic » Netgear NAS-Duo and Firefly JAVA client on Mac

Netgear NAS-Duo and Firefly JAVA client on Mac

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues Netgear NAS-Duo and Firefly JAVA client on Mac

This topic contains 2 replies, has 2 voices, and was last updated by  FogCityNative 8 years, 10 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2809

    FogCityNative
    Participant

    I have set up Firefly on my NetGear NAS Duo, opened the ports 3689 on my Buffalo router and pointed them to the NAS, and I can use the Firefly Java client to access the music locally without a problem.

    But if I enter my EXTERNAL IP address (or my dyndns.org domain name) in the Java client, it simply will not connect. Here’s the error message I get:

    [FireflyClientException] class java.net.ConnectException – Unable to connect (Connection refused).
    at net.firefly.client.controller.request.RSPRequestManager.isAuthenticationRequired(RSPRequestManager.java:125)
    at net.firefly.client.gui.swing.dialog.NewHostDialog$OKButtonActionListener$1.run(NewHostDialog.java:279)
    at java.lang.Thread.run(Thread.java:613)

    I am not a programmer or a Unix jock and I don’t know what this message is trying to tell me . . . can anyone please help me??

    I want to give this java applet to my friends so they can access and play my music files on their computers . . . but how???

    #18231

    Anonymous

    @fogcitynative wrote:

    I have set up Firefly on my NetGear NAS Duo, opened the ports 3689 on my Buffalo router and pointed them to the NAS, and I can use the Firefly Java client to access the music locally without a problem.

    But if I enter my EXTERNAL IP address (or my dyndns.org domain name) in the Java client, it simply will not connect. Here’s the error message I get:

    [FireflyClientException] class java.net.ConnectException – Unable to connect (Connection refused).
    at net.firefly.client.controller.request.RSPRequestManager.isAuthenticationRequired(RSPRequestManager.java:125)
    at net.firefly.client.gui.swing.dialog.NewHostDialog$OKButtonActionListener$1.run(NewHostDialog.java:279)
    at java.lang.Thread.run(Thread.java:613)

    I am not a programmer or a Unix jock and I don’t know what this message is trying to tell me . . . can anyone please help me??

    I want to give this java applet to my friends so they can access and play my music files on their computers . . . but how???

    You should check your configuration to see which port is open from the internet.
    Try pointing your browser to http://dyndns.org.domain.name:3689/ and you should access your firefly server configuration page. If you don’t, the firefly client won’t. If you do, try accessing http://dyndns.org.domain.name:3689/rsp/info with your browser (the request that causes your error).
    If previous works well in your browser, check its proxy parameters to see if a proxy is configured and if so, copy the proxy parameters in firefly client preferences popup.

    #18232

    FogCityNative
    Participant

    @caribou wrote:

    You should check your configuration to see which port is open from the internet.
    Try pointing your browser to http://dyndns.org.domain.name:3689/ and you should access your firefly server configuration page. If you don’t, the firefly client won’t. If you do, try accessing http://dyndns.org.domain.name:3689/rsp/info with your browser (the request that causes your error).
    If previous works well in your browser, check its proxy parameters to see if a proxy is configured and if so, copy the proxy parameters in firefly client preferences popup.

    Thanks, I tried to ping http://dyndns.org.domain.name and it took me right to the log in screen for my Buffalo Router.

    But once I appended the port 3689 it would no longer resolve.

    Checking using ping, it appears that it is being blocked at OpenDNS, the company providing my DNS Servers, because instead of resolving to my WAN IP or to the IP of my NAS, it resolves to an OpenDNS IP.

    More ideas please, I think you are on the right track . . .

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.