You are here: Home » Topic » Need help installing mt-daapd with FLAC support

Need help installing mt-daapd with FLAC support

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues Need help installing mt-daapd with FLAC support

This topic contains 10 replies, has 2 voices, and was last updated by  don quixada 10 years, 1 month ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #212

    RazzleCat

    I am running the mt-daapd nightly 20060324 on a Kurobox PPC Linux server (standard install, not Gentoo) and am trying to recompile mt-daapd with FLAC support. I have the flac binary in /usr/bin but do not have libFLAC installed (due to ppc support issues). Whenever I try to compile mt-daapd with –enable-flac I get an error about libFLAC not being found. Is there anyway around this? Has anyone successfully installed libFLAC on a standard Kurobox?

    Any assistance is much appreciated!

    #4130

    rpedde
    Participant

    You can compile it without –enable-flac, and just add .flac to your extensions. It will work, you just won’t get file metadata (title, author, album, etc).

    Why doesn’t flac work on the kuro? It works on all the other ppc platforms I have, seems like it should work on kuro, too.

    — Ron

    #4131

    RazzleCat

    Thanks for the reply Ron.

    I’m not sure why, but I cannot compile flac on my Kuro as I get errors about altivec not being found, even though I try to compile with altivec and asm support disabled. From the few results Google yields, it looks like others have had a similar issue, so I may look for an older version of flac (both 1.1.1 and 1.1.2 have the same issue).

    I have tried playing flac files on the SoundBridge but this isn’t working either. I can see the files – type Wav, plus a valid length in the properties, but they won’t play. If I check the mt-daapd.log, it seems to be streaming them okay.

    Any suggestions on things to check?

    #4132

    rpedde
    Participant

    Run it with a -d9, and it should show you the command it is using to transcode. Run that command right from the command line, and make sure it pumps back a bunch of crap at you.

    You could also run that and redirect it to something.wav and make sure that .wav file plays on a regular machine, too.

    #4133

    RazzleCat

    I’ve tried running mt-daapd with -d9 and reviewed the output. However I cannot see any obvious lines such as a call to mt-daapd-ssc.sh in there. What should I be looking for?

    Incidentally, I tried running


    /usr/local/sbin/mt-daapd.sh /mnt/other/test.flac 0 0

    and get a whole lot of garbage output to the screen.

    If I try to output this to a file with


    /usr/local/sbin/mt-daapd.sh /mnt/other/test.flac 0 0 > /mnt/other/test.wav

    I get the error wavstreamer: Read failed.

    Post edited by: RazzleCat, at: 2006/03/30 12:28

    #4134

    rpedde
    Participant

    If you run mt-daapd with -d5 you should see something like:


    Thread 2: Autoconvert file /Users/ron/working/mt-daapd/src/new-mp3/ogg/Genesis_-_LTWW10_Tonight,Tonight,Tonight.ogg for client
    Executing ./mt-daapd-ssc.sh "/Users/ron/working/mt-daapd/src/new-mp3/ogg/Genesis_-_LTWW10_Tonight,Tonight,Tonight.ogg" 0 215.600 "ogg"

    Try running that, with quotes and everything, and redirect it to a file.

    Also, you might try editing the mt-daapd.sh and putting explicit paths to flac and wavstreamer, since your paths and environment will be different when running as a daemon.

    #4135

    RazzleCat

    Thanks Ron. This is odd. I’ve added explicit paths for wavstream and flac and tried running mt-daapd with d-5. The first 10 or so tracks the Roku tried playing didn’t work but then the next one out of every 10 or so actually did play fine. Here’s a sample of the output running -d -f :

    Session 1: Streaming file '01 - Professional Jealousy .flac' to 192.168.2.11 (offset 0)
    Finished streaming file to remote: 16384 bytes
    Session 1: Streaming file '01 - Roadhouse Blues.flac' to 192.168.2.11 (offset 0)
    Finished streaming file to remote: 16384 bytes
    Thread 129: Autoconvert file /mnt/itunes/__FLAC/Counting Crows - August And Everything After (1993)[FLAC](MFSL)/01 - Round Here.flac for client
    Executing /usr/local/sbin/mt-daapd-ssc.sh "/mnt/itunes/__FLAC/Counting Crows - August And Everything After "'('"1993"')'"[FLAC]"'('"MFSL"')'"/01 - Round Here.flac" 0 333.826 "flac"
    Session 1: Streaming file '01 - Round Here.flac' to 192.168.2.11 (offset 0)
    Finished streaming converted file to remote
    wavstreamer: Write failed.

    Note that only the last track above actually played. I outputted the following to a wav file, and this plays back fine.


    /usr/local/sbin/mt-daapd-ssc.sh "/mnt/itunes/__FLAC/Counting Crows - August And Everything After "'('"1993"')'"[FLAC]"'('"MFSL"')'"/01 - Round Here.flac" 0 333.826 "flac" > /mnt/other/august.wav

    Post edited by: RazzleCat, at: 2006/03/31 14:24

    Post edited by: RazzleCat, at: 2006/03/31 14:25

    #4136

    RazzleCat

    Incidentally, I have tried manually outputting various flac files to wavs (as per my previous post) and both files that play via mt-daapd and those that fail, output playable wavs fine…

    #4137

    rpedde
    Participant

    Can you send me on the of the flacs that don’t play? You can send me a link or the file at ron at pedde.com.

    #4138

    rpedde
    Participant

    Fixed in r914

    http://trac.mt-daapd.org/index.cgi/changeset/914

    You’ll have to add the codectype “unkn” to your list of codectypes to transcode.

    — Ron

    #4139

    don quixada
    Participant

    I don’t know if this was/is your problem, but when I updated the flac codecs it broke firefly. I had to re-build firefly and then everything worked again.

    dq

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.