You are here: Home » Topic » My Soundbridge can’t connect

My Soundbridge can’t connect

This topic contains 8 replies, has 3 voices, and was last updated by  rpedde 11 years, 8 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1745

    mishadreams
    Participant

    Hi,

    My SB (?) can see my wi-fi network but when trying to connect just says ” no DCHP connection using local link”

    whats going on. I’m running firefly svn 1586 after reading this forum. Initailly Firefly wouldn’t stop “starting up” an issue which has been resolved by shortening the default name as suggested. I’ve disabled my firewall, though the SB could always see the network and at a loss as to what to try now.

    Does iTunes need to be running?

    any ideas folks greatfully recieved.

    cheers

    mike

    #12649

    rpedde
    Participant

    @mishadreams wrote:

    Hi,

    My SB (?) can see my wi-fi network but when trying to connect just says ” no DCHP connection using local link”

    whats going on. I’m running firefly svn 1586 after reading this forum. Initailly Firefly wouldn’t stop “starting up” an issue which has been resolved by shortening the default name as suggested. I’ve disabled my firewall, though the SB could always see the network and at a loss as to what to try now.

    Does iTunes need to be running?

    any ideas folks greatfully recieved.

    cheers

    mike

    No, it sounds like the sb has dropped the wirless connection. If it says it can’t get a dhcp address, then it’s not seeing the rest of your network.

    Either that or you don’t have a dhcp server on your network but that would be surprising, as most routers have dhcp built-in.

    Double check that your wireless connection is set up okay and the sb can see it fine.

    Then check your ip on the soundbridge (should show up on your system config menu option (i think that’s what it’s called)), and see ifyou can ping that address from your workstation.

    #12650

    mishadreams
    Participant

    Hi, Many thanks for the response.

    I’m still not having any joy I’m afraid.

    The WIfi status reports like this:

    Connected to wireless network M**********
    quality:100 Signal: -65dBm
    IP address: 169.254.14.107
    MAC address: 00:0D:4B:21:08:81
    Netmask: 255.255.0.0
    gateway: 0.0.0.0
    DNS1: 0.0.0.0
    DNS2: 0.0.0.0

    So I take it from this that the SB can see and is connected to the WiFi. Firefly is running, the log reads like this:

    2007-09-27 18:29:54 (a000ed88): Starting with debuglevel 0
    2007-09-27 18:29:54 (a000ed88): Starting rendezvous daemon
    2007-09-27 18:29:54 (a000ed88): Starting signal handler
    2007-09-27 18:29:55 (a000ed88): Initializing database
    2007-09-27 18:30:21 (a000ed88): Starting web server from /Library/PreferencePanes/Firefly.prefPane/Contents/Resources/Firefly Helper.app/Contents/Resources/Server/admin-root on port 0
    2007-09-27 18:30:21 (a000ed88): Registering rendezvous names
    2007-09-27 18:30:23 (a000ed88): Serving 2252 songs. Startup complete in 30 seconds
    2007-09-27 18:30:23 (a000ed88): Rescanning database
    2007-09-27 18:30:29 (a000ed88): Starting playlist scan
    2007-09-27 18:30:33 (a000ed88): Scanned 2252 songs (was 2252) in 10 seconds

    Healthy?

    Any suggestions?

    Firstly, am I right in assuming that iTunes doesn’t need to be running as long as firefly is and secondly, my computer is connected to the router via Ethernet, does airport need to be running on my computer as well?

    again many thanks

    mike
    thanks in advance

    #12651

    andyg
    Participant

    IP address: 169.254.14.107

    that’s most liekly your problem – soundbridge not picking up a dhcp ip address off the same range as your router – it needs to be 192.168.x.x or similar. Your gateway shows 0.0.0.0 it should in fat be your router’s ip – most likely 192.168.2.1

    have a look at this from roku support and follow the instructions to set a static ip

    http://www.rokulabs.com/support/soundbridge/static_ip.php

    holler if that doesn’t fix it 😉

    #12652

    mishadreams
    Participant

    Hi again, and thansks for the reply 😆

    I’m trying to follow the links though they are for a PC and I’m on a mac. I can change the IP address on my system through System Preferences – network -. I then change the Systems IP address to match the IP address on the soundbridge. The I use the Terminal to try to contact the Soundbridge using it’s IP address begining 169.254.x.x. but Terminal reports thus:

    Last login: Fri Sep 28 08:51:18 on ttyp2
    Welcome to Darwin!
    Macintosh:~ Michaels$ telnet 169.254.14.107
    Trying 169.254.14.107…
    telnet: connect to address 169.254.14.107: Connection refused
    telnet: Unable to connect to remote host
    Macintosh:~ Michaels$

    I’m not sure what I’m doing wrong 😥 As I can’t contact the soundbridge I can’t change it’s IP address. Why can I not telnet to the Soundbridge?

    And why is this so complicated?

    thanks in advance

    #12653

    andyg
    Participant

    The I use the Terminal to try to contact the Soundbridge using it’s IP address begining 169.254.x.x. but Terminal reports thus:

    when you telnet to the SB ensure you type 169.254.14.107 4444

    does it let you in now?

    #12654

    mishadreams
    Participant

    no, it reports thus:

    Last login: Fri Sep 28 09:53:55 on console
    Welcome to Darwin!
    Macintosh:~ Michaels$ telnet 169.254.14.107 4444
    Trying 169.254.14.107…
    telnet: connect to address 169.254.14.107: Connection refused
    telnet: Unable to connect to remote host
    Macintosh:~ Michaels$

    thanks

    #12655

    andyg
    Participant

    A general suggestion at this point is to confirm you have the latest firware on your router and that you ARE wireless when trying to telnet the SB.

    Another thought, when you changed the IP in system prefs/network to get onto the 169.254 range, did you renew the DHCP lease? Your mac may have thought it was still on a 192.168 range. Give that a whirl. If you can then telent in and give the SB a static address remember that you would need to change your mac back to the 192.168 range and again renew the DHCP lease.

    #12656

    rpedde
    Participant

    @mishadreams wrote:

    Connected to wireless network M**********
    quality:100 Signal: -65dBm
    IP address: 169.254.14.107
    MAC address: 00:0D:4B:21:08:81
    Netmask: 255.255.0.0
    gateway: 0.0.0.0
    DNS1: 0.0.0.0
    DNS2: 0.0.0.0

    169.254 addresses are part of apipa. it means your soundbridge didn’t get a dhcp address.

    I’d have to wonder if your wireless access point has a good connection to your wired network. Is it connected to your cable modem or dsl modem? Is the “link” light green?

    Usually it’s your cable modem that hands out dhcp addresses, and if your sb can’t get a dhcp address, it’s probably because the wireless access point isn’t connected to the rest of your network.

    If so, a static address won’t help. You have a more fundamental networking issue. Like a connectivity issue.

    Double-check cabling. That’s what I’d suspect. Particularly if your desktop pc can get to the internet.

    — Ron

Viewing 9 posts - 1 through 9 (of 9 total)

The forum ‘Setup Issues’ is closed to new topics and replies.