You are here: Home » Topic » mt-daapd service won’t start anymore

mt-daapd service won’t start anymore

This topic contains 0 replies, has 1 voice, and was last updated by  Anonymous 7 years, 8 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #2988

    Anonymous

    When I start mt-daapd as a service I always get this avahi error and mt-daapd aborts:

    [[email protected] ~]$ sudo service mt-daapd restart
    Shutting down DAAP server: [ OK ]
    Starting DAAP servermt-daapd: client.c:776: avahi_client_errno: Assertion `client' failed.
    /bin/bash: line 1: 26119 Aborted /usr/sbin/mt-daapd
    [FAILED]

    Mt-daapd runs fine from command line (with or without -f option):

    [[email protected] ~]$ sudo mt-daapd -f -c /etc/mt-daapd.conf
    Starting rendezvous daemon
    Client running
    Current database version: 8
    Starting signal handler
    Loading playlists
    Initializing database
    Starting mp3 scan

    When I run mt-daapd from the command line with -d 9 I can see it rebuild the database and then can successfully access the web server and connection/streaming from an iTunes client. Now I just need to get it to start as a service again…

    Mt-daapd used to daemonize just fine but I recently upgraded from Fedora Core 8 to FC10. Not sure what changed, but I thought it might have to do with order of service startup. At first, I noticed that I had mt-daapd configured to run for runlevels 2-5, whereas avahi was configured to run for runlevels 3-5. That meant that during a normal bootup, mt-daapd would always get started before avahi was running. I assumed this was the problem since the error seemed to indicate that mt-daapd needed avahi to be running. So I changed mt-daapd to also start at runlevels 3-5. This didn’t help, though. I still get the same error.

    I am running mt-daapd-0.2.4.2-4.fc10.x86_64 on a Fedora Core 10 x86_64 system.

    Any ideas?

    Thanks,
    Tim ❓

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.