You are here: Home » Topic » mt-daapd seems to be an ‘incompatible’ server…?

mt-daapd seems to be an ‘incompatible’ server…?

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues mt-daapd seems to be an ‘incompatible’ server…?

This topic contains 6 replies, has 3 voices, and was last updated by  jgoor 11 years, 9 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1095

    jgoor
    Participant

    Hi,
    My M1001 has software 2.7 beta loaded.
    mt-daapd is installed via my Ubuntu repository.
    M1001 sees the server aparrantly, but qualifies it as ‘incompatible’.
    Any ideas…?

    I also tried Slimserver, and this server was reckognized, even the propagated servername, but the M1001 couldn’t connect to it.

    Perhapd these 2 serverproblems are related in some way – I dunno.

    The webradio does work btw…

    Rgds,
    jgoor

    #9131

    fizze
    Participant

    I suppose its a Pinnacle soundbridge, and the version of mt-daapd / firefly you installed is a bit outdated 😉 (0.2.4 perhaps)

    The reason for this is because old versions only act like a iTunes (DAAP) server, which Pinnacle’s units doesnt have a license for. Therefor RCP was introduced. It is present in older versions of firefly, but has to be enabled first. In the latest versions of Firefly RCP and DAAP are enabled by default.

    So the best bet is to install a newer version, preferably from http://nightlies.mt-daapd.org/ since I donno which version is in your Ubuntu rep.

    #9132

    jgoor
    Participant

    You are right – but since I earlier installed the 0.2.4 version, installing the nightly somehow did’t work out. I explicitely had to remove the old binary else the wrong one would start, even after installing the nightly.

    Anyway, here I am, staring at the webconfig page saying things like ‘@[email protected]’ in stead of the old parameters which still reside in /etc/mt-daatd.conf

    Do you have a link to a config howto of the nighlies?

    Thanx!
    jgoor

    P.S.
    And indeed – we’re talking Pinnacle SounBridge here 🙂

    #9133

    CCRDude
    Participant

    Did you remove the config file from the old version as well, or only the old binaries? And since the old one was from the repository, did you remove it through the packet manager, or the “dirty” way by deleting files?

    #9134

    jgoor
    Participant

    I did not remove the old config file – now I have. I used apt for removing but somehow that did not go well.
    But the old config file was not used – so this wil not make any difference.
    I’d like to knowhow to configure the new mt-daapd.

    Cheers,
    jgoor

    #9135

    jgoor
    Participant

    Wait – I removed the config fiel the mt-daapd would not start.
    After re-installation mt-daapd did start and the UI looks very different!
    It seems I’ve been messing things up big time while searching for the Grail of audio streaming. 😉
    I’ll keep you informed..
    Thanks.
    Jgoor

    #9136

    jgoor
    Participant

    Aaahhh. what can I say… I Works!
    Thanx for your support!

    jgoor

Viewing 7 posts - 1 through 7 (of 7 total)

The forum ‘Setup Issues’ is closed to new topics and replies.