You are here: Home » Topic » mt-daapd not working after power out – Debian Etch on NSLU2

mt-daapd not working after power out – Debian Etch on NSLU2

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues mt-daapd not working after power out – Debian Etch on NSLU2

This topic contains 10 replies, has 2 voices, and was last updated by  rpedde 11 years, 8 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1138

    wabe
    Participant

    Had a perfectly working mt-daapd on an NSLU2 running Debian Etch until power was cut a couple of days ago.
    The system works in general as a samba server but I cannot see the music in iTunes any longer nor access the webinterface for mt-daapd
    I’ve tried reinstalling mt-daapd.
    The only thing I’ve noticed is an error message regarding ‘error initializing howl’
    I’ve tried apt-get upgrade and tried resolving packages.
    Any tips on how to proceed?

    #9354

    rpedde
    Participant

    @wabe wrote:

    Had a perfectly working mt-daapd on an NSLU2 running Debian Etch until power was cut a couple of days ago.
    The system works in general as a samba server but I cannot see the music in iTunes any longer nor access the webinterface for mt-daapd
    I’ve tried reinstalling mt-daapd.
    The only thing I’ve noticed is an error message regarding ‘error initializing howl’
    I’ve tried apt-get upgrade and tried resolving packages.
    Any tips on how to proceed?

    Sounds like your howl isn’t running. iirc, it’s called mDNSresponder, so a “/etc/init.dmDNSresponder start” should do it. Then you can start mt-daapd and it should show up.

    #9355

    wabe
    Participant

    Thanks for the reply! I assume you mean “/etc/init.d/mDNSresponder Start”. I ran this command and received “no such file or directory”
    I suppose something got damaged by the power loss. What should I reinstall to fix this?

    #9356

    wabe
    Participant

    Researched this issue further a bit. Found out that mDSresponder is part of a package called avahi. The particular service is called “avahi-daemon”. When trying to start this service manually I get an error message:
    “Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon* avahi-daemon disabled because there is a unicast .local domain”

    I’ve tried to read up on this since I use .local as internal domain name. I’ve tried to change this name to a different one in “hosts” but still receive the same error message after rebooting.

    Anyone knows what’s going on?

    #9357

    rpedde
    Participant

    @wabe wrote:

    Researched this issue further a bit. Found out that mDSresponder is part of a package called avahi. The particular service is called “avahi-daemon”. When trying to start this service manually I get an error message:
    “Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon* avahi-daemon disabled because there is a unicast .local domain”

    I’ve tried to read up on this since I use .local as internal domain name. I’ve tried to change this name to a different one in “hosts” but still receive the same error message after rebooting.

    Anyone knows what’s going on?

    Yep, that’s it. Avahi (in fact, mdns in general) doesn’t work well with a .local domain. It expects that .local is just for mdns, and a *real* domain name. You can change your host name, and fix your dns to not provide answers for .local, and that should make it work.

    #9358

    wabe
    Participant

    and fix your dns to not provide answers for .local, and that should make it work.

    Thanks *rpedde*!!
    How do I “fix the dns”? I’ve managed to change the .local domain in the “hosts” file. What else need changing? Really appreciate your help since I’m no expert in Linux

    #9359

    rpedde
    Participant

    @wabe wrote:

    and fix your dns to not provide answers for .local, and that should make it work.

    Thanks *rpedde*!!
    How do I “fix the dns”? I’ve managed to change the .local domain in the “hosts” file. What else need changing? Really appreciate your help since I’m no expert in Linux

    Hmm… The places I’d look for something called “.local” would be in your /etc hostname, as well as your /etc/hosts.

    What are you using for DNS? Your router/switch? You might look at the web admin on that, and make sure you don’t have a domain name of .local set up on that. Maybe you could use “.network” or something instead. That would play more nicely with the mDNS.

    I think it’s probably wherever your dns server is — my guess would be your firewall/router.

    #9360

    wabe
    Participant

    Still at loss unfortunately. I’ve changed domain suffix at the router to a different one. This system doesn’t use DHCP though. I’ve set the ip manually using a static assignment. I’ve checked that the system indeed reports the new suffix using “uname”.
    Avahi-daemon still reports the .local error however. Any other ideas?

    #9361

    rpedde
    Participant

    @wabe wrote:

    Still at loss unfortunately. I’ve changed domain suffix at the router to a different one. This system doesn’t use DHCP though. I’ve set the ip manually using a static assignment. I’ve checked that the system indeed reports the new suffix using “uname”.
    Avahi-daemon still reports the .local error however. Any other ideas?

    There is a workaround described on the avahi site:

    http://avahi.org/wiki/AvahiAndUnicastDotLocal

    #9362

    wabe
    Participant

    Thanks for the tip! I’ve already changed the domain to *.int* instead of .local but still receive the error-message. Reluctant to change back to .local considering the “best-practice” advice not to use it.
    I’m puzzled about these problems since everything worked fine until power went out. I wonder if this .local behavior of Avahi is a “new feature” that started off by me running “apt-get upgrade”?
    I’ve noticed that mt-daapd is running (ps -Al | mt-daapd shows 3 instances) but pretty useless since it cannot communicate with the outside world.
    Do you know of any forum specificaly aimed at Avahi issues or have any other suggestions on how to proceed?

    #9363

    rpedde
    Participant

    @wabe wrote:

    Thanks for the tip! I’ve already changed the domain to *.int* instead of .local but still receive the error-message. Reluctant to change back to .local considering the “best-practice” advice not to use it.
    I’m puzzled about these problems since everything worked fine until power went out. I wonder if this .local behavior of Avahi is a “new feature” that started off by me running “apt-get upgrade”?
    I’ve noticed that mt-daapd is running (ps -Al | mt-daapd shows 3 instances) but pretty useless since it cannot communicate with the outside world.
    Do you know of any forum specificaly aimed at Avahi issues or have any other suggestions on how to proceed?

    I’d guess the etch startup script is checking for a local unicast zone. You might be able to edit /etc/init.d/avahi (or mDNSresponder, whatever the startup script is called) and disable the check for the unicast zone.

Viewing 11 posts - 1 through 11 (of 11 total)

The forum ‘Setup Issues’ is closed to new topics and replies.