You are here: Home » Topic » mt-daapd not scanning sub directories

mt-daapd not scanning sub directories

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #620
    zdroshnya
    Guest

    Hi all,

    first post here 🙂

    I’ve just set up the mt-daapd server on Unslung 6.8.
    Tried first just some mp3 files, and it went ok. Hearing them now on Rhythmbox.

    The problem is that any sound files on the subdirectories are not added to the library…is that a standard definition that I’ll have to live with, or is there any configuration parameter that one can set up? (found nothing in mt-daapd.conf file…)

    The files are on a WD MyBook 250GB, set up as a root disk on the Disk2 USB port.

    Any help would be greatly appreciated!

    Miguel

    #6530
    rpedde
    Participant

    @zdroshnya wrote:

    Hi all,

    first post here 🙂

    I’ve just set up the mt-daapd server on Unslung 6.8.
    Tried first just some mp3 files, and it went ok. Hearing them now on Rhythmbox.

    The problem is that any sound files on the subdirectories are not added to the library…is that a standard definition that I’ll have to live with, or is there any configuration parameter that one can set up? (found nothing in mt-daapd.conf file…)

    The files are on a WD MyBook 250GB, set up as a root disk on the Disk2 USB port.

    Any help would be greatly appreciated!

    Miguel

    It’s almost certainly permissions. Check to make sure the directories are at least r-x by the user that mt-daapd runs as (nobody).

    – Ron

    #6531
    polak
    Guest

    Yes I had the same problem and changing permissions to rw AND x was required to see the subfolders. Being a linux newbie and not understanding the ‘nobody’ user I went for a+rwx i.e. enabling all users.

    #6532
    polak
    Guest

    Oh, and it took this linux newbie a while to figure out that you need the -R option to change permissions down through the sub-directories of your music folder i.e. you need the following (as root): –

    chmod -R a+rwx /home/user_name/music

    …substituting your username and music path as appropriate and make that a -R not a -r!

    #6533
    zdroshnya
    Guest

    It needed write permissions…even if i don;t really understand why it needs them.

    Thx a lot!
    Miguel

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.