You are here: Home » Topic » make fails at ar

make fails at ar

This topic contains 1 reply, has 1 voice, and was last updated by  rpedde 10 years, 8 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #1206

    simsb

    Hello,
    after running an earlier version [909] installed with ipkg I’m trying to compile 1498. This is on an NSLU2 running OpenSlug so there aren’t any binaries available as far as I can tell?

    The ./configure stage has run ok but make stops with an error from the version of the ar utility on OpenSlug. Any ideas how to get round this one?
    cheers
    Ben


    ar cru .libs/out-daap.a out-daap.o out-daap-proto.o
    BusyBox v1.01 (2006.06.09-14:27+0000) multi-call binary

    Usage: ar [-o] [-v] [-p] [-t] [-x] ARCHIVE FILES

    Extract or list FILES from an ar archive.

    Options:
    -o preserve original dates
    -p extract to stdout
    -t list
    -x extract
    -v verbosely list files processed

    make[3]: *** [out-daap.la] Error 1
    #9677

    rpedde
    Participant

    @simsb wrote:

    Hello,
    after running an earlier version [909] installed with ipkg I’m trying to compile 1498. This is on an NSLU2 running OpenSlug so there aren’t any binaries available as far as I can tell?

    The ./configure stage has run ok but make stops with an error from the version of the ar utility on OpenSlug. Any ideas how to get round this one?
    cheers
    Ben


    ar cru .libs/out-daap.a out-daap.o out-daap-proto.o
    BusyBox v1.01 (2006.06.09-14:27+0000) multi-call binary

    Usage: ar [-o] [-v] [-p] [-t] [-x] ARCHIVE FILES

    Extract or list FILES from an ar archive.

    Options:
    -o preserve original dates
    -p extract to stdout
    -t list
    -x extract
    -v verbosely list files processed

    make[3]: *** [out-daap.la] Error 1

    I think you’ll need the full-on binutils ar, rather than just the busybox one. The busybox one looks to only be able to extract, not create archives.

    — Ron

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.