You are here: Home » Topic » Linkstation Firefly needs Bonjour running on PC

Linkstation Firefly needs Bonjour running on PC

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues Linkstation Firefly needs Bonjour running on PC

This topic contains 4 replies, has 2 voices, and was last updated by  Anonymous 9 years, 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #2646

    Anonymous

    I have installed Firefly svn 1586 on stock V1.11 Linkstation Pro. My Soundbridges will only see the service if I leave Bonjour running on a PC. Is this expected behaviour?
    It defeats the objective of having a music server available without needing to leave a PC always on.
    Router is DLink G624T.
    Thanks.

    #17728

    Anonymous

    I’ve done some reading on Bonjour and mDNS through various forums and articles eg http://en.wikipedia.org/wiki/Bonjour_(software). It seems that the Firefly service simply broadcasting its availabilty is not sufficient for it to be consumed. It requires an mDNS application like Bonjour to resolve its name to be used. So I have answered my own question, yes Bonjour is needed.

    However I believe there are other mDNS apps, the main alternative being Avahi. Is there anyone using this successfully by installing it on the Linkstatsion running Firefly, and if so, which binaries should I download. I’d rather avoid building it if possible, I not a Linux guy.

    On the other hand I may have this totally wrong and would welcome being told so. Thanks.

    #17729

    stretch
    Participant

    Firefly has an mDNS responder built-in. You shouldn’t need Bonjour running on the PC. NSLU2’s & ReadyNAS’ certainly don’t. I have both & I don’t have Bonjour running on my PC.

    Chances are your router, being a D-Link, is not handling multicast properly and your PC is somehow fixing the problem.
    Other D-Link routers don’t work properly with Firefly & I wouldn’t be surprised if all of them had problems.

    Check your router for settings labelled UPnP, IGMP or WMM.

    #17730

    Anonymous

    I thought the modem was the problem originally. Then I found the IGMP snooping switch and the service finally appeared. It doesn’t add up though that the router is still the problem. The firefly service on the LS (wired) is getting through the router to the PC (a wireless laptop) running Bonjour, and the mDNS packets are also getting through the router from the PC to the soundbridges (wireless).

    The uPnP switch is to open up the router itself to uPnP discovery, it is not a passthrough switch.

    I know many others have solved their connection problems with new routers, but its not a certainty. I should probably upgrade the DLink firmware first before spending more money.

    Thanks for the response.

    #17731

    Anonymous

    I’ve now found the cause of the problem. I have a second Linkstation, Live version, and when that is on I need to have Bonjour running on the pc for the soundbridges to see the firefly server on the Linkstation Pro. When the LS Live is off, Bonjour is not needed. Not a router problem.

    I have the LS Live running only 1 day a week to do a LS->LS backup so I can live with this. Strange behaviour though. Pcast is disabled on LS Live.

    EDIT:
    Please disregard the above, bad analysis on my part. I hadn’t realised that although the pc laptop is in sleep mode it is still responding.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.