You are here: Home » Topic » Library no longer visible after upgrade

Library no longer visible after upgrade

This topic contains 6 replies, has 3 voices, and was last updated by  ville 9 years, 7 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #2176

    magnate
    Participant

    Hi folks,

    I just upgraded my server from Debian Etch to Lenny, which means firefly has gone from (roughly) 1376 to 1696.

    The web interface still shows the server running, and all the songs are there, but neither iTunes on my Windows PC nor my Soundbridge can see the library.

    Am I missing something obvious??

    CC

    #16088

    rpedde
    Participant

    @magnate wrote:

    Hi folks,

    I just upgraded my server from Debian Etch to Lenny, which means firefly has gone from (roughly) 1376 to 1696.

    The web interface still shows the server running, and all the songs are there, but neither iTunes on my Windows PC nor my Soundbridge can see the library.

    Am I missing something obvious??

    CC

    Check the status page on the web interface and see if the plugins are loaded. If they aren’t, it’s probably becasue the plugin path changed.

    see where the plugins are on your installation:

    dpkg -L mt-daapd | grep “rsp”

    shoudl show you were the plugins are. In 1376, they were in /usr/lib/mt-daapd/plugins. They probably moved to /usr/lib/mt-daapd or something.

    Check your config file that the plugins/plugin_dir entry matches where the plugins actually are (as determined above)

    — Ron

    #16089

    magnate
    Participant

    @rpedde wrote:

    @magnate wrote:

    Hi folks,

    I just upgraded my server from Debian Etch to Lenny, which means firefly has gone from (roughly) 1376 to 1696.

    The web interface still shows the server running, and all the songs are there, but neither iTunes on my Windows PC nor my Soundbridge can see the library.

    Am I missing something obvious??

    CC

    Check the status page on the web interface and see if the plugins are loaded. If they aren’t, it’s probably becasue the plugin path changed.

    see where the plugins are on your installation:

    dpkg -L mt-daapd | grep “rsp”

    shoudl show you were the plugins are. In 1376, they were in /usr/lib/mt-daapd/plugins. They probably moved to /usr/lib/mt-daapd or something.

    Check your config file that the plugins/plugin_dir entry matches where the plugins actually are (as determined above)

    — Ron

    Three plugins are loaded (all svn1696): daap, rsp and ssc-ffmpeg

    I think these are the same three that were always loaded. Should I be looking for any others? They’re still in /usr/lib/mt-daapd/plugins btw.

    CC

    #16090

    magnate
    Participant

    Found the problem – apologies for the panic.

    During the upgrade, the “dbus” daemon had not been restarted. I don’t know why, but this meant that the avahi-daemon could not restart properly, which meant that although the mt-daapd server was up and running fine, avahi wasn’t broadcasting that fact, so I couldn’t connect to it.

    All sorted with “invoke-rc.d dbus start”.

    Cheers all,

    CC

    #16091

    ville
    Participant

    My Ubuntu upgrade failed yesterday badly and I had to make a clean install. The Ubuntu install itself went smoothly and I quickly had Firefly up and running. Everything seemed to be ok but for some reason Soundbridge did not find my music library.

    Two hours checking, setting, configuring and googling… And then I found this post – voila! Thanks again, magnate!

    #16092

    ville
    Participant

    Hmm… something strange. Today I restart my Ubuntu and same thing again: Soundbridge fails to see my music library. Firefly is running & no errors in the log. I did try to restart mt-daapd but no help.

    However, when I restarted dbus and mt-daapd again, SB found my music lib. What’s going on?

    #16093

    ville
    Participant

    Problem has disappeared. Don’t know why…

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.