You are here: Home » Topic » iTunes Unable to find Shared library

iTunes Unable to find Shared library

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1637
    philo23
    Participant

    I’ve set up my kubuntu 7.04 to run mt-daapd, but how ever it does not show up in iTunes on my two other computers on the network, my macbook and my windows vista machine, Shares are turned on because each machine is also sharing its library to the others, i’ve check to make sure mt-daapd is running by using: ps aux | grep “daap”
    Output:

    nobody   14502  0.0  0.7  27800  2040 pts/2    Sl+  00:07   0:00 mt-daapd -f
    nobody 14503 0.0 0.3 2372 792 pts/2 S 00:07 0:00 mt-daapd -f
    philip 14544 0.0 0.2 2892 764 pts/1 R+ 00:14 0:00 grep daap

    and: ps aux | grep “avahi”
    Output:

    avahi     4778  0.0  0.5   2768  1440 ?        Ss   Aug17   0:00 avahi-daemon: running [server.local]
    avahi 4779 0.0 0.1 2664 456 ? Ss Aug17 0:00 avahi-daemon: chroot helper
    philip 14546 0.0 0.2 2892 768 pts/1 R+ 00:15 0:00 grep avahi

    I’ve had mt-daapd running on the same machine running ubuntu 7.04 before, but it was very picky about starting up.
    Also i didnt download the .deb and install it that way, i compiled it and it passed all the ./configure checks to my knowledge.

    Thanks for any help anyone gives me, its all greatly appreciated.

    #12103
    philo23
    Participant

    i’ve just restarted my music server and i’ve noticed mt-daapd hasnt started at login. just as a note.

    EDIT: but it has shown up in iTunes but when you click on it, it simply goes back to the local music list. Any ideas?

    #12104
    philo23
    Participant

    i’ve check /var/log/messages for anything with mt-daapd in
    i’ve found these lines:

    Aug 17 00:38:54 server mt-daapd[7032]: *** WARNING *** The programme 'mt-daapd' uses the HOWL compatiblity layer of Avahi.
    Aug 17 00:38:54 server mt-daapd[7032]: *** WARNING *** Please fix your application to use the native API of Avahi!
    #12105
    rpedde
    Participant

    @philo23 wrote:

    i’ve check /var/log/messages for anything with mt-daapd in
    i’ve found these lines:

    Aug 17 00:38:54 server mt-daapd[7032]: *** WARNING *** The programme 'mt-daapd' uses the HOWL compatiblity layer of Avahi.
    Aug 17 00:38:54 server mt-daapd[7032]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Any firewall? Can you web to the admin port (3689)?

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.