You are here: Home » Topic » Issues when PC comes out of Standby

Issues when PC comes out of Standby

This topic contains 11 replies, has 3 voices, and was last updated by  macollin 10 years, 11 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #734

    macollin
    Participant

    Apologies for the double post (I posted this with no luck in the Roku forum), but I figured it couldn’t hurt to try a different crowd…

    I am currently running Firefly (but I can also recreate the issue with iTunes) on a Windows XP machine. I typically put my computer in standby mode at night. Once I wake the PC up I go to the soundbridge and start it up. It is able to connect to Firefly. However, the issue I am seeing is one of the following:

    1. Once in firefly the soundbridge is unable to browse any artisits, albums, playlists, etc.
    2. Once in firefly the soundbridge is able to browse. I can start playing a song and after about a minute the song stops and the soundbridge states “Preparing to play…”. It then can’t play that track, so it skips to the next. It can’t play any of the following songs so it skips through all of them. If I then try and go back and browse anything (album, artist, etc) the soundbridge is unable to browse.

    My solution to this is to reboot my router (I am using a DI-624 wirelessly). Once I do this everything works flawlessly. What could the rebooting of my router be doing to rectify this issue? Will the fix for the other standby issues I have read about in the forum fix this issue as well?

    Thanks in advance.[/b]

    #7098

    fizze
    Participant

    the fact that rebooting the rouer fixed everything indicates that its a networking issue.
    did you try to refresh your IP config on the PC?
    try

    ipconfig /release
    ipconfig / renew

    in the windows box.
    I think that maybe you hit a DHCP timeout, and the router does some bogus then. or windows. 😉

    #7099

    macollin
    Participant

    Thanks for the response. I will give this a try when I get home tonight.

    Would I have to run these commands everytime I wakeup the computer from standby? Is there a way to automate that?

    Also, the other thing that I forgot to mention is that the Internet Radio (not through firefly) works flawlessly coming out of standby…but, it works just fine when the PC is sleeping too.

    #7100

    rpedde
    Participant

    @macollin wrote:

    My solution to this is to reboot my router (I am using a DI-624 wirelessly). Once I do this everything works flawlessly. What could the rebooting of my router be doing to rectify this issue? Will the fix for the other standby issues I have read about in the forum fix this issue as well?

    I’m with fizze — that sounds like a dhcp issue.

    Do you have an option in your router to have dhcp reservations? Some routers let you ensure that you always get the same IP address from your machine every time you boot or come out of standby. Might be worth looking at.

    Another thing you could try would be using a static IP address rather than a DHCP address.

    That might get you somewhere, too.

    — Ron

    #7101

    macollin
    Participant

    I believe I am using the DHCP reservations. I have an IP setup for the Soundbridge in something called “Static DHCP Client List”. I have tried adding it to this list and removing from this list with the same result.

    Do you recommend I go one step further and force the static IP with the Soundbridge? Also, doesn’t it seem funky that the Internet Radio piece works fine regardless and that it is just the media server side that seems to hiccuup coming out of standby, or am I missing something?

    Thanks again for the help.

    #7102

    fizze
    Participant

    well, its not the soundbridge, but the PC that should have a static IP as well 😉

    assume that the soundbridge “sees” firefly with IP 1, then the PC goes to hibernate, after it wakes up it gets the IP 7. The soundbridge still “sees” something via multicasts or whatever, but then it gets weird. 😉 🙄

    #7103

    macollin
    Participant

    I see, that makes sense.

    I do have my PC logged in the “Static DHCP Client List” of my router as well.

    So, the other strange thing to me is why does it initially connect to Firefly, play for ~1 minute and then start failing. Is that still representative of a DHCP problem?

    #7104

    fizze
    Participant

    I think so. Well, maybe the router has a problem with hibernation of the PC? *shrug*

    Im out of options here, since I dont have any experience with hibernating windoze.

    btw what router/firmware are you running?

    #7105

    macollin
    Participant

    Thanks for the effort.

    I’m using a D-link DI-624. Not sure of the firm (as I’m at work), but I believe I updated June of this year.

    #7106

    fizze
    Participant

    well, D-Link are generally sucky (imho), netgear are better, while linksys/cisco are the way to go (ymmv)

    #7107

    rpedde
    Participant

    @macollin wrote:

    I see, that makes sense.

    I do have my PC logged in the “Static DHCP Client List” of my router as well.

    So, the other strange thing to me is why does it initially connect to Firefly, play for ~1 minute and then start failing. Is that still representative of a DHCP problem?

    I have absolutely no idea on that one. Do you get any log messages on the server that help? You should see them on the “log” pane of the tray applet.

    — Ron

    #7108

    macollin
    Participant

    The best I can do for a log file right now is this:

    2006-11-02 21:01:23 (a1832be5): Starting with debuglevel 0
    2006-11-02 21:01:24 (a1832be5): Starting rendezvous daemon
    2006-11-02 21:01:24 (a1832be5): Can’t get db version. New database?
    2006-11-02 21:01:24 (a1832be5): Initializing database
    2006-11-02 21:02:59 (33f9b4fb): Session 0: Streaming file ’02 Ponderosa.mp3′ to 192.168.1.4 (offset 0)

    A couple of problems 1) I am unable to recreate unless my PC is in standby for a significant amount of time (e.g. overnight, while I’m at work); 2) I don’t know how to change the debuglevel to a more verbose setting. I saw the comments in the mt-daapd.conf file, but I am still a bit unclear.

    Thanks again.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.